apt-key: Manpage mentions Debian instead of Ubuntu keys

Bug #445903 reported by Florian Diesch
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned
apt (Ubuntu)
Low
Daniel Hahler

Bug Description

Binary package hint: apt

The manpage of apt-key mentions Debian where it should mention Ubuntu:

In the COMMANDS section:

      update
           Update the local keyring with the keyring of Debian archive keys
           and removes from the keyring the archive keys which are no longer
           valid.

"Debian archive keys" should be "Ubuntu archive keys"

In the FILES section:

      /usr/share/keyrings/debian-archive-keyring.gpg
           Keyring of Debian archive trusted keys.

       /usr/share/keyrings/debian-archive-removed-keys.gpg
           Keyring of Debian archive removed trusted keys.

Again "Debian" should be replace by "Ubuntu".

apt:
  Installed: 0.7.20.2ubuntu6
  Candidate: 0.7.20.2ubuntu6
  Version table:
 *** 0.7.20.2ubuntu6 0
        500 http://de.archive.ubuntu.com.de jaunty/main Packages
        100 /var/lib/dpkg/status

apt:
  Installed: 0.7.23.1ubuntu1
  Candidate: 0.7.23.1ubuntu1
  Version table:
 *** 0.7.23.1ubuntu1 0
        500 http://de.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

Related branches

Revision history for this message
Torsten Spindler (tspindler) wrote :

Debian is still mentioned in apt-key in Lucid, confirming this bug.

Changed in apt (Ubuntu):
status: New → Confirmed
Revision history for this message
Victor Vargas (kamus) wrote :

This issue is still valid under Ubuntu Maverick, additionally I have sent an upstream report to Ubuntu Translation team. Thanks

Changed in apt (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Revision history for this message
David Planella (dpm) wrote :

If I understand it correctly, we are talking about a change that needs to be done in the English original text, most likely by a patch. This is nothing that can be solved with translations, thus marking the translations task as Invalid.

If you still think there is a need for a translations task, feel free to reopen.

Changed in ubuntu-translations:
status: New → Invalid
Revision history for this message
Florian Diesch (diesch) wrote : Re: [Bug 445903] Re: apt-key: Manpage mentions Debian instead of Ubuntu keys

David Planella <email address hidden> writes:

> If I understand it correctly, we are talking about a change that needs
> to be done in the English original text, most likely by a patch. This is
> nothing that can be solved with translations, thus marking the
> translations task as Invalid.
>
> If you still think there is a need for a translations task, feel free to
> reopen.

I guess most translations have the same bug as they are translated from
the English text. At least the German translation has it, too.

   Florian
--
How to add files opened in Emacs to GNOME’s recently used document list:
<http://www.florian-diesch.de/doc/emacs/add-to-gnomes-recently-used-documents/>

Robert Roth (evfool)
tags: added: manpage
Revision history for this message
Daniel Hahler (blueyed) wrote :

I will propose the branch to fix this when the P-series opens up - it is apparently too late for Oneiric (string freeze).

Changed in apt (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Daniel Hahler (blueyed)
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (8.0 KiB)

This bug was fixed in the package apt - 0.8.16~exp12ubuntu1

---------------
apt (0.8.16~exp12ubuntu1) precise; urgency=low

  [ Michael Vogt ]
  * merge from debian/experimental:
    - new ABI

  [ Steve Langasek ]
  * apt-pkg/algorithms.cc: iterate Breaks the same way as Conflicts, so that
    we resolve virtual package Breaks more effectively. Thanks to Colin
    Watson for the patch. Closes: #657695, LP: #922485.
  * apt-pkg/algorithms.{cc,h}: use an int to represent resolver scores, not
    a signed short, because large upgrades can result in an overflow for
    core packages. Thanks again to Colin Watson. Closes: #657732,
    LP: #917173.
  * Multi-Arch: none build-deps should be DEB_HOST_ARCH, not DEB_BUILD_ARCH.
    Closes: #646288.

apt (0.8.16~exp12) experimental; urgency=low

  [ Michael Vogt ]
  * apt-pkg/deb/dpkgpm.cc:
    - fix segfault on pkg removal

  [ David Kalnischkies ]
  * apt-pkg/cacheiterators.h:
    - return the correct version arch for all+foreign, too
  * apt-pkg/packagemanager.cc:
    - ignore breaks on not-installed versions while searching for
      breakage loops as we don't have to avoid them
  * debian/control:
    - remove APT from the short descriptions as lintian doesn't like it
      and it doesn't transport any information for a reader anyway
    - apply typofixes by Pascal De Vuyst, thanks! (Closes: #652834, #652835)
  * debian/rules:
    - apply patch to enable usage of hardning CPPFLAGS and LDFLAGS by
      Moritz Muehlenhoff, thanks! (Closes: #653504)
  * methods/https.cc:
    - use curls list append instead of appending Range and If-Range by hand
      which generates malformed requests, thanks Mel Collins for the hint!
      (Closes: #646381)
  * test/libapt/run-tests:
    - hurd doesn't have dmesg yet and we don't really need it either,
      so use with $0 a more stable data source for hashsumming

  [ Pino Toscano ]
  * test/libapt/globalerror_test.cc:
    - errno 0 has a different strerror on hurd, so generate the expected
      message dynamically instead of hardcoding 'Success' (Closes: #656530)

apt (0.8.16~exp11) experimental; urgency=low

  [ David Kalnischkies ]
  * apt-pkg/deb/dpkgpm.cc:
    - redirect out/input of dpkg --assert-multi-arch to /dev/null
    - if multi-arch is detected ensure that pkg:all is reported as pkg:all

apt (0.8.16~exp10) experimental; urgency=low

  [ David Kalnischkies ]
  * apt-pkg/depcache.cc:
    - implicit conflicts (for multiarch) are supposed to conflict
      only with real packages, not with virtual providers
  * apt-pkg/pkgcache.cc:
    - ignore implicit conflicts on providers in AllTarget, too
  * apt-pkg/deb/dpkgpm.cc:
    - check if dpkg supports multiarch with --assert-multi-arch
      and if it does be always explicit about the architecture
  * apt-pkg/contrib/fileutl.h:
    - store the offset in the internal fd before calculate size of
      the zlib-handled file to jump back to this place again

  [ Michael Vogt ]
  * apt-pkg/contrib/fileutl.h:
    - fix segfault triggered by the python-apt testsuite

apt (0.8.16~exp9) experimental; urgency=low

  [ Julian Andres Klode ]
  * apt-pkg/cdrom.cc:
    - Accept .bz2, .xz files in addition to .gz fil...

Read more...

Changed in apt (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers