apt doesn't finish downloading files on 9.04 mini.iso installation

Bug #368178 reported by Sami Olmari on 2009-04-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: apt

First of all, this is propably the infamous "apt race condition" bug, also for person 'mvo', an person called 'cjwatson' sent me here and asked to mention this :) Also I used finnish installation so all menu descriptions might not be word-exact.

So, I'll try to be short:

I use "netboot" or mini.iso installation method for Ubuntu 9.04, mine laptop is IBM t42p. If I choose only to install most basic CLI system and then apt-get install ubuntu-desktop, it downloads (seemingly) every file, apparently libmbca0 last, then there reads [99% working] and it sits there forever (I stopped at overnight).

Then I tried to install "normal way" so that I choose ubuntu-desktop in the installer, it also sat forever on same libmbca0 but this time there didn't read that [99% working], (propably because installer have been choosed to supress any additional messages). Then I pressed esc to get into installers main menu, then I choosed again "choose programs to be installed" or to that effect, there was ubuntu-desktop already chosed and then I clicked next and rest of installation went smoothly... Apparently this time apt doesn't download anything, but has everything already downloaded, including libmbca0. This happened 3 times in the row on exact same spot until I figured out how to get around it (as I heard this is an rarely occurring hard-to-repeat bug).

If anyone want's to try squash this bug I can offer any assistance I can do.

Michael Vogt (mvo) wrote :

Thanks a lot for comming here.

I'm the person "mvo" and I would love to diagnose this further, I was so far unable to reporduce it in a reliable way. Can you reproduce this in the install only or on a installed system as well? If on a installed system, please
run:
$ sudo apt-get -o Debug::pkgAcquire=true dist-upgrade --download-only 2> /tmp/lala
and attach that file?

Changed in apt (Ubuntu):
importance: Undecided → High
status: New → In Progress
Sami Olmari (olmari) wrote :

Well I try ASAP to do total reinstallation and hope it will occur again...

"Can you reproduce this in the install only or on a installed system as well?"

Well it did happend each and everytime on mine system until I figured the way around it.. So it did happend on installed system as well... I'll try gain to install an "bare" system and then apt-get install ubuntu-desktop to some file let's go from there?

So what I should run in this case would be:

$ sudo apt-get -o Debug::pkgAcquire=true install ubuntu-desktop --download-only 2> /tmp/asdf ?

As I can install the bare system but never full desktop no matter do I try to install it directly form setup nor as trough apt-get ...

Sami Olmari (olmari) wrote :

Well... It didn't jam now no matter what I tried... Seems to be the dreaded "symptom" of this bug...

I wonder could there be any possibility for me to get custom download server that would mirror exactly the packages from 23th of april? In other word the first stuff that was released in 9.04 final, before anything was changed... Then I could define that as mine download server manually in the installer and see would this happend again... As back then it happened each and every time, no matter how I tried to install "ubuntu-desktop".

Changed in apt (Ubuntu):
status: In Progress → Fix Committed
assignee: nobody → artur bryczek (arturbryczek)
Changed in apt (Ubuntu):
status: Fix Committed → New
assignee: artur bryczek (arturbryczek) → nobody

Changed to Invalid as Ubuntu 9.04 is no longer supported.

Changed in apt (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers