package libgtk2.0-bin 2.14.4-0ubuntu2 failed to install/upgrade: package libgtk2.0-bin is already installed and configured

Bug #322955 reported by DamianBailey
8
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Fix Released
Medium
Michael Vogt
Jaunty
Fix Released
Medium
Michael Vogt

Bug Description

After receiving previous error about libxine when installing udates I attempted to use the add/remove applications option to remove any "xine" related apps. Which failed with a few errors. This was the second.

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 8.10
ErrorMessage: package libgtk2.0-bin is already installed and configured
NonfreeKernelModules: nvidia
Package: libgtk2.0-bin 2.14.4-0ubuntu2
PackageArchitecture: all
SourcePackage: gtk+2.0
Title: package libgtk2.0-bin 2.14.4-0ubuntu2 failed to install/upgrade: package libgtk2.0-bin is already installed and configured
Uname: Linux 2.6.27-11-generic i686

Revision history for this message
DamianBailey (damian-bailey) wrote :
Revision history for this message
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Unpacking replacement rhythmbox ...^M
Processing triggers for hal ...^M
Regenerating hal fdi cache ...^M
 * Restarting Hardware abstraction layer hald^M
   ...done.^M
Processing triggers for man-db ...^M
Processing triggers for gxine ...^M
Segmentation fault^M
dpkg: subprocess post-installation script returned error exit status 139^M
Log ended: 2009-01-29 22:16:21

Log started: 2009-01-29 22:35:32
dpkg: error processing libxine1-bin (--configure):^M
 package libxine1-bin is not ready for configuration^M
 cannot configure (current status `triggers-awaited')^M
Log ended: 2009-01-29 22:35:32

This looks like there is a issue in dpkg/apt interaction with triggers - I look into it

Changed in gtk+2.0:
assignee: nobody → mvo
importance: Undecided → Medium
milestone: none → jaunty-alpha-4
status: New → Triaged
Revision history for this message
Michael Vogt (mvo) wrote :

I think the issue is that apt does not drive dpkg with the right options if the dpkg state is in pending-triggers state.

Michael Vogt (mvo)
Changed in apt:
milestone: jaunty-alpha-4 → jaunty-alpha-5
Revision history for this message
Steve Langasek (vorlon) wrote :

Damian,

Can you please provide the output of "ls /usr/lib/xine/plugins/1.24/" on the affected system?

Revision history for this message
Steve Langasek (vorlon) wrote :

correction: please provide the output of "ls /usr/lib/xine/plugins/*".

Revision history for this message
jamesh (jameshugman) wrote :

james@silverback:~$ ls /usr/lib/xine/plugins/*
post xineplug_dmx_mpeg.so
xineplug_ao_out_alsa.so xineplug_dmx_mpeg_ts.so
xineplug_ao_out_file.so xineplug_dmx_nsv.so
xineplug_ao_out_none.so xineplug_dmx_ogg.so
xineplug_ao_out_oss.so xineplug_dmx_pva.so
xineplug_ao_out_pulseaudio.so xineplug_dmx_qt.so
xineplug_decode_a52.so xineplug_dmx_rawdv.so
xineplug_decode_bitplane.so xineplug_dmx_real.so
xineplug_decode_dts.so xineplug_dmx_slave.so
xineplug_decode_dvaudio.so xineplug_dmx_sputext.so
xineplug_decode_dxr3_spu.so xineplug_dmx_yuv4mpeg2.so
xineplug_decode_dxr3_video.so xineplug_dmx_yuv_frames.so
xineplug_decode_faad.so xineplug_flac.so
xineplug_decode_ff.so xineplug_inp_cdda.so
xineplug_decode_gsm610.so xineplug_inp_dvb.so
xineplug_decode_image.so xineplug_inp_dvd.so
xineplug_decode_lpcm.so xineplug_inp_file.so
xineplug_decode_mad.so xineplug_inp_http.so
xineplug_decode_mpc.so xineplug_inp_mms.so
xineplug_decode_mpeg2.so xineplug_inp_net.so
xineplug_decode_qt.so xineplug_inp_pnm.so
xineplug_decode_real.so xineplug_inp_pvr.so
xineplug_decode_rgb.so xineplug_inp_rtp.so
xineplug_decode_speex.so xineplug_inp_rtsp.so
xineplug_decode_spucc.so xineplug_inp_smb.so
xineplug_decode_spucmml.so xineplug_inp_stdin_fifo.so
xineplug_decode_spudvb.so xineplug_inp_v4l.so
xineplug_decode_spu.so xineplug_inp_vcdo.so
xineplug_decode_sputext.so xineplug_inp_vcd.so
xineplug_decode_theora.so xineplug_vo_out_aa.so
xineplug_decode_vorbis.so xineplug_vo_out_caca.so
xineplug_decode_w32dll.so xineplug_vo_out_directfb.so
xineplug_decode_yuv.so xineplug_vo_out_dxr3.so
xineplug_dmx_asf.so xineplug_vo_out_fb.so
xineplug_dmx_audio.so xineplug_vo_out_none.so
xineplug_dmx_avi.so xineplug_vo_out_opengl.so
xineplug_dmx_fli.so xineplug_vo_out_sdl.so
xineplug_dmx_flv.so xineplug_vo_out_syncfb.so
xineplug_dmx_games.so xineplug_vo_out_xcbshm.so
xineplug_dmx_iff.so xineplug_vo_out_xcbxv.so
xineplug_dmx_image.so xineplug_vo_out_xdirectfb.so
xineplug_dmx_matroska.so xineplug_vo_out_xshm.so
xineplug_dmx_mng.so xineplug_vo_out_xvmc.so
xineplug_dmx_mpeg_block.so xineplug_vo_out_xv.so
xineplug_dmx_mpeg_elem.so xineplug_vo_out_xxmc.so
xineplug_dmx_mpeg_pes.so xineplug_wavpack.so
james@silverback:~$ ls /usr/lib/xine/plugins/* | wc -w
92

Revision history for this message
DamianBailey (damian-bailey) wrote : Re: [Bug 322955] Re: package libgtk2.0-bin 2.14.4-0ubuntu2 failed to install/upgrade: package libgtk2.0-bin is already installed and configured

Steve Langasek wrote:
> Damian,
>
> Can you please provide the output of "ls /usr/lib/xine/plugins/1.24/" on
> the affected system?
>
>
Output as follows:

post xineplug_dmx_mpeg.so
xineplug_ao_out_alsa.so xineplug_dmx_mpeg_ts.so
xineplug_ao_out_esd.so xineplug_dmx_nsv.so
xineplug_ao_out_file.so xineplug_dmx_ogg.so
xineplug_ao_out_none.so xineplug_dmx_pva.so
xineplug_ao_out_oss.so xineplug_dmx_qt.so
xineplug_ao_out_pulseaudio.so xineplug_dmx_rawdv.so
xineplug_decode_a52.so xineplug_dmx_real.so
xineplug_decode_bitplane.so xineplug_dmx_slave.so
xineplug_decode_dts.so xineplug_dmx_sputext.so
xineplug_decode_dvaudio.so xineplug_dmx_yuv4mpeg2.so
xineplug_decode_dxr3_spu.so xineplug_dmx_yuv_frames.so
xineplug_decode_dxr3_video.so xineplug_flac.so
xineplug_decode_faad.so xineplug_inp_cdda.so
xineplug_decode_ff.so xineplug_inp_dvb.so
xineplug_decode_gdk_pixbuf.so xineplug_inp_dvd.so
xineplug_decode_gsm610.so xineplug_inp_file.so
xineplug_decode_image.so xineplug_inp_gnome_vfs.so
xineplug_decode_lpcm.so xineplug_inp_http.so
xineplug_decode_mad.so xineplug_inp_mms.so
xineplug_decode_mpc.so xineplug_inp_net.so
xineplug_decode_mpeg2.so xineplug_inp_pnm.so
xineplug_decode_qt.so xineplug_inp_pvr.so
xineplug_decode_real.so xineplug_inp_rtp.so
xineplug_decode_rgb.so xineplug_inp_rtsp.so
xineplug_decode_speex.so xineplug_inp_smb.so
xineplug_decode_spucc.so xineplug_inp_stdin_fifo.so
xineplug_decode_spucmml.so xineplug_inp_v4l.so
xineplug_decode_spudvb.so xineplug_inp_vcdo.so
xineplug_decode_spu.so xineplug_inp_vcd.so
xineplug_decode_sputext.so xineplug_vo_out_aa.so
xineplug_decode_theora.so xineplug_vo_out_caca.so
xineplug_decode_vorbis.so xineplug_vo_out_directfb.so
xineplug_decode_w32dll.so xineplug_vo_out_dxr3.so
xineplug_decode_yuv.so xineplug_vo_out_fb.so
xineplug_dmx_asf.so xineplug_vo_out_none.so
xineplug_dmx_audio.so xineplug_vo_out_opengl.so
xineplug_dmx_avi.so xineplug_vo_out_sdl.so
xineplug_dmx_fli.so xineplug_vo_out_syncfb.so
xineplug_dmx_flv.so xineplug_vo_out_xcbshm.so
xineplug_dmx_games.so xineplug_vo_out_xcbxv.so
xineplug_dmx_iff.so xineplug_vo_out_xdirectfb.so
xineplug_dmx_image.so xineplug_vo_out_xshm.so
xineplug_dmx_matroska.so xineplug_vo_out_xvmc.so
xineplug_dmx_mng.so xineplug_vo_out_xv.so
xineplug_dmx_mpeg_block.so xineplug_vo_out_xxmc.so
xineplug_dmx_mpeg_elem.so xineplug_wavpack.so
xineplug_dmx_mpeg_pes.so

Regards

Damian

_________________________________________________________________
Check out the new and improved services from Windows Live. Learn more!
http://clk.atdmt.com/UKM/go/132630768/direct/01/

Revision history for this message
DamianBailey (damian-bailey) wrote :

Steve Langasek wrote:
> correction: please provide the output of "ls /usr/lib/xine/plugins/*".
>
>

Corrected output as follows:

post xineplug_dmx_mpeg.so
xineplug_ao_out_alsa.so xineplug_dmx_mpeg_ts.so
xineplug_ao_out_esd.so xineplug_dmx_nsv.so
xineplug_ao_out_file.so xineplug_dmx_ogg.so
xineplug_ao_out_none.so xineplug_dmx_pva.so
xineplug_ao_out_oss.so xineplug_dmx_qt.so
xineplug_ao_out_pulseaudio.so xineplug_dmx_rawdv.so
xineplug_decode_a52.so xineplug_dmx_real.so
xineplug_decode_bitplane.so xineplug_dmx_slave.so
xineplug_decode_dts.so xineplug_dmx_sputext.so
xineplug_decode_dvaudio.so xineplug_dmx_yuv4mpeg2.so
xineplug_decode_dxr3_spu.so xineplug_dmx_yuv_frames.so
xineplug_decode_dxr3_video.so xineplug_flac.so
xineplug_decode_faad.so xineplug_inp_cdda.so
xineplug_decode_ff.so xineplug_inp_dvb.so
xineplug_decode_gdk_pixbuf.so xineplug_inp_dvd.so
xineplug_decode_gsm610.so xineplug_inp_file.so
xineplug_decode_image.so xineplug_inp_gnome_vfs.so
xineplug_decode_lpcm.so xineplug_inp_http.so
xineplug_decode_mad.so xineplug_inp_mms.so
xineplug_decode_mpc.so xineplug_inp_net.so
xineplug_decode_mpeg2.so xineplug_inp_pnm.so
xineplug_decode_qt.so xineplug_inp_pvr.so
xineplug_decode_real.so xineplug_inp_rtp.so
xineplug_decode_rgb.so xineplug_inp_rtsp.so
xineplug_decode_speex.so xineplug_inp_smb.so
xineplug_decode_spucc.so xineplug_inp_stdin_fifo.so
xineplug_decode_spucmml.so xineplug_inp_v4l.so
xineplug_decode_spudvb.so xineplug_inp_vcdo.so
xineplug_decode_spu.so xineplug_inp_vcd.so
xineplug_decode_sputext.so xineplug_vo_out_aa.so
xineplug_decode_theora.so xineplug_vo_out_caca.so
xineplug_decode_vorbis.so xineplug_vo_out_directfb.so
xineplug_decode_w32dll.so xineplug_vo_out_dxr3.so
xineplug_decode_yuv.so xineplug_vo_out_fb.so
xineplug_dmx_asf.so xineplug_vo_out_none.so
xineplug_dmx_audio.so xineplug_vo_out_opengl.so
xineplug_dmx_avi.so xineplug_vo_out_sdl.so
xineplug_dmx_fli.so xineplug_vo_out_syncfb.so
xineplug_dmx_flv.so xineplug_vo_out_xcbshm.so
xineplug_dmx_games.so xineplug_vo_out_xcbxv.so
xineplug_dmx_iff.so xineplug_vo_out_xdirectfb.so
xineplug_dmx_image.so xineplug_vo_out_xshm.so
xineplug_dmx_matroska.so xineplug_vo_out_xvmc.so
xineplug_dmx_mng.so xineplug_vo_out_xv.so
xineplug_dmx_mpeg_block.so xineplug_vo_out_xxmc.so
xineplug_dmx_mpeg_elem.so xineplug_wavpack.so
xineplug_dmx_mpeg_pes.so

Regards

Damian

_________________________________________________________________
Twice the fun—Share photos while you chat with Windows Live Messenger. Learn more.
http://www.microsoft.com/uk/windows/windowslive/products/messenger.aspx

Revision history for this message
ibmblauw (jos-marlet) wrote : Re: [Bug 322955] Re: package libgtk2.0-bin 2.14.4-0ubuntu2 failed to install/upgrade: package libgtk2.0-bin is already installed and configured

Probleem opgelost dank zij U

groetjes en mijn dank daarvoor

Jos Marlet

2009/2/4 Michael Vogt <email address hidden>:
> *** This bug is a duplicate of bug 323073 ***
> https://bugs.launchpad.net/bugs/323073
>
> ** This bug has been marked a duplicate of bug 323073
> package libgtk2.0-dev 2.14.4-0ubuntu2 failed to install/upgrade: paketet libgtk2.0-dev är inte redo för att konfigureras
>
> --
> package libgtk2.0-bin 2.14.4-0ubuntu2 failed to install/upgrade: package libgtk2.0-bin is already installed and configured
> https://bugs.launchpad.net/bugs/322955
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (via bug 323073).
>

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.7.20.2ubuntu1

---------------
apt (0.7.20.2ubuntu1) jaunty; urgency=low

  [ Christian Perrier ]
  * Translations:
    - bg.po. Closes: #513211
    - zh_TW.po. Closes: #513311
    - nb.po. Closes: #513843

  [ Michael Vogt ]
  * merged from the debian-sid branch
  * [ABI break] merge support for http redirects, thanks to
    Jeff Licquia and Anthony Towns
  * [ABI break] use int for the package IDs (thanks to Steve Cotton)
  * apt-pkg/contrib/strutl.cc:
    - fix TimeToStr i18n (LP: #289807)
  * debian/apt.conf.autoremove:
    - readd "linux-image" (and friends) to the auto-remove
     blacklist
  * fix some i18n issues (thanks to Gabor Kelemen)
    LP: #263089
  * apt-pkg/deb/dpkgpm.cc:
    - filter "ENOMEM" errors when creating apport reports
  * cmdline/apt-get.cc:
    - fix "apt-get source pkg=ver" if binary name != source name
      (LP: #202219)
  * apt-pkg/indexrecords.cc:
    - fix some i18n issues
  * apt-pkg/contrib/strutl.h:
    - add new strprintf() function to make i18n strings easier
  * apt-pkg/dev/debsystem.cc:
    - add missing apti18n.h header
  * cmdline/apt-get.cc:
    - default to "false" for the "APT::Get::Build-Dep-Automatic"
      option (follow debian here)
  * apt-pkg/pkgcache.cc:
    - do not run "dpkg --configure pkg" if pkg is in trigger-awaited
      state (LP: #322955)
  * methods/https.cc:
    - add Acquire::https::AllowRedirect support
    - do not unlink files in partial/ (thanks to robbiew)

  [ Dereck Wonnacott ]
  * Clarify the --help for 'purge' (LP: #243948)

  [ Ian Weisser ]
  * /apt-pkg/deb/debsystem.cc:
    - add 'sudo' to the error message to "run 'dpkg --configure -a'"
      (LP: #52697)

 -- Michael Vogt <email address hidden> Mon, 09 Feb 2009 14:21:05 +0100

Changed in apt:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers