"The following additional packages will be installed" and "The following NEW packages will be installed"

Bug #1887574 reported by teo1978

This bug report was converted into a question: question #691872: "The following additional packages will be installed" and "The following NEW packages will be installed".

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Undecided
Unassigned

Bug Description

I did:

  $ sudo apt-get install cinnamon-desktop-environment

I attach the complete output below.

There are two blocks among others:

  The following additional packages will be installed:
  (....)
  The following NEW packages will be installed:
  (....)

The two lists massively overlap, though they are not exactly identical.

The phrasing is ambiguous to start with: even if the two lists didn't overlap at all, I would be quite confused by this message, because it's not clear what the difference is supposed to be between "additional" packages that are going to be installed and "NEW" packages that are going to be installed. That alone is an issue.

But the fact that the two lists are almost (but not quite) identical, makes me wonder whether something is wrong, like a duplicate source or something. If that was the case, there should be a warning clarifying it. If all is ok, then again, the phrasing is deficient.

$ sudo apt-get install cinnamon-desktop-environment
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  at gcc-9-base:i386 gir1.2-geocodeglib-1.0 gir1.2-mutter-2 gnome-software-common libaio1 libargon2-0 libatk1.0-0:i386 libavahi-common-data:i386 libavresample3
  libavutil-ffmpeg54 libavutil55 libbcprov-java libboost-date-time1.65.1 libboost-filesystem1.65.1 libboost-iostreams1.65.1 libboost-locale1.65.1
  libboost-program-options1.67.0 libboost-python1.65.1 libboost-regex1.65.1 libboost-signals1.65.1 libboost-system1.65.1 libboost-thread1.65.1 libbrlapi0.6 libcamel-1.2-61
  libcdio17 libcommons-lang3-java libdatrie1:i386 libdns1104 libevent-2.1-6 libevent-core-2.1-6 libffi6:i386 libfl2 libfluidsynth1 libfprint0 libfribidi0:i386 libgcc-8-dev
  libgeos-3.6.2 libgeos-3.7.2 libgeotiff2 libgl1-mesa-glx:i386 libgmime-3.0-0 libgnome-desktop-3-17 libgraphite2-3:i386 libharfbuzz0b:i386 libhunspell-1.6-0 libidn11:i386
  libip6tc0 libiptc0 libisc-export169 libisc1100 libisc1105 libisccc161 libjs-inherits libkeyutils1:i386 libkyotocabinet16v5 liblivemedia64 libllvm9 liblouis14 liblouis17
  liblouisutdml8 liblwres161 libmagickcore-6.q16-3 libmicrodns0 libmng2:i386 libmutter-2-0 libmypaint-1.3-0 libmysqlclient20 libnet1 libnfs12 libomp5 libomp5-10
  libopencv-core3.2 libopencv-ml3.2 libopenjpeg5 libopenobex2 liborcus-0.13-0 libpackagekit-glib2-16 libpango-1.0-0:i386 libpangox-1.0-0 libplacebo4 libpostproc54
  libprocps6 libproj13 libpython3.7-minimal libqpdf21 libqscintilla2-qt5-l10n libqt5script5 libreoffice-avmedia-backend-gstreamer libreoffice-style-galaxy libruby2.5
  libshiboken1.2v5 libshiboken2-5.11 libspeexdsp1:i386 libssl1.0-dev libssl1.0.0:i386 libstdc++-7-dev libswresample-ffmpeg1 libtalloc2:i386 libtevent0:i386 libthai0:i386
  libusbmuxd4 libuv1-dev libva1 libvpx3 libvpx5 libwireshark12 libwiretap9 libwscodecs2 libwsutil10 libx265-146 libx265-79 libx86emu1 libxcb-dri2-0-dev libxcb-dri3-dev
  libxcb-glx0-dev libxcb-randr0-dev libxcb-sync-dev libxft2:i386 libxshmfence-dev libxt6:i386 libxv1:i386 node-abbrev node-ansi-regex node-aproba node-aws4 node-builtins
  node-call-limit node-camelcase node-chownr node-color-name node-concat-map node-cookie-jar node-core-util-is node-decamelize node-delegates node-editor node-extsprintf
  node-fast-deep-equal node-har-schema node-has-flag node-has-symbol-support-x node-has-to-string-tag-x node-has-unicode node-hosted-git-info node-iferr node-invert-kv
  node-is-object node-is-plain-obj node-is-retry-allowed node-is-stream node-isstream node-json-schema node-json-stringify-safe node-jsonparse node-lcid node-lockfile
  node-mime node-nopt node-opener node-path-is-inside node-process-nextick-args node-promise-inflight node-pseudomap node-punycode node-qs node-qw
  node-require-main-filename node-retry node-safe-buffer node-semver node-semver-diff node-signal-exit node-slash node-slide node-sorted-object node-spdx-license-ids
  node-string-decoder node-strip-json-comments node-text-table node-tunnel-agent node-uid-number node-unpipe node-uuid node-validate-npm-package-name node-wrappy
  node-xtend pastebinit pax python-certifi python-constantly python-dateutil python-idna python-pyasn1 python-simplejson python3-asn1crypto python3-pycurl
  python3-zope.interface qtdeclarative5-qtquick2-plugin ruby2.5 ruby2.5-dev ruby2.5-doc unity-scope-devhelp unity-scope-manpages unity-scope-tomboy unity-scope-yelp
  x11proto-composite-dev
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  blueman cinnamon cinnamon-common cinnamon-control-center cinnamon-control-center-data cinnamon-control-center-goa cinnamon-core cinnamon-screensaver cinnamon-session
  cinnamon-session-common cinnamon-settings-daemon cjs desktop-base fig2dev five-or-more fonts-noto fonts-noto-cjk-extra fonts-noto-core fonts-noto-extra
  fonts-noto-ui-core fonts-noto-ui-extra fonts-noto-unhinted fonts-quicksand four-in-a-row gedit-plugin-bookmarks gedit-plugin-bracket-completion
  gedit-plugin-character-map gedit-plugin-code-comment gedit-plugin-color-picker gedit-plugin-color-schemer gedit-plugin-commander gedit-plugin-draw-spaces
  gedit-plugin-find-in-files gedit-plugin-git gedit-plugin-join-lines gedit-plugin-multi-edit gedit-plugin-session-saver gedit-plugin-smart-spaces gedit-plugin-synctex
  gedit-plugin-terminal gedit-plugin-translate gedit-plugin-word-completion gedit-plugins gedit-plugins-common gir1.2-caribou-1.0 gir1.2-cinnamondesktop-3.0
  gir1.2-clutter-1.0 gir1.2-cmenu-3.0 gir1.2-cogl-1.0 gir1.2-coglpango-1.0 gir1.2-cvc-1.0 gir1.2-ggit-1.0 gir1.2-gkbd-3.0 gir1.2-gtkclutter-1.0 gir1.2-gucharmap-2.90
  gir1.2-keybinder-3.0 gir1.2-meta-muffin-0.0 gir1.2-nemo-3.0 gir1.2-timezonemap-1.0 gir1.2-xapp-1.0 gir1.2-xkl-1.0 gnome-backgrounds gnome-chess gnome-games gnome-klotski
  gnome-nibbles gnome-robots gnome-sound-recorder gnome-taquin gnome-tetravex gnote gtk2-engines hexchat hexchat-common hexchat-perl hexchat-plugins hexchat-python3 hitori
  hoichess iagno inkscape iso-flags-png-320x240 libcacard0 libcaribou-common libcaribou0 libcinnamon-control-center1 libcinnamon-menu-3-0 libcjs0 libcscreensaver0 libcvc0
  libdiscid0 libfreerdp2-2 libgit2-28 libgit2-glib-1.0-0 libgsl23 libgslcblas0 libgtk-vnc-2.0-0 libgtkmm-2.4-1v5 libgtkspell0 libgvnc-1.0-0 libhttp-parser2.9
  libimage-magick-perl libimage-magick-q16-perl libkeybinder-3.0-0 libmanette-0.2-0 libmbedcrypto3 libmbedtls12 libmbedx509-0 libmuffin0 libmusicbrainz5-2
  libmusicbrainz5cc2v5 libphodav-2.0-0 libphodav-2.0-common libspice-client-glib-2.0-8 libspice-client-gtk-3.0-5 libusbredirhost1 libusbredirparser1 libwinpr2-2 libwmf-bin
  lightsoff mate-icon-theme mate-themes muffin muffin-common python-numpy python3-pampy python3-psutil python3-pyinotify python3-setproctitle python3-tinycss python3-xapp
  python3-xlib quadrapassel simple-scan sound-juicer spice-client-glib-usb-acl-helper swell-foop tali transmission-gtk vinagre
Suggested packages:
  cinnamon-doc python3-opencv tracker-gui | gnome-search-tool gnome | kde-standard | xfce4 | wmaker xfig bbchess crafty fairymax fruit glaurung gnuchess phalanx sjeng
  stockfish toga2 hexchat-otr unifont dia inkscape-tutorials libsvg-perl libxml-xql-perl pstoedit python-uniconvertor freerdp2-x11 gsl-ref-psdoc | gsl-doc-pdf
  | gsl-doc-info | gsl-ref-html imagemagick-doc python-dev python-pytest python-numpy-dbg python-numpy-doc python-psutil-doc python-pyinotify-doc python-tinycss-doc
  gstreamer1.0-lame gstreamer1.0-plugins-really-bad
Recommended packages:
  python-scour
The following NEW packages will be installed:
  blueman cinnamon cinnamon-common cinnamon-control-center cinnamon-control-center-data cinnamon-control-center-goa cinnamon-core cinnamon-desktop-environment
  cinnamon-screensaver cinnamon-session cinnamon-session-common cinnamon-settings-daemon cjs desktop-base fig2dev five-or-more fonts-noto fonts-noto-cjk-extra
  fonts-noto-core fonts-noto-extra fonts-noto-ui-core fonts-noto-ui-extra fonts-noto-unhinted fonts-quicksand four-in-a-row gedit-plugin-bookmarks
  gedit-plugin-bracket-completion gedit-plugin-character-map gedit-plugin-code-comment gedit-plugin-color-picker gedit-plugin-color-schemer gedit-plugin-commander
  gedit-plugin-draw-spaces gedit-plugin-find-in-files gedit-plugin-git gedit-plugin-join-lines gedit-plugin-multi-edit gedit-plugin-session-saver gedit-plugin-smart-spaces
  gedit-plugin-synctex gedit-plugin-terminal gedit-plugin-translate gedit-plugin-word-completion gedit-plugins gedit-plugins-common gir1.2-caribou-1.0
  gir1.2-cinnamondesktop-3.0 gir1.2-clutter-1.0 gir1.2-cmenu-3.0 gir1.2-cogl-1.0 gir1.2-coglpango-1.0 gir1.2-cvc-1.0 gir1.2-ggit-1.0 gir1.2-gkbd-3.0 gir1.2-gtkclutter-1.0
  gir1.2-gucharmap-2.90 gir1.2-keybinder-3.0 gir1.2-meta-muffin-0.0 gir1.2-nemo-3.0 gir1.2-timezonemap-1.0 gir1.2-xapp-1.0 gir1.2-xkl-1.0 gnome-backgrounds gnome-chess
  gnome-games gnome-klotski gnome-nibbles gnome-robots gnome-sound-recorder gnome-taquin gnome-tetravex gnote gtk2-engines hexchat hexchat-common hexchat-perl
  hexchat-plugins hexchat-python3 hitori hoichess iagno inkscape iso-flags-png-320x240 libcacard0 libcaribou-common libcaribou0 libcinnamon-control-center1
  libcinnamon-menu-3-0 libcjs0 libcscreensaver0 libcvc0 libdiscid0 libfreerdp2-2 libgit2-28 libgit2-glib-1.0-0 libgsl23 libgslcblas0 libgtk-vnc-2.0-0 libgtkmm-2.4-1v5
  libgtkspell0 libgvnc-1.0-0 libhttp-parser2.9 libimage-magick-perl libimage-magick-q16-perl libkeybinder-3.0-0 libmanette-0.2-0 libmbedcrypto3 libmbedtls12 libmbedx509-0
  libmuffin0 libmusicbrainz5-2 libmusicbrainz5cc2v5 libphodav-2.0-0 libphodav-2.0-common libspice-client-glib-2.0-8 libspice-client-gtk-3.0-5 libusbredirhost1
  libusbredirparser1 libwinpr2-2 libwmf-bin lightsoff mate-icon-theme mate-themes muffin muffin-common python-numpy python3-pampy python3-psutil python3-pyinotify
  python3-setproctitle python3-tinycss python3-xapp python3-xlib quadrapassel simple-scan sound-juicer spice-client-glib-usb-acl-helper swell-foop tali transmission-gtk
  vinagre
0 upgraded, 141 newly installed, 0 to remove and 3 not upgraded.
Need to get 350 MB of archives.
After this operation, 1.070 MB of additional disk space will be used.
Do you want to continue? [Y/n] n

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: apt 2.0.2ubuntu0.1
ProcVersionSignature: Ubuntu 5.4.0-40.44-generic 5.4.44
Uname: Linux 5.4.0-40-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.20.11-0ubuntu27.3
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Tue Jul 14 22:04:53 2020
InstallationDate: Installed on 2013-10-11 (2468 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
SourcePackage: apt
UpgradeStatus: Upgraded to focal on 2020-07-12 (2 days ago)

Revision history for this message
teo1978 (teo8976) wrote :
Revision history for this message
Daniel Letzeisen (dtl131) wrote :

User is not familiar with apt conventions.

Changed in apt (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers