apt 1.9.6 regression

Bug #1859952 reported by Julian Andres Klode on 2020-01-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Critical
Julian Andres Klode

Bug Description

APT 1.9.6 introduced empty groups by making use of groups to
deduplicate package names.

This caused a problem in NewProvidesAllArch because automake was providing automake-1.16
while having the source package automake-1.16. So we found the
automake-1.16 group, iterated over its empty package list, trying
to store the provides (which hence never happened).

Changed in apt (Ubuntu):
assignee: nobody → Julian Andres Klode (juliank)
Julian Andres Klode (juliank) wrote :

Fixed in 1.9.7, will sync later.

Changed in apt (Ubuntu):
status: In Progress → Fix Committed
tags: removed: block-proposed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 1.9.7

---------------
apt (1.9.7) experimental; urgency=medium

  * Trim trailing whitespace (thanks lintian-brush)
  * NewProvidesAllArch: Check if group is empty before using it.
    This caused automake-1.16 to not be provided by automake anymore,
    because apt wanted to add provides to packages in an empty automake-1.16
    group. LP: #1859952
  * Fix debian-rules-uses-deprecated-systemd-override.
    We accidentally managed to restart apt-daily{,-upgrade}.service
    again because our dh_systemd_start override was being ignored
    since we switched to debhelper 12. Override dh_installsystemd
    instead.

 -- Julian Andres Klode <email address hidden> Thu, 16 Jan 2020 12:13:50 +0100

Changed in apt (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers