Nvidia driver leads to black screen on bionic 18.04 SDDM LightDM bug?

Bug #1765923 reported by Hontas Farmer
This bug affects 8 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
nvidia-graphics-drivers-390 (Ubuntu)
sddm (Ubuntu)

Bug Description

Using the April 19th daily build of Kubuntu 18.04 I installed the Nvidia drivers via the following command.

sudo ubuntu-drivers autoinstall

The install process proceeds fine and after a logout process I get a black screen. I tried this on the April 17th daily build of bionic and a reboot also results in a black screen.

The following is a question which was submitted by a Ubuntu 17.10 user: QUOTE
After I installed latest Nvidia driver-390 and tried to boot after shutting down once I faced a black screen problem. since, I'm a noob but something related to nvidia drivers couldn't be started. Then I followed https://askubuntu.com/a/968692/802490
While following these instructions re-installing of nvidia drivers failed. The only things that worked is purging the drivers and changing "WaylandEnable=false" in (/etc/gdm3/custom.conf). Now, I want to re-install nvidia drivers again but I'm afraid that this will lead to that problem again. Can anyone help in re-installing the driver such that I won't face that problem? END QUOTE


Use Ctrl-Alt-f6 to get to a login prompt.
run "startx"

The x server will start and Nvidia drivers will function.

When I try to run SDDM I get an error (Which I will try to copy down to add to this bug when I am on a different computer than the one I am reporting the bug about.).

Installing lightDM does not work... it installs but is either will not run or will not actually start a x session.

Hontas Farmer (hontasf)
description: updated
Revision history for this message
Hontas Farmer (hontasf) wrote :

This is what I get when I log out of X and run sddm

:~$ sddm
[04:28:22.147] (II) DAEMON: Initializing...
[04:28:22.154] (II) DAEMON: Logind interface found
[04:28:22.154] (II) DAEMON: Starting...
[04:28:22.155] (II) DAEMON: Adding new display on vt 1 ...
[04:28:22.155] (II) DAEMON: Loading theme configuration from ""
[04:28:22.155] (II) DAEMON: Display server starting...
[04:28:22.155] (II) DAEMON: Running: /usr/bin/X -nolisten tcp -auth /var/run/sddm/{3029e4a4-8913-4abe-ac00-294e7375c132} -background none -noreset -displayfd 17 -seat seat0 vt1
[04:28:22.157] (EE) DAEMON: Display server failed to start. Exiting
Aborted (core dumped)

Revision history for this message
Hontas Farmer (hontasf) wrote :

Installing GDM3 does lead to a system which will not boot to a black screen. Note you will need to change the desktop session to plasma to get to kde.

For an experienced user used to the command prompt this is an annoyance. I'd rather run a pure KDE kubuntu system. To a newer or less technical user having a black screen (not flashing cursor BLACK) is a show stopper.

Rik Mills (rikmills)
tags: added: bionic kubuntu
Rik Mills (rikmills)
tags: added: nvidia sddm
removed: kubuntu
Revision history for this message
Rik Mills (rikmills) wrote :

Is this a machine with hybrid graphics?

Revision history for this message
Hontas Farmer (hontasf) wrote :

Yes it does have hybrid graphics. I also use an external GPU. This occurs with or without the EGPU plugged in.

However, it may be that there was a problem in that specific version of SDDM in that particular daily build. Somehow, someway installing the Ubuntu Gnome desktop system and gdm2 fixed it. Then I did a full upgrade a couple days ago and got a new version of sddm, switched to that and that seems to have fixed it.

The real problem is that a new user when confronted with a utterly BLACK screen won't know to Ctrl alt f6 into a terminal and do things from there. That sort of thing is a typical "why Linux will always be for geeks" moment.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: New → Confirmed
Changed in sddm (Ubuntu):
status: New → Confirmed
Revision history for this message
Thomas Friedrichsmeier (tfry) wrote :

Same symptoms(*) here after a fresh upgrade to 18.04.

Tried installing gdm, as suggested above, and also adding "xrandr" as suggested, here: https://forums.fedoraforum.org/showthread.php?316354-SDDM-shows-black-screen-with-Nvidia . Neither made a difference for me.

However, the problem finally went away after switching to the nouveau driver. (And I have no recollection of ever asking for the proprietary nvidia driver, specifically, but I may be wrong about that.)

(*) Symptoms: sddm, but also lightdm and gdm3 showing only black. startx brings up an xfce session without problems.

Revision history for this message
Mike Butash (michael-butash) wrote :

I upgraded from 17.04 to this, and can't get to a desktop now. Really regretting using ubuntu, yet again. This is a dell xps 15 9550, I finally had to try an upgrade due to various weird issues with 17.04 still, but at least it worked vs. now. Might try nouveau as recommended.

Revision history for this message
hsinclair (hsinclair) wrote :

I had this issue and resolved it by modifying the 10-nvidia.conf file to add the line:

Option "PrimaryGPU" "true"

The problem that I had was that the system would boot with the Intel GPU and once it go to the X-Display it attempted to use the NVidia drivers which were not properly initialized.

Revision history for this message
Julian Andres Klode (juliank) wrote :

I cannot possibly imagine how a blank screen on installing nvidia drivers is an apt problem, so I'm marking that as invalid.

Changed in apt (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
hsinclair (hsinclair) wrote :

The driver works properly. However, the configuration is what's at issue (therefore an apt problem). The configuration that's forcible enforced in the xorg.conf.d directory doesn't take into account that some devices have dual video cards. My issue was that there is an onboard Intel video chipset and also a NVidia discrete video adapter in my laptop. The kernel detects Intel and NVidia video cards and loads the Intel drivers... When the X-Windows system loads it detects the NVidia video card and attempts to load the X-Server system for it, but the underling modules haven't been loaded into the system and therefore loads the the black screen.

If you go into the xorg.conf.d and modify the 10-nvidia.conf files to add the [Option "PrimaryGPU" "true"] line then it works, but because these files are not configured in the package as configuration files they are overwritten on every update.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments