apt crashed with SIGSEGV

Bug #1764521 reported by Malachi de AElfweald on 2018-04-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Medium
Unassigned

Bug Description

Apport is reporting this in conjunction with
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1764519

dmesg said there were systemd errors. Tried to run `sudo systemctl status` but that sigfaulted. Tried to reboot, but that failed. Had to hard reboot.

malachid@odin:~$ lsb_release -rd
Description: Ubuntu Bionic Beaver (development branch)
Release: 18.04

malachid@odin:~$ apt-cache policy apt
apt:
  Installed: 1.6~beta1
  Candidate: 1.6~beta1
  Version table:
 *** 1.6~beta1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
DistroRelease: Ubuntu 18.04
Package: apt 1.6~beta1
ProcVersionSignature: Ubuntu 4.15.0-15.16-generic 4.15.15
Uname: Linux 4.15.0-15-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.9-0ubuntu4
Architecture: amd64
CrashCounter: 1
Date: Mon Apr 16 11:48:25 2018
ExecutablePath: /usr/bin/apt
ProcCmdline: apt install libdvdnav4 libdvdread4 libdvd-pkg
ProcEnviron:
 LANG=en_US.UTF-8
 TERM=xterm-256color
 PATH=(custom, no user)
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f0342c2b76b: cmp %r14w,(%rax)
 PC (0x7f0342c2b76b) ok
 source "%r14w" ok
 destination "(%rax)" (0x7f02cba3c0cd) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: apt
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/liblzma.so.5
 ?? () from /lib/x86_64-linux-gnu/liblzma.so.5
 ?? () from /lib/x86_64-linux-gnu/liblzma.so.5
 ?? () from /lib/x86_64-linux-gnu/liblzma.so.5
 ?? () from /lib/x86_64-linux-gnu/liblzma.so.5
Title: apt crashed with SIGSEGV
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Malachi de AElfweald (malachid) wrote :
Malachi de AElfweald (malachid) wrote :

Although I wasn't installing anything at the time, the crash reporter also popped up saying that a problem occurred while installing libopencore-amrwb0 0.1.3-2.1

Maybe that is related to apt crashing?

https://bugs.launchpad.net/ubuntu/+source/opencore-amr/+bug/1764522

Changed in apt (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Julian Andres Klode (juliank) wrote :

Have you run memory checks? If everything crashes, it might be a faulty memory module.

information type: Private → Public
Malachi de AElfweald (malachid) wrote :

I have downloaded Memtest86-7.5.iso but haven't yet got the 40_custom entry correct to launch it via loopback. I guess I could burn it to USB/CD.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers