SIGSEGV when reloading cache after setting architecture to ""

Bug #1549819 reported by Adam Collard on 2016-02-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Undecided
Unassigned
landscape-client (Ubuntu)
Undecided
Unassigned

Bug Description

When reloading the cache, after setting an architecture, the Python process segfaults.

Simple script to reproduce is at: http://paste.ubuntu.com/15197359/

Tested on a Xenial LXD with Wily host (on the host, the script doesn't trigger the segfault).

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: python-apt 1.1.0~beta1build1
ProcVersionSignature: Ubuntu 4.2.0-27.32-generic 4.2.8-ckt1
Uname: Linux 4.2.0-27-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
Date: Thu Feb 25 14:09:39 2016
ProcEnviron:
 TERM=screen
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: python-apt
UpgradeStatus: No upgrade log present (probably fresh install)

Adam Collard (adam-collard) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in landscape-client (Ubuntu):
status: New → Confirmed
Changed in python-apt (Ubuntu):
status: New → Confirmed
summary: - SIGSEGV when reloading cache after setting architecture
+ SIGSEGV when reloading cache after setting architecture to ""
Julian Andres Klode (juliank) wrote :

Reassigning as its reproducible with apt-cache gencaches.

affects: python-apt (Ubuntu) → apt (Ubuntu)
Andreas Hasenack (ahasenack) wrote :

Here is a bt full from this reproducer given to me by juliank:
$ cat a.cfg
APT::Architecture "";
$ apt-cache gencaches -c a.cfg -o Dir::Cache=$PWD -o Debug::NoLocking=1
Reading package lists... Error!
E: The package cache was built for different architectures: vs i386
W: You may want to run apt-get update to correct these problems
E: The package cache file is corrupted

http://pastebin.ubuntu.com/15197953/

Also attached in case the pastebin gets wiped.

Andreas Hasenack (ahasenack) wrote :
Julian Andres Klode (juliank) wrote :

This has been fixed upstream in APT 1.2.4 which I just uploaded. Once that's synced, we're done.

Brian Murray (brian-murray) wrote :

Is bug 970729 a duplicate of this?

Adam Collard (adam-collard) wrote :

@Brian - I don't have permission to read that bug, so can't comment one way or the other

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 1.2.4

---------------
apt (1.2.4) unstable; urgency=medium

  [ David Kalnischkies ]
  * use local changelog from /usr/share/doc if possible
  * always download changelogs into /tmp first
  * pass versioned provides to external solvers in EDSP

  [ Julian Andres Klode ]
  * Fix maintscript to properly remove 20changelog (Closes: #814754)
  * Fix crash with empty architecture list (LP: #1549819)
  * Add missing numeric includes in files using std::accumulate()

 -- Julian Andres Klode <email address hidden> Sat, 27 Feb 2016 14:02:47 +0100

Changed in apt (Ubuntu):
status: Confirmed → Fix Released
Changed in landscape-client (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers