"E: Method http has died unexpectedly" when run under lxc on wily apt 1.0.9.9ubuntu1

Bug #1457754 reported by Timo Jyrinki on 2015-05-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Curl
New
Undecided
Unassigned
apt (Ubuntu)
High
Unassigned
gnutls28 (Ubuntu)
Undecided
Unassigned
lxc (Ubuntu)
High
Unassigned

Bug Description

lxc-create -t download -n wily-gui -- -d ubuntu -r wily -a amd64 + some config according to https://www.stgraber.org/2014/02/09/lxc-1-0-gui-in-containers/ + https://www.stgraber.org/2014/01/17/lxc-1-0-unprivileged-containers/ + enabling network.

---
root@wily-gui:/home/ubuntu# apt update
E: Method http has died unexpectedly!
E: Sub-process http received a segmentation fault.
---

Downgrading apt to https://launchpad.net/ubuntu/+source/apt/1.0.9.7ubuntu4 in the LXC rootfs seems to fix the issue.

description: updated
Timo Jyrinki (timo-jyrinki) wrote :

It's not about the apt version. I just got it with the downgraded apt, and something apt does when installing the packages fixes it, since it started working once I re-installed the older packages... if you don't believe, here's a bit cut-off but copy-pasted output from my lxc:

---
root@wily-gui:~# apt-get autoremove --purge unity.*
Luetaan pakettiluetteloita... Valmis
...
0 päivitetty, 14 uutta asennusta, 106 poistettavaa ja 16 päivittämätöntä.
Noudettavaa arkistoa 3 375 kt.
Toiminnon jälkeen vapautuu 79,8 M t levytilaa.
Haluatko jatkaa? [K/e]
E: Method http has died unexpectedly!
E: Aliprosessi http aiheutti suojausvirheen.
root@wily-gui:~# apt-get autoremove --purge unity.*
Luetaan pakettiluetteloita... Valmis
...
0 päivitetty, 14 uutta asennusta, 106 poistettavaa ja 16 päivittämätöntä.
Noudettavaa arkistoa 3 375 kt.
Toiminnon jälkeen vapautuu 79,8 M t levytilaa.
Haluatko jatkaa? [K/e] k
E: Method http has died unexpectedly!
E: Aliprosessi http aiheutti suojausvirheen.
root@wily-gui:/# dpkg -i libapt-* apt*
(Reading database ... 118694 files and directories currently installed.)
Preparing to unpack libapt-inst1.5_1.0.9.7ubuntu4_amd64.deb ...
Unpacking libapt-inst1.5:amd64 (1.0.9.7ubuntu4) over (1.0.9.7ubuntu4) ...
Preparing to unpack libapt-pkg4.12_1.0.9.7ubuntu4_amd64.deb ...
Unpacking libapt-pkg4.12:amd64 (1.0.9.7ubuntu4) over (1.0.9.7ubuntu4) ...
Preparing to unpack apt_1.0.9.7ubuntu4_amd64.deb ...
Unpacking apt (1.0.9.7ubuntu4) over (1.0.9.7ubuntu4) ...
Preparing to unpack apt-utils_1.0.9.7ubuntu4_amd64.deb ...
Unpacking apt-utils (1.0.9.7ubuntu4) over (1.0.9.7ubuntu4) ...
Setting up libapt-pkg4.12:amd64 (1.0.9.7ubuntu4) ...
Setting up apt (1.0.9.7ubuntu4) ...
Setting up libapt-inst1.5:amd64 (1.0.9.7ubuntu4) ...
Setting up apt-utils (1.0.9.7ubuntu4) ...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for libc-bin (2.21-0ubuntu4) ...
root@wily-gui:/# apt-get autoremove --purge unity.*
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu
Luetaan tilatiedot... Valmis
...
0 päivitetty, 14 uutta asennusta, 106 poistettavaa ja 16 päivittämätöntä.
Noudettavaa arkistoa 3 375 kt.
Toiminnon jälkeen vapautuu 79,8 M t levytilaa.
Haluatko jatkaa? [K/e]
Nouda:1 http://archive.ubuntu.com/ubuntu/ wily/universe gnome-control-center amd64 1:3.14.2-2ubuntu3 [1 464 kB]
Nouda:2 http://archive.ubuntu.com/ubuntu/ wily/main libcolord-gtk1 amd64 0.1.25-1.1build2 [16,7 kB]
Nouda:3 http://archive.ubuntu.com/ubuntu/ wily/main libgnome-control-center1 amd64 1:3.14.2-2ubuntu3 [90,1 kB]
...

description: updated
tags: added: wily
Timo Jyrinki (timo-jyrinki) wrote :

So my modus operandi is now always:
1. lxc-start
2. lxc-attach
3. dpkg -i *.deb (apt_1.0.9.7ubuntu4_amd64.deb libapt-inst1.5_1.0.9.7ubuntu4_amd64.deb python3-apt_0.9.3.11ubuntu1_amd64.deb apt-utils_1.0.9.7ubuntu4_amd64.deb libapt-pkg4.12_1.0.9.7ubuntu4_amd64.deb python-apt_0.9.3.11ubuntu1_amd64.deb)
4. start using the container

Changed in lxc (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu):
status: New → Confirmed
Changed in lxc (Ubuntu):
status: New → Confirmed
Nazar Mokrynskyi (nazar-pc) wrote :
Download full text (5.5 KiB)

I'm getting this on regular installation of Ubuntu 15.10:
nazar-pc@nazar-pc ~> sudo apt-get update
Hit http://repository.spotify.com stable InRelease
Ign http://ua.archive.ubuntu.com wily InRelease
Get:1 http://repository.spotify.com stable/non-free amd64 Packages [1 433 B]
Ign http://download.opensuse.org InRelease
Hit http://repo.steampowered.com precise InRelease
Ign http://ppa.launchpad.net vivid InRelease
Ign http://extras.ubuntu.com utopic InRelease
Ign http://archive.canonical.com wily InRelease
Hit http://repository.spotify.com stable/non-free i386 Packages
Ign http://ua.archive.ubuntu.com wily-updates InRelease
Hit http://download.opensuse.org Release.gpg
Ign http://ppa.launchpad.net vivid InRelease
Hit http://extras.ubuntu.com utopic Release.gpg
Ign http://ua.archive.ubuntu.com wily-backports InRelease
Hit http://archive.canonical.com wily Release.gpg
Ign http://security.ubuntu.com wily-security InRelease ...

Read more...

Nazar Mokrynskyi (nazar-pc) wrote :

Bug appears after updating curl from 7.38.0-3ubuntu3 to 7.42.1-2ubuntu1.
Downgrading to 7.38.0-3ubuntu3 fixes the problem

Changed in apt (Ubuntu):
importance: Undecided → High
Nazar Mokrynskyi (nazar-pc) wrote :

Fixed for me with latest update of GNU TLS

Timo Jyrinki (timo-jyrinki) wrote :

Same here, at least for now.

Changed in gnutls (Ubuntu):
status: New → Fix Released
Changed in apt (Ubuntu):
status: Confirmed → Invalid
Changed in lxc (Ubuntu):
status: Confirmed → Invalid
affects: gnutls (Ubuntu) → gnutls28 (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers