Ubuntu

firefox plugin-install says "plugin installed" for non-completed installation

Reported by Martin Olsson on 2007-09-22
114
This bug affects 6 people
Affects Status Importance Assigned to Milestone
apt (Baltix)
Undecided
Unassigned
apt (Ubuntu)
Undecided
Unassigned
apturl (Ubuntu)
Medium
Michael Vogt
firefox (Ubuntu)
Undecided
Unassigned
flashplugin-nonfree (Ubuntu)
High
Unassigned
ubufox (Ubuntu)
Medium
Unassigned

Bug Description

1. install latest gutsy and apt-get update it
2. launch firefox and point it to http://www.velox.com.br/ (or any other site which has flash content)
3. SCREENSHOT_1: a yellow bar appears with "Install missing plugins..." button
4. SCREENSHOT_2: user can choose either commcerial flash or free gnash version (press next to get the default choice which is the commercial version)
5. SCREENSHOT_3: Firefox plugin installer then asks, "do you really want to install it?". (press the NO button here)
6. SCREENSHOT_4: Firefox plugin installer then says "plugin successfully installed" (even though the installation was aborted).

I expected it to say "installation aborted" or something instead.

Martin Olsson (mnemo) wrote :
Martin Olsson (mnemo) wrote :
Martin Olsson (mnemo) wrote :
Martin Olsson (mnemo) wrote :
David Chart (ubuntu-davidchart) wrote :

I also see this, on 7.10 Beta on amd64. Neither Flash plugin installs (E: You have held broken packages for the Adobe one, and "package not found" for Gnash), but FIrefox reports "plugin successfully installed".

David Chart (ubuntu-davidchart) wrote :

Note: the above "package not found" for Gnash appears to be due to the Ubuntu repository for Japan being out of date. Shifting Synaptic to point at the main repository made it work.

I've got a similar bug. When installing the java plug-in, and downloading the package, clicking cancel ends the installation but the message: Firefox finished installing the missing plug-ins is stilled displayed.

Martin Olsson (mnemo) wrote :

This bug is about the fact that Firefox says "installation completed" despite the fact that the installation failed. I fail to understand why this is being confirmed in the "apt" category? Isn't it a Firefox bug? Surely, the Flash packages has several problems (for which there are other bug reports; like the bad MD5 etc) but this bug was intended to track the incorrect Firefox behavior, this bug is not about any repository problem.

mnemo, firefox uses apt to install the flash plugin from the repos so thats why its filed under apt :) An obvious workaround is to manually download the flash plugin from adobe and install it yourself. It only takes a minute or so.

Martin Olsson (mnemo) wrote :

Yea, I already got flash installed manually; I'm trying to explain a bug here not solve a problem on my computer :-)

I'm assuming the "Plugin Finder Service" window is a part of Firefox (?). I'm not sure whether the "Install additional software?" yes-or-no dialog in screenshot 3 is part of Firefox or some package manager. However, I believe (correct me if i'm wrong) that in any case the bug is in Firefox.

In screenshot 3, suppose the "Install additional software?" dialog is part of Firefox; in that case this is a Firefox bug.
In screenshot 3, suppose the "Install additional software?" dialog is part of Synaptic/APT; in that case this is STILL a Firefox bug.

Let me explain why this is a Firefox bug in the latter case. If firefox invokes Synaptic/APT to install flash but for some reason that installation fails (or as in my repro steps above, is canceled by the user) then Synaptic/APT should report an error code back to Firefox to indicate this.

Firefox should use this error code / result to show an appropriate message to the user. Since I canceled the installation, it makes no sense that Firefox tells me that the "Firefox finished installing plugins" because I know this is untrue. Therefore, I'm guessing that Firefox ignores the error code from Synaptic/APT and always displays the same "finished installing plugins" for all possible situations.

Now, isn't that a bug in Firefox, no?

Oliver Gerlich (ogerlich) wrote :

AFAIK the apt-based plugin installation is done by the Ubufox package.

How about marking it as a bug in apt, firefox, and ubufox? That would make sure that the devs from all three packages can decide whether the problem is on their turf.

Martin Olsson (mnemo) wrote :

Good idea! I've added the packages as suggested.

Saivann Carignan (oxmosys) wrote :

This bug is not a Firefox bug since the particular plugin installation is a part of ubufox which calls apt, it may be a apt bug and it's for sure a ubufox bug. Therefore, I set Firefox status to Invalid and ubufox status to confirmed, Importance to medium.

To everybody who try to install adobe flash player through ubufox, the problem with the installation is completely caused by bug #173890, flashplugin-nonfree installation doesn't fail in apt but flash is still not installed because of a md5sum problem, ubufox and apt can't fix this problem, it's a flashplugin-nonfree bug.

Changed in ubufox:
importance: Undecided → Medium
status: New → Confirmed
Changed in firefox:
status: New → Invalid
shanthi (shanthi0227) wrote :

This bug isnot allowing me to install plugins n I am really missing watching videos n listening to my fav songs. What do I do? Anyone to help correct this problem

On Fri, Feb 08, 2008 at 03:21:28PM -0000, shanthi wrote:
> This bug isnot allowing me to install plugins n I am really missing
> watching videos n listening to my fav songs. What do I do? Anyone to
> help correct this problem
>

 affects ubuntu/apt
 status invalid
 affects baltix/apt
 status invalid
 affects ubuntu/apturl
 status confirmed

... there is a bug about improving error handling between apturl +
ubufox open. this one should be a made duplicate of that.

 - Alexander

Changed in apt:
status: Confirmed → Invalid
status: New → Invalid

Thanks for ur information. Somehow the plugins have been installed but still I cant download Yahoo messenger or google talk to voice chat with my frnds. Is there any remedy? also I cant listen to songs on Raaga.com n Raagalahari.com. It always says transferring data butnever opens.

----- Original Message ----
From: Alexander Sack <email address hidden>
To: <email address hidden>
Sent: Tuesday, February 19, 2008 7:28:59 AM
Subject: Re: [Bug 144042] Re: firefox plugin-install says "plugin installed" for non-completed installation

On
Fri,
Feb
08,
2008
at
03:21:28PM
-0000,
shanthi
wrote:
>
This
bug
isnot
allowing
me
to
install
plugins
n
I
am
really
missing
>
watching
videos
n
listening
to
my
fav
songs.
What
do
I
do?
Anyone
to
>
help
correct
this
problem
>

affects
ubuntu/apt

status
invalid

affects
baltix/apt

status
invalid

affects
ubuntu/apturl

status
confirmed

...
there
is
a
bug
about
improving
error
handling
between
apturl
+
ubufox
open.
this
one
should
be
a
made
duplicate
of
that.

-
Alexander

**
Changed
in:
apt
(Ubuntu)

Status:
Confirmed
=>
Invalid

**
Changed
in:
apt
(Baltix)

Status:
New
=>
Invalid

**
Also
affects:
apturl
(Ubuntu)

Importance:
Undecided

Status:
Confirmed

--
firefox
plugin-install
says
"plugin
installed"
for
non-completed
installation
https://bugs.launchpad.net/bugs/144042
You
received
this
bug
notification
because
you
are
a
direct
subscriber
of
the
bug.

Status
in
Source
Package
"apt"
in
Ubuntu:
Invalid
Status
in
Source
Package
"apturl"
in
Ubuntu:
Confirmed
Status
in
Source
Package
"firefox"
in
Ubuntu:
Invalid
Status
in
Source
Package
"ubufox"
in
Ubuntu:
Confirmed
Status
in
Source
Package
"apt"
in
Baltix
GNU/Linux:
Invalid

Bug
description:

1.
install
latest
gutsy
and
apt-get
update
it
2.
launch
firefox
and
point
it
to
http://www.velox.com.br/

(or
any
other
site
which
has
flash
content)
3.
SCREENSHOT_1:
a
yellow
bar
appears
with
"Install
missing
plugins..."
button
4.
SCREENSHOT_2:
user
can
choose
either
commcerial
flash
or
free
gnash
version
(press
next
to
get
the
default
choice
which
is
the
commercial
version)
5.
SCREENSHOT_3:
Firefox
plugin
installer
then
asks,
"do
you
really
want
to
install
it?".
(press
the
NO
button
here)
6.
SCREENSHOT_4:
Firefox
plugin
installer
then
says
"plugin
successfully
installed"
(even
though
the
installation
was
aborted).

I
expected
it
to
say
"installation
aborted"
or
something
instead.

      ____________________________________________________________________________________
Be a better friend, newshound, and
know-it-all with Yahoo! Mobile. Try it now. http://mobile.yahoo.com/;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ

Alexander Sack (asac) on 2008-02-21
description: updated
Jim J (morlockhq) wrote :

I can confirm that this is a bug in ubufox. I got the exact same condition when there was the update from flashplugin-nonfree 9.0.48.0.2+really0ubuntu12(gutsy) to flashplugin-nonfree 9.0.48.0.2+really0ubuntu12.2 (gutsy-updates).

The only way to fix it for me was to shut down firefox, then uninstall flashplugin-nonfree 9.0.48.0.2+really0ubuntu12(gutsy) with synaptic (I assume straight apt would have worked) and then reinstall flashplugin-nonfree 9.0.48.0.2+really0ubuntu12(gutsy) and update it to 9.0.48.0.2+really0ubuntu12.2 (gutsy-updates) within synaptic.

Then when I started firefox and visited youtube, I got the message that I needed to install a plugin which lauched ubufox and it showed that the adobe flash player was installed.

Then I relaunched firefox and everything worked fine.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

apturl now returns useful exit codes that ubufox can use.

Changed in apturl:
assignee: nobody → mvo
importance: Undecided → Medium
status: Confirmed → Fix Released
Alexander Sack (asac) wrote :

now that apturl returns reasonable error codes it should be fixed in ubufox as well.

Changed in ubufox:
status: Confirmed → Fix Released
Dmitry Diskin (diskin) wrote :

Not sure if it is related, but I just got this (see screenshot). Synaptic fails to detect the md5 failure. This is fresh 8.10 installation with all latest updates.

Alexander Sack (asac) wrote :

Hmm ... you still get "success"? ... sounds like either a flashplugin-nonfree issue or apturl doesnt properly return the error code.

Alexander Sack (asac) wrote :

flashplugin-nonfree _must_ fail if it fails to install download.

Changed in flashplugin-nonfree:
importance: Undecided → High
status: New → Triaged
Jwednesday (jwednesday) wrote :

this was resolved a long time ago ... why is it coming up now?

On Mon, 22 Dec 2008 12:01:19 -0500, Alexander Sack <email address hidden> wrote:

> Hmm ... you still get "success"? ... sounds like either a flashplugin-
> nonfree issue or apturl doesnt properly return the error code.
>
> ** Also affects: flashplugin-nonfree (Ubuntu)
> Importance: Undecided
> Status: New
>

--
Using Opera's revolutionary e-mail client: http://www.opera.com/mail/

Dmitry Diskin (diskin) wrote :

> this was resolved a long time ago ... why is it coming up now?

Not sure why. The MD5 was clearly broken (I got an update in several days fixing that), but apart from that, it was a clean install with all up-to-date fixes.

Yannis Tsop (ogiannhs) wrote :
Download full text (6.9 KiB)

I have this problem again:

Preconfiguring packages ...
(Reading database ... 156501 files and directories currently installed.)
Preparing to replace flashplugin-nonfree 10.0.15.3ubuntu1~intrepid1 (using .../flashplugin-nonfree_10.0.15.3ubuntu1~intrepid1_i386.deb) ...
Unpacking replacement flashplugin-nonfree ...
Setting up flashplugin-nonfree (10.0.15.3ubuntu1~intrepid1) ...
Downloading...
--2009-03-04 12:57:02-- http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
Resolving fpdownload.macromedia.com... 92.122.194.70
Connecting to fpdownload.macromedia.com|92.122.194.70|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3994294 (3.8M) [application/x-gzip]
Saving to: `./install_flash_player_10_linux.tar.gz'

     0K .......... .......... .......... .......... .......... 1% 309K 12s
    50K .......... .......... .......... .......... .......... 2% 915K 8s
   100K .......... .......... .......... .......... .......... 3% 939K 7s
   150K .......... .......... .......... .......... .......... 5% 9.70M 5s
   200K .......... .......... .......... .......... .......... 6% 980K 5s
   250K .......... .......... .......... .......... .......... 7% 11.0M 4s
   300K .......... .......... .......... .......... .......... 8% 1.03M 4s
   350K .......... .......... .......... .......... .......... 10% 11.3M 3s
   400K .......... .......... .......... .......... .......... 11% 10.2M 3s
   450K .......... .......... .......... .......... .......... 12% 1.13M 3s
   500K .......... .......... .......... .......... .......... 14% 11.3M 3s
   550K .......... .......... .......... .......... .......... 15% 11.0M 2s
   600K .......... .......... .......... .......... .......... 16% 8.89M 2s
   650K .......... .......... .......... .......... .......... 17% 15.0M 2s
   700K .......... .......... .......... .......... .......... 19% 1.25M 2s
   750K .......... .......... .......... .......... .......... 20% 11.0M 2s
   800K .......... .......... .......... .......... .......... 21% 11.3M 2s
   850K .......... .......... .......... .......... .......... 23% 11.3M 2s
   900K .......... .......... .......... .......... .......... 24% 11.0M 2s
   950K .......... .......... .......... .......... .......... 25% 10.0M 1s
  1000K .......... .......... .......... .......... .......... 26% 1.56M 1s
  1050K .......... .......... .......... .......... .......... 28% 11.0M 1s
  1100K .......... .......... .......... .......... .......... 29% 7.38M 1s
  1150K .......... .......... .......... .......... .......... 30% 11.4M 1s
  1200K .......... .......... .......... .......... .......... 32% 11.0M 1s
  1250K .......... .......... .......... .......... .......... 33% 7.97M 1s
  1300K .......... .......... .......... .......... .......... 34% 7.30M 1s
  1350K .......... .......... .......... .......... .......... 35% 2.34M 1s
  1400K .......... .......... .......... .......... .......... 37% 3.62M 1s
  1450K .......... .......... .......... .......... .......... 38% 11.3M 1s
  1500K .......... .......... .......... .......... .......... 39% 11.0M 1s
  1550K .......... .......... .......... .......... ...........

Read more...

Changed in ubufox:
status: Fix Released → New
Dara Adib (daradib) wrote :

@Yannis T

This bug for the apparent successful installation of a package when the md5sums fail does not currently affect the ubufox package. I would recommending checking Bug 173890 for your issue.

Changed in ubufox:
status: New → Fix Released
Przemysław Kulczycki (azrael) wrote :

Ubufox shows "installation successful" when installation fails due to Bug #363798: ubufox can't install adobe flash plugin on 64-bit jaunty

Jeroen (c0p3rn1c) wrote :

Upgrading from intrepid to jaunty (32 bit) wrecked my flash. Synaptic say it's installed but firefox keeps asking to install it and when I continue to install it firefox says it's already installed.
First I tried to re-install the flashplugin-nonfree package, that diden't work but re-installing flashplugin-installer too did.

John Vivirito (gnomefreak) wrote :

We are using -installer now as i recall, i dont remember why or why -nonfree is in repos but you can ask on irc.freenode.net #ubuntu-mozillateam

Alexander Sack (asac) wrote :

jeroen can you pleaes check your intrepid-jaunty upgrade logs and see if the download during flash upgrade failed?

Alexander Sack (asac) wrote :

this bug has been fixed long ago. please open new bugs for new issues.

Changed in flashplugin-nonfree (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers