aptd crashed with SIGSEGV in _IO_vfprintf_internal()

Bug #1436626 reported by Aleksandar Dezelin on 2015-03-26
104
This bug affects 17 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
High
Unassigned

Bug Description

Errors Bucket
-------------
https://errors.ubuntu.com/problem/4d8c3bd9e5dfe8ccfe2783d6d12c7c5cb88b8cd9

sudo apt-get upgrade -y

ProblemType: CrashDistroRelease: Ubuntu 15.04
Package: aptdaemon 1.1.1+bzr981-0ubuntu2
ProcVersionSignature: Ubuntu 3.19.0-9.9-generic 3.19.1
Uname: Linux 3.19.0-9-generic x86_64
ApportVersion: 2.16.2-0ubuntu4
Architecture: amd64
Date: Thu Mar 26 02:04:25 2015
ExecutablePath: /usr/sbin/aptd
InstallationDate: Installed on 2015-02-27 (26 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
InterpreterPath: /usr/bin/python3.4
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/sbin/aptd
ProcEnviron: LANG=C.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7fba78fec4b2 <_IO_vfprintf_internal+18578>: repnz scas %es:(%rdi),%al
 PC (0x7fba78fec4b2) ok
 source "%es:(%rdi)" (0x00000006) not located in a known VMA region (needed readable region)!
 destination "%al" ok
SegvReason: reading NULL VMA
Signal: 11SourcePackage: aptdaemon
StacktraceTop:
 _IO_vfprintf_internal (s=s@entry=0x217fbd0, format=<optimized out>, ap=ap@entry=0x7ffc20027548) at vfprintf.c:1642
 ___fprintf_chk (fp=0x217fbd0, flag=1, format=<optimized out>) at fprintf_chk.c:35
 pkgDPkgPM::WriteApportReport(char const*, char const*) () from /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.12
 pkgDPkgPM::ProcessDpkgStatusLine(char*) () from /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.12
 pkgDPkgPM::DoDpkgStatusFd(int) () from /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.12
Title: aptd crashed with SIGSEGV in _IO_vfprintf_internal()
UpgradeStatus: Upgraded to vivid on 2015-03-07 (18 days ago)
UserGroups:

Aleksandar Dezelin (dezelin) wrote :

StacktraceTop:
 _IO_vfprintf_internal (s=s@entry=0x217fbd0, format=<optimized out>, ap=ap@entry=0x7ffc20027548) at vfprintf.c:1642
 ___fprintf_chk (fp=0x217fbd0, flag=1, format=<optimized out>) at fprintf_chk.c:35
 fprintf (__fmt=<optimized out>, __stream=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/stdio2.h:98
 pkgDPkgPM::WriteApportReport (this=this@entry=0x19cbb20, pkgpath=<optimized out>, errormsg=<optimized out>) at /build/buildd/apt-1.0.9.7ubuntu3/apt-pkg/deb/dpkgpm.cc:1910
 pkgDPkgPM::ProcessDpkgStatusLine (this=this@entry=0x19cbb20, line=line@entry=0x1d47da1 "status: libapt-inst1.5:amd64 : error : package libapt-inst1.5:amd64 is already installed and configured") at /build/buildd/apt-1.0.9.7ubuntu3/apt-pkg/deb/dpkgpm.cc:647

Changed in aptdaemon (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :
information type: Private → Public
Changed in aptdaemon (Ubuntu):
importance: Medium → High
Sebastien Bacher (seb128) wrote :

those issues started around march 18, not sure what changed in vivid, seems rather an apt issue

affects: aptdaemon (Ubuntu) → apt (Ubuntu)
Byte (v-palievsky) wrote :

home@Dell:~$ sudo apt-get upgrade -y
[sudo] password for home:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

description: updated
tags: added: rls-v-incoming
David Kalnischkies (donkult) wrote :

The funpart to observe here is that apt is crashing while writing an apport report for an observed failure… so figure out what error it is that apt wants to report here is probably bringing you guys a lot closer to figure out what goes on… (looking at the stacktrace in the bugreport alone as I don't have the clearance to look at anything else). Maybe the new crashreport is partly written before it crashes as multiple fprintf's are involved in its creation… (I don't see an obvious badboy. Maybe something about the sourcename lookup. I had to do some bad stuff to preserve ABI in there lately (to fix md5-only source), maybe something of that is incorrect. [even through I would presume these calls would fail, rather than fprintf…]).

Michael Vogt (mvo) on 2015-04-07
Changed in apt (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 1.0.9.7ubuntu4

---------------
apt (1.0.9.7ubuntu4) vivid; urgency=medium

  [ Michael Vogt ]
  * Fix crash in pkgDPkgPM::WriteApportReport(() (LP: #1436626)
 -- Michael Vogt <email address hidden> Tue, 07 Apr 2015 12:28:32 +0200

Changed in apt (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers