apt is unable to handle CDROMS with default mount option

Bug #1415701 reported by Andrew Wilkins on 2015-01-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Medium
Unassigned

Bug Description

I have found i am almost completely unable to use CDROM as an apt repository on Ubuntu 14.04

I found the command apt-cdrom add by default, was unable to detect CDROMs
it was attempting to find them in /media/cdrom/
by default ubuntu now seems to mount cds in /media/$USER/ and this is not something set via fstab
i was able to get them to add with the command
apt-cdrom add -m --cdrom /media/$USER/

I seem to have been able to pull the package list from the CD, but when it comes to installing from it, apt encounters a similar error
it ask you to insert the disc in drive /media/cdrom/ again

I also am completely unable to add cds via the software & updates setting manager, it always fails to find the cd, which is presumably part of the same issue.

manually remounting with
sudo mount /dev/cdrom /media/cdrom
get some things to work, but most of the actions trigger a remount which goes back to the default location

I was finally able to get things working again properly by adding the fstab line
/dev/cdrom /media/cdrom udf,iso9660 user,noauto,exec,utf8 0 0
resolves the problem for me
but this is a work around not a fix, it may break other stuff

In apt conf i have tried setting
Acquire::cdrom::mount "file/path/";
with various file paths, the file paths, to try and make it work with the default mount behaviour,this looked to be the right setting to change as the message changed accordingly to what i was setting, but i could not get it to work for actually installing packages, even by setting an absolute file path for my user in the media directory.

does not seem to effect 12.04

I have tried this on several ubuntu 14.04 machines now
the result is always the same

also affects 14.10

tags: added: trusty utopic
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu):
status: New → Confirmed
Changed in apt (Ubuntu):
importance: Undecided → Medium
tags: added: rls-x-incoming xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers