Ubuntu

apt prints wrong error message when installing broken package

Reported by Alexandra Kossovsky on 2005-03-12
8
Affects Status Importance Assigned to Milestone
apt (Debian)
New
Unknown
apt (Ubuntu)
Low
Unassigned

Bug Description

Universe contains broken packages for amd64 (and it is not the subject of this
bugreport), and apt refuses to install them:
apt-get install konq-plugins
............
The following packages have unmet dependencies:
  konq-plugins: Depends: kdelibs4 (>= 4:3.3.2-1ubuntu8) but it is not going to
be installed
                Depends: konqueror (>= 4:3.3.2) but it is not going to be installed
                Depends: libkonq4 (>= 4:3.3.2) but it is not going to be installed
                Depends: ark but it is not going to be installed
All 4 packages are already installed and have versions larger than necessary.
The real problem is following:
apt-get install konq-plugins konqueror ark
............
The following packages have unmet dependencies:
  kdelibs-data: Conflicts: konq-plugins (< 4:3.3.99) but 4:3.3.2-1ubuntu1 is to
be installed

The first error message is very misleading. It will be more user-friendly to
tell about conflict on the first request.

severity 218605 minor
retitle 218605 Error messages for broken packages are not always enlightening
thanks

--
 - mdz

Universe contains broken packages for amd64 (and it is not the subject of this
bugreport), and apt refuses to install them:
apt-get install konq-plugins
............
The following packages have unmet dependencies:
  konq-plugins: Depends: kdelibs4 (>= 4:3.3.2-1ubuntu8) but it is not going to
be installed
                Depends: konqueror (>= 4:3.3.2) but it is not going to be installed
                Depends: libkonq4 (>= 4:3.3.2) but it is not going to be installed
                Depends: ark but it is not going to be installed
All 4 packages are already installed and have versions larger than necessary.
The real problem is following:
apt-get install konq-plugins konqueror ark
............
The following packages have unmet dependencies:
  kdelibs-data: Conflicts: konq-plugins (< 4:3.3.99) but 4:3.3.2-1ubuntu1 is to
be installed

The first error message is very misleading. It will be more user-friendly to
tell about conflict on the first request.

Debian Bug Importer (debzilla) wrote :
Download full text (4.4 KiB)

Message-Id: <email address hidden>
Date: Sat, 01 Nov 2003 15:21:42 +0000
From: Henning Makholm <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: apt: misleading dependency problem message

Package: apt
Version: 0.5.14
Severity: normal

If, on system with the following installed, all current from unstable:

apt 0.5.14
perl 5.8.1-4
perl-modules 5.8.1-4 (provides libtile-temp-perl)
autoconf 2.57-11

I try to install autoconf2.13 from woody, I see the following output

  $ sudo apt-get install autoconf2.13/stable
  Reading Package Lists... Done
  Building Dependency Tree... Done
  Selected version 2.13-43 (Debian:3.0r1a/stable) for autoconf2.13
  Some packages could not be installed. This may mean that you have
  requested an impossible situation or if you are using the unstable
  distribution that some required packages have not yet been created
  or been moved out of Incoming.

  Since you only requested a single operation it is extremely likely that
  the package is simply not installable and a bug report against
  that package should be filed.
  The following information may help to resolve the situation:

  The following packages have unmet dependencies:
    autoconf2.13: Depends: autoconf (>= 2.50) but it is not going to be installed
                  Depends: perl but it is not going to be installed
                  Depends: libfile-temp-perl
  E: Broken packages
  $

The message from apt about unmet dependencies is grossly misleading;
I do have all of autoconf (>=2.50), perl and libfile-temp-perl.

The actual reason for the refusal seems to be that autoconf 2.57-11
declares a conflict against autoconf2.13 (<<2.13-47). But the only way
I found that out was by knowing in advance know that there is some
intimate interaction between the maintainer script of the two
autoconfs, so they may do something like that.

(And why would one want to do exactly this? One probably wouldn't, but
I originallty came across the problem when I tried to selectively
upgrade autoconf to unstable on a woody box and apt-get insisted on
removing autoconf2.13 without giving any good explanation why).

-- Package-specific info:

-- apt-config dump --

APT "";
APT::Architecture "i386";
APT::Build-Essential "";
APT::Build-Essential:: "build-essential";
Dir "/";
Dir::State "var/lib/apt/";
Dir::State::lists "lists/";
Dir::State::cdroms "cdroms.list";
Dir::State::userstatus "status.user";
Dir::State::status "/var/lib/dpkg/status";
Dir::Cache "var/cache/apt/";
Dir::Cache::archives "archives/";
Dir::Cache::srcpkgcache "srcpkgcache.bin";
Dir::Cache::pkgcache "pkgcache.bin";
Dir::Etc "etc/apt/";
Dir::Etc::sourcelist "sources.list";
Dir::Etc::vendorlist "vendors.list";
Dir::Etc::vendorparts "vendors.list.d";
Dir::Etc::main "apt.conf";
Dir::Etc::parts "apt.conf.d";
Dir::Etc::preferences "preferences";
Dir::Bin "";
Dir::Bin::methods "/usr/lib/apt/methods";
Dir::Bin::dpkg "/usr/bin/dpkg";
DPkg "";
DPkg::Pre-Install-Pkgs "";
DPkg::Pre-Install-Pkgs:: "/usr/sbin/dpkg-preconfigure --apt || true";

-- (no /etc/apt/preferences present) --

-- /etc/apt/sources.list --

# deb ftp://...

Read more...

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sun, 2 Nov 2003 13:49:49 -0500
From: Matt Zimmerman <email address hidden>
To: <email address hidden>
Subject: Re: Bug#218605: apt: misleading dependency problem message

severity 218605 minor
retitle 218605 Error messages for broken packages are not always enlightening
thanks

--
 - mdz

Matt Zimmerman (mdz) on 2006-01-19
Changed in apt:
assignee: mdz → mvo

This just can't be an issue anymore?? The Debian bug is dated back in 2003.....And the Ubuntu one is 1+ years old, without any comments. Reject?

Michael Vogt (mvo) wrote :

We have not touched this code in the last months in a substancial way so it is very likely that this is a issue still. Please do not reject yet (without verifing).

I see this all the time, and I have to agree, it's a pretty odd way to report a package conflict.

Changed in apt:
status: Unconfirmed → Confirmed
Michael Vogt (mvo) on 2009-06-09
Changed in apt (Ubuntu):
assignee: Michael Vogt (mvo) → nobody

Thank you for posting this bug.

Does this occur in Lucid?

Changed in apt (Ubuntu):
status: Confirmed → Incomplete
Philip Muškovac (yofel) wrote :

Seen it on maverick.

Changed in apt (Ubuntu):
status: Incomplete → Confirmed
Vivek Taparia (vivektaparia) wrote :

The following packages have unmet dependencies:

cups-bsd: Depends: libc6 (>= 2.4) but 2.15-0ubuntu13 is installed
          Depends: cups-client (= 1.5.3-1) but 1.5.3-2 is installed
perl: Depends: perl-base (= 5.14.2-11) but 5.14.2-12 is installed
      Depends: perl-modules (>= 5.14.2-11) but 5.14.2-11 is installed
      Depends: zlib1g (>= 1:1.2.3.3.dfsg) but 1:1.2.3.4.dfsg-3ubuntu4 is installed

Vivek Taparia (vivektaparia) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.