apt doesn't handle bar build-deps properly

Bug #1335614 reported by Chow Loong Jin on 2014-06-29
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Undecided
Unassigned

Bug Description

When running "sudo apt-get build-deps banshee" on Ubuntu trusty, this happens:
E: Failed to satisfy Build-Depends dependency for banshee: Installed package libgpod-cil-dev is too new

Banshee's build-deps containing libgpod-cil-dev are:
libgpod-cil-dev (>= 0.8.2-7~), libgpod-cil-dev (<< 0.8.3-2) | libgpod-cil-dev (>= 0.8.3-4ubuntu3~)

and the libgpod-cil-dev version is: 0.8.3-4ubuntu3

The version should be satisfied in this, and in fact, aptitude build-dep works correctly.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers