apt 0.9.15.4ubuntu4 uninstalls ppa:webupd8team/java oracle-java[78]-installer

Bug #1302736 reported by Andrew Skalski on 2014-04-04
264
This bug affects 61 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Undecided
Unassigned

Bug Description

This morning's update to the "apt" package (0.9.15.4ubuntu4) adds sun-java6-jdk to the Breaks/Replaces list for apt. This unfortunately creates a conflict with oracle-java7-installer / oracle-java8-installer from ppa:webupd8team/java, both of which "Provide" sun-java6-jdk:

apt (0.9.15.4ubuntu4) trusty; urgency=low

  Cherry pick fixes from the apt 1.0 branch:

  [ Michael Vogt ]
  * add sun-java{5,6}-jdk to breaks/replaces as that provided a "apt"
    binary as well

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: apt 0.9.15.4ubuntu4
ProcVersionSignature: Ubuntu 3.13.0-22.44-generic 3.13.8
Uname: Linux 3.13.0-22-generic x86_64
ApportVersion: 2.14-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Apr 4 13:38:24 2014
InstallationDate: Installed on 2011-07-09 (1000 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
SourcePackage: apt
UpgradeStatus: Upgraded to trusty on 2014-03-16 (18 days ago)

Andrew Skalski (askalski) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt (Ubuntu):
status: New → Confirmed
Rohan Dhruva (rohandhruva) wrote :

IMO, this is a bug in the webup8 packages: they should not provide or conflict against sun-java6-jdk. Especially not the java7 and java8 installers.

Andrew Skalski (askalski) wrote :

I just sent an email to the maintainer of the webupd8 packages, asking for him to weigh in. While I agree that removing the sun-java6-jdk Provide from the webupd8 installers would indeed resolve the issue, I'm not familiar enough to know what the possible downside might be of doing so.

This bug effects me as well, there is a useful work around provided by "Andy S" on ask ubuntu. http://askubuntu.com/questions/443370/oracle-java8-installer-results-in-apt-removal?noredirect=1#comment580460_443370

Kevin (kevinshlee) wrote :

The workaround was provided by AvatarKava not Andy S.

http://ppa.launchpad.net/webupd8team/java/ubuntu/pool/main/o/oracle-java8-installer/oracle-java8-installer_8u0-1~webupd8~5_all.deb
You can download this file or the one specified here
http://ppa.launchpad.net/webupd8team/java/ubuntu/dists/trusty/main/binary-amd64/Packages
Or
http://ppa.launchpad.net/webupd8team/java/ubuntu/dists/trusty/main/binary-i386/Packages
for 32bit.

Then
sudo dpkg -i --ignore-depends=apt oracle-java8-installer_8u0-1~webupd8~5_all.deb

Kevin (kevinshlee) wrote :

Yet after installing it through the workaround, no more software package can be installed until the JDK8 is removed.

Kevin (kevinshlee) wrote :

I ended up installing the old version of apt downloaded from https://launchpad.net/ubuntu/+source/apt/0.9.15.4ubuntu3/+build/5872859
then locked the version using the synaptic package manager. I guess I just stick with this version until the problem's solved.

Julian Andres Klode (juliank) wrote :

The ppa packages are wrong.

Changed in apt (Ubuntu):
status: Confirmed → Invalid

Yeah, me too. Ubuntu 14.04 x64.webupd8team oracle java 8 jdk failed. Synaptic/apt unistalled webupd8team oracle8 and installed openjdk7.
Then, I uninstanlled openjdk. When trying to reinstall webupd8team oracle8, my postgresql installation has gone and apt was unistalled.

description: updated
Sirius1977 (sirius1977) wrote :

It's not the ppa. There were no sun-java packages from Ubuntu, since Oracle changes the license. So the package name on Ubuntu's side is simpley wrong. It comes with OpenJDK which doesn't came from Oracle.

Changed in apt (Ubuntu):
status: Invalid → Confirmed
Julian Andres Klode (juliank) wrote :

You are right that the breaks do not cover openjdk-6-jdk yet. This needs to be added. The other breaks are correct as well though, because the sun JDKs ship an apt binary as well.

Changed in apt (Ubuntu):
status: Confirmed → Invalid
Julian Andres Klode (juliank) wrote :

It turns out that openjdk-6-jdk (>= 6b24-1.11-0ubuntu1) is not affected, that is precise or newer. So there seems to be no need to add breaks for that as well.

Chris H (harsesus) on 2014-04-05
Changed in apt (Ubuntu):
status: Invalid → Incomplete
Julian Andres Klode (juliank) wrote :

Please do not play around with the bug status. There's nothing incomplete about this bug.

* The packages from the PPA *wrongly* claim to be sun-java6-jdk while being JDK 7 or 8.
* APT *correctly* breaks sun-java5-jdk and sun-java6-jdk, because installing those together would not work, because all three packages provide an APT binary.

There's nothing we can do here. Please contact the PPA provider and ask them to fix their packages.

Please do not reopen the bug or comment on it. Thank you.

Changed in apt (Ubuntu):
status: Incomplete → Invalid
Gao Shichao (xgdgsc) wrote :

Where is sun-java6-jdk in the ubuntu repo (http://packages.ubuntu.com/search?keywords=sun-java6&searchon=names&suite=all&section=all) ? Why apt package need to break it if there is no such package in the repo? Or I didn' t find its existence in the official repo?

Joel Almeida (joelalmeidaptg) wrote :

Cmon guys this really needs to be fixed. I manage to install java6 with the "manual" method but now I cannot install anything else because I have "broken dependencies".

Anders Aagaard (aagaande) wrote :

Yes, it really has to be fixed.. by the people maintaining the third party repository that has the actual bug in it. Ubuntu's core packages can't put in workarounds for bugs in other repositories.

Yeti (bernat-1) wrote :

Anyone can open a bug ticket for the webupd8 team?

QIII (paddyhayes) wrote :

Sorry for one more comment, Julian...

OK folks, we have been given an answer and have been asked not to post further here. This is not a problem with anything Canonical can control.

I've contacted the package manager at webupd8.org. If I get any info or a resolution, I will post it on Ubuntu Forums.

So let's do as Julian asked and stop commenting here.

Thanks to all and thanks to Julian for pointing us in the right direction..

Michael Vogt (mvo) wrote :

I agree with julian about the analysis. But I also think by providing a versionized break/replaces we can make the experiences for the jdk users smoother. The attached patch should ensure we replace the deprectated apt while still keeping the java8 packages on the system (which is ok, it does not contain a apt binary anymore).

Julian Andres Klode (juliank) wrote :

OK everyone, we added a work-around to ignore Provides: sun-java6-jdk. While those are still wrong, this should smoothen the upgrade. Michael will add the patches to trusty soon.

http://anonscm.debian.org/gitweb/?p=apt/apt.git;a=commit;h=5f9dd175b765fe3839f029f39bb42e6136a2326c

Changed in apt (Ubuntu):
status: Invalid → Fix Committed
Michael Vogt (mvo) wrote :

Thanks Julian, I cherry-picked the fix and uploaded the packages to trusty.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.9.15.4ubuntu5

---------------
apt (0.9.15.4ubuntu5) trusty; urgency=low

  [ Julian Andres Klode ]
  * Version the Breaks/Replaces for sun-java{5,6}-jdk
    (LP: #1302736)
  * Add versioned openjdk-6-jdk breaks
 -- Michael Vogt <email address hidden> Mon, 07 Apr 2014 11:40:40 +0200

Changed in apt (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers