13.10 -> 14.04 upgrade failed: initramfs failed to ugprade, udev is not configured yet

Bug #1286161 reported by Darren Hatherley on 2014-02-28
54
This bug affects 6 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
High
Unassigned
Saucy
High
Unassigned
Trusty
High
Unassigned

Bug Description

TEST CASE:
1. Install a minimal saucy 64bit environment (lxc container or VM)
2. Add i386 to the list of architectures
  $ sudo dpkg --add-architecture i386
3. Restore the clone from [1]:
  $ sudo apt-clone restore apt-clone_system_state.tar.gz
4. Upgrade:
  $ sudo do-release-upgrade -d

[1] https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1286161/+attachment/4000804/+files/dist-upgrade.tar.gz

ACTUAL RESULT
Upgrade fails with:
Setting up klibc-utils (2.0.3-0ubuntu1) ...
dpkg: dependency problems prevent configuration of initramfs-tools:
 initramfs-tools depends on udev (>= 147~-5); however:
  Package udev is not configured yet.

dpkg: error processing package initramfs-tools (--configure):
 dependency problems - leaving unconfigured
Setting up libplymouth2:amd64 (0.8.8-0ubuntu15) ...
dpkg: dependency problems prevent configuration of plymouth:
 plymouth depends on initramfs-tools; however:
  Package initramfs-tools is not configured yet.
 plymouth depends on upstart (>= 1.11-0ubuntu3); however:
  Package upstart is not configured yet.
 plymouth depends on udev (>= 166-0ubuntu4); however:
  Package udev is not configured yet.

== Original Description ==
Release upgrade from 13.10 to 14.04 beta 1 failed with this message:

Could not install the upgrades
The upgrade has aborted. Your system could be in an unusable state. A recovery will run now (dpkg --configure -a). Please report this bun in a browser at http://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrade/+filebug and attach the files in /var/log/dist-upgrade/ to the bug report. installArchives() failed.

The update was invoked using kubuntu-devel-release-upgrade.

The files from /var/log/dist-upgrade are attached in the enclosed tar archive. It looks like that dierctory contains some old log files too, but I've included them just in case they're also relevant.

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

From apt-term.log

dpkg: dependency problems prevent configuration of initramfs-tools:
 initramfs-tools depends on udev (>= 147~-5); however:
  Package udev is not configured yet.

dpkg: error processing package initramfs-tools (--configure):
 dependency problems - leaving unconfigured
Setting up libplymouth2:amd64 (0.8.8-0ubuntu15) ...
dpkg: dependency problems prevent configuration of plymouth:
 plymouth depends on initramfs-tools; however:
  Package initramfs-tools is not configured yet.
 plymouth depends on upstart (>= 1.11-0ubuntu3); however:
  Package upstart is not configured yet.
 plymouth depends on udev (>= 166-0ubuntu4); however:
  Package udev is not configured yet.

dpkg: error processing package plymouth (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mountall:
 mountall depends on udev; however:
  Package udev is not configured yet.
 mountall depends on plymouth; however:
  Package plymouth is not configured yet.

dpkg: error processing package mountall (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ifupdown:
 ifupdown depends on initscripts (>= 2.88dsf-25); however:
  Package initscripts is not configured yet.

dpkg: error processing package ifupdown (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.19-0ubuntu2) ...
Errors were encountered while processing:
 initramfs-tools
 plymouth
 mountall
 ifupdown

Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → High
summary: - Release upgrade failed - installArchives() failed
+ 13.10 -> 14.04 upgrade failed: initramfs failed to ugprade, udev is not
+ configured yet
tags: added: dist-upgrade saucy2trusty
Brian Murray (brian-murray) wrote :

I tried using apt-clone to restore the system state of the reporter's system using the apt-clone file enclosed in the attachment and this failed. There were many error messages about from the pkgProblemResolver regarding held packages.

Changed in ubuntu-release-upgrader (Ubuntu):
importance: High → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
disabled (assault64-googlemail) wrote :

Looks like i've got the same issue.
Although, i must admit, package manager did a hell of a job recovering - not only i got working system, i got _actually updated_ system.

Brian Murray (brian-murray) wrote :

Most people experiencing this bug seem to be running Kubuntu.

Jean-Baptiste Lallement (jibel) wrote :

I reproduced this issue with the apt-clone from the OP.

@Brian, you have to enable multi-arch with "dpkg --add-architecture i386" before restoring the clone, otherwise some packages are not installable.

Changed in ubuntu-release-upgrader (Ubuntu):
importance: Medium → High
Changed in ubuntu-release-upgrader (Ubuntu Trusty):
milestone: none → ubuntu-14.04
assignee: nobody → Canonical Foundations Team (canonical-foundations)
description: updated
tags: added: rls-t-tracking
Steve Langasek (vorlon) on 2014-04-02
Changed in ubuntu-release-upgrader (Ubuntu Trusty):
assignee: Canonical Foundations Team (canonical-foundations) → Brian Murray (brian-murray)
Michael Vogt (mvo) wrote :

Fwiw, I can reproduce this with:
"""
dpkg: dependency problems prevent configuration of libqt4-declarative:amd64:^M
 libqt4-declarative:amd64 depends on libqtgui4 (= 4:4.8.5+git192-g085f851+dfsg
-2ubuntu4); however:^M
  Package libqtgui4:amd64 is not configured yet.^M
^M
dpkg: error processing package libqt4-declarative:amd64 (--configure):^M
 dependency problems - leaving unconfigured^M
"""

This is a instace of the apt debian bug #740843, I will cherry pick the fix for this.
Unfortunately we need to SRU it.

Changed in ubuntu-release-upgrader (Ubuntu Trusty):
status: Confirmed → In Progress
Michael Vogt (mvo) wrote :

Here is the debdiff for upstream commit http://anonscm.debian.org/gitweb/?p=apt/apt.git;a=commit;h=0caa5a4c6472d1b74444c4f38ced6c3b89fa50fe

Its not entirely without risk as the change is relatively recent and hasn't yet got that much testing inside debian.

Michael Vogt (mvo) wrote :

I confirmed that when installing the libapt-pkg4.12 1.0 (from debian/unstable) prior to the upgrade the bug is no longer triggered.

tags: added: patch
Michael Vogt (mvo) wrote :

Fwiw, the upgrade works with the attached debdiff in my test-system.

Changed in ubuntu-release-upgrader (Ubuntu Trusty):
assignee: Brian Murray (brian-murray) → Michael Vogt (mvo)
Changed in apt (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → High
Michael Vogt (mvo) on 2014-04-04
Changed in ubuntu-release-upgrader (Ubuntu Saucy):
status: New → Invalid
Changed in apt (Ubuntu Saucy):
status: New → In Progress
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.9.15.4ubuntu4

---------------
apt (0.9.15.4ubuntu4) trusty; urgency=low

  Cherry pick fixes from the apt 1.0 branch:

  [ Michael Vogt ]
  * add sun-java{5,6}-jdk to breaks/replaces as that provided a "apt"
    binary as well

  [ David Kalnischkies ]
  * ensure proper teardown in dpkg error cases (Closes: 738969)
  * use the pretty fullname of a pkg as download desciption
  * cmdline parsing: apt-config is not apt-cdrom
  * do not configure already unpacked packages needlessly (Closes: 740843)
    LP: #1286161

  [ Julian Andres Klode ]
  * Promote xz-utils from apt Suggests to libapt-pkg Depends
 -- Michael Vogt <email address hidden> Fri, 04 Apr 2014 09:08:51 +0200

Changed in apt (Ubuntu Trusty):
status: In Progress → Fix Released

Hello Darren, or anyone else affected,

Accepted apt into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/apt/0.9.9.1~ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in apt (Ubuntu Saucy):
status: In Progress → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

I was able to successfully complete an upgrade using the apt-clone file mentioned in the test case and apt version 0.9.9.1~ubuntu3.1 from saucy-proposed.

Brian Murray (brian-murray) wrote :

Strangely looking at main.log it shows the wrong version of apt being used but installed packages in the apt-clone file shows the correct version. Testing what the release upgrader uses exhibits the same behaviour.

Setting up apt (0.9.9.1~ubuntu3.1) ...
gpg: key 437D05B5: "Ubuntu Archive Automatic Signing Key <email address hidden>" not changed
gpg: key FBB75451: "Ubuntu CD Image Automatic Signing Key <email address hidden>" not changed
gpg: key C0B21F32: "Ubuntu Archive Automatic Signing Key (2012) <email address hidden>" not changed
gpg: key EFE21092: "Ubuntu CD Image Automatic Signing Key (2012) <email address hidden>" not changed
gpg: Total number processed: 4
gpg: unchanged: 4
(saucy-amd64)root@impulse:/home/bdmurray# python -c 'import apt; print apt.apt_pkg.VERSION'
0.9.9.1~ubuntu1

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.9.9.1~ubuntu3.1

---------------
apt (0.9.9.1~ubuntu3.1) saucy-proposed; urgency=low

  * cherry pick upstream commit 0caa5a4c to fix multiarch upgrade
    bug LP: #1286161
 -- Michael Vogt <email address hidden> Thu, 03 Apr 2014 12:49:08 +0200

Changed in apt (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for apt has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in ubuntu-release-upgrader (Ubuntu Trusty):
status: In Progress → Invalid
no longer affects: ubuntu-release-upgrader (Ubuntu Trusty)
no longer affects: ubuntu-release-upgrader (Ubuntu Saucy)
no longer affects: ubuntu-release-upgrader (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers