Comment 2 for bug 113424

Ray Ward (ray-ward4) wrote :

How I fixed this.
Do the following.
sudo rm /var/lib/apt/lists/* -vf
Back it up first of course.
This may not be necessary but you must understand these are the steps I took.
Next do sudo apt-get update
This updates the list folder.
If you get the following error E: Dynamic MMap ran out of room

Its time to edit the config file for apt. Ubuntu users can find this in the following location.
Add the following line.
APT::Cache-Limit "118388608";

Big number.
It started off without the first two digits but I kept getting the same error this fixed it. No more core dumps.
Fire up synaptic. Bang what now?
apt-get -f install synaptic
Response in English your libraries are out of date and your nuts are in a vice try running apt-get -f install on it's own.
This did however work.
apt-get -f install synaptic
Response well it worked. Synaptic now works without error.
You should do an apt-get autoclean as theres a lot of stuff that needs to be cleared out.
Warning always take care when removing files on a live system. This machine has bucket loads of space so reinstalling and moving data to a fresh install does not bother me.