apt resolver doesn't do sensible things when satisfying a cross-dependency on a virtual package (steam, wine)

Bug #1130419 reported by Steve Langasek on 2013-02-19
248
This bug affects 56 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
High
Unassigned
Precise
Critical
Unassigned
Raring
High
Unassigned

Bug Description

[Test Case]
 * Install precise 12.04.2 from the amd64 LTS cd
 * Attempt to install steam, or wine1.4
 * Good behavior: libgl1-mesa-glx-lts-quantal and libgl1-mesa-dri-lts-quantal should be installed
 * Broken behavior: Fails to find a correct resolution because it tries to pull in libgl1-mesa-glx:i386, or even worse it resolves it by uninstalling all the xserver-xorg-lts-quantal packages.

[Regression Potential]
 * I don't expect new bugs to pop up, since this is really a multiarch issue that only pops up because of the enablement stack. The conflict resolution is adjusted to prefer installing packages that we already have for other architectures when Multiarch: same is specified.

[Original bug report]
As a result of the LTS enablement work in 12.04.2, we now have a situation where for the first time, a library dependency of a substantial number of packages in main is satisfied by two different real packages (libgl1-mesa-glx-lts-quantal Provides: libgl1-mesa-glx), and there isn't one right "default" answer to the question of which package should be installed (users who installed 12.04 have one option; users who installed 12.04.2 have a different one).

This interacts quite badly with apt's resolver when cross-installing a multiarch-capable package that also has a dependency on one of these libraries. For example, the steam:i386 package has the following dependencies:

  Depends: libc6, libgl1-mesa-dri, libgl1-mesa-glx, xterm | gnome-terminal, zenity

Since libgl1-mesa-dri and libgl1-mesa-glx are both real packages, apt tries to pull these in by name. However, the libgl1-mesa-glx-lts-quantal:amd64 and libgl1-mesa-dri-lts-quantal:amd64 packages already installed have a Conflicts/Provides on libgl1-mesa-glx and libgl1-mesa-dri respectively, and the conflicts relationship crosses architectures.

It's reported that when installing via software-center, this conflict may even result in removal of the X server. I can't reproduce this myself (since steam64 has now been withdrawn from the software center until the problem can be addressed), but apt is certainly not able to find a solution to this problem on its own:

sudo apt-get -o Debug::pkgProblemResolver=1 install steam
Reading package lists... Done
Building dependency tree
Reading state information... Done
Starting
Starting 2
Investigating (0) libgl1-mesa-dri-lts-quantal [ amd64 ] < 9.0-0ubuntu1~precise4 > ( libs )
Broken libgl1-mesa-dri-lts-quantal:amd64 Conflicts on libgl1-mesa-dri [ i386 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-dri:i386 2 as a solution to libgl1-mesa-dri-lts-quantal:amd64 33
  Added libgl1-mesa-dri:i386 to the remove list
  Conflicts//Breaks against version 8.0.4-0ubuntu0.2 for libgl1-mesa-dri but that is not InstVer, ignoring
  Conflicts//Breaks against version 8.0.2-0ubuntu3 for libgl1-mesa-dri but that is not InstVer, ignoring
  Fixing libgl1-mesa-dri-lts-quantal:amd64 via keep of libgl1-mesa-dri:i386
Investigating (0) libgnome-desktop-3-2 [ amd64 ] < 3.4.2-0ubuntu0.1 > ( libs )
Broken libgnome-desktop-3-2:amd64 Depends on libgl1-mesa-glx [ amd64 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-glx:amd64 14 as a solution to libgnome-desktop-3-2:amd64 30
  Added libgl1-mesa-glx:amd64 to the remove list
Broken libgnome-desktop-3-2:amd64 Depends on libgl1 [ amd64 ] < none > ( none )
  Considering libgl1-mesa-swx11:amd64 0 as a solution to libgnome-desktop-3-2:amd64 30
  Added libgl1-mesa-swx11:amd64 to the remove list
  Fixing libgnome-desktop-3-2:amd64 via keep of libgl1-mesa-glx:amd64
  Fixing libgnome-desktop-3-2:amd64 via keep of libgl1-mesa-swx11:amd64
Investigating (0) gnome-session-bin [ amd64 ] < 3.2.1-0ubuntu8 > ( gnome )
Broken gnome-session-bin:amd64 Depends on libgl1-mesa-glx [ amd64 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-glx:amd64 14 as a solution to gnome-session-bin:amd64 17
  Added libgl1-mesa-glx:amd64 to the remove list
Broken gnome-session-bin:amd64 Depends on libgl1 [ amd64 ] < none > ( none )
  Considering libgl1-mesa-swx11:amd64 0 as a solution to gnome-session-bin:amd64 17
  Added libgl1-mesa-swx11:amd64 to the remove list
  Fixing gnome-session-bin:amd64 via keep of libgl1-mesa-glx:amd64
  Fixing gnome-session-bin:amd64 via keep of libgl1-mesa-swx11:amd64
Investigating (0) x11-utils [ amd64 ] < 7.6+4ubuntu0.1 > ( x11 )
Broken x11-utils:amd64 Depends on libgl1-mesa-glx [ amd64 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-glx:amd64 14 as a solution to x11-utils:amd64 16
  Added libgl1-mesa-glx:amd64 to the remove list
Broken x11-utils:amd64 Depends on libgl1 [ amd64 ] < none > ( none )
  Considering libgl1-mesa-swx11:amd64 0 as a solution to x11-utils:amd64 16
  Added libgl1-mesa-swx11:amd64 to the remove list
  Fixing x11-utils:amd64 via keep of libgl1-mesa-glx:amd64
  Fixing x11-utils:amd64 via keep of libgl1-mesa-swx11:amd64
Investigating (0) libnux-2.0-0 [ amd64 ] < 2.14.1-0ubuntu1 > ( libs )
Broken libnux-2.0-0:amd64 Depends on libgl1-mesa-glx [ amd64 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-glx:amd64 14 as a solution to libnux-2.0-0:amd64 12
  Try Installing libgl1-mesa-glx [ amd64 ] < none -> 8.0.4-0ubuntu0.3 > ( libs ) before changing libnux-2.0-0:amd64
Investigating (0) libglapi-mesa-lts-quantal [ amd64 ] < 9.0-0ubuntu1~precise4 > ( libs )
Broken libglapi-mesa-lts-quantal:amd64 Conflicts on libglapi-mesa [ amd64 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libglapi-mesa:amd64 0 as a solution to libglapi-mesa-lts-quantal:amd64 5
  Added libglapi-mesa:amd64 to the remove list
  Conflicts//Breaks against version 8.0.4-0ubuntu0.2 for libglapi-mesa but that is not InstVer, ignoring
  Conflicts//Breaks against version 8.0.2-0ubuntu3 for libglapi-mesa but that is not InstVer, ignoring
Broken libglapi-mesa-lts-quantal:amd64 Conflicts on libglapi-mesa [ i386 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libglapi-mesa:i386 0 as a solution to libglapi-mesa-lts-quantal:amd64 5
  Added libglapi-mesa:i386 to the remove list
  Conflicts//Breaks against version 8.0.4-0ubuntu0.2 for libglapi-mesa but that is not InstVer, ignoring
  Conflicts//Breaks against version 8.0.2-0ubuntu3 for libglapi-mesa but that is not InstVer, ignoring
  Fixing libglapi-mesa-lts-quantal:amd64 via keep of libglapi-mesa:amd64
  Fixing libglapi-mesa-lts-quantal:amd64 via keep of libglapi-mesa:i386
Investigating (0) libqt4-opengl [ amd64 ] < 4:4.8.1-0ubuntu4.3 -> 4:4.8.1-0ubuntu4.4 > ( libs )
Broken libqt4-opengl:amd64 Depends on libqtcore4 [ amd64 ] < 4:4.8.1-0ubuntu4.3 -> 4:4.8.1-0ubuntu4.4 > ( libs ) (= 4:4.8.1-0ubuntu4.4)
  Considering libqtcore4:amd64 93 as a solution to libqt4-opengl:amd64 4
  Holding Back libqt4-opengl:amd64 rather than change libqtcore4:amd64
Investigating (0) libgl1-mesa-glx [ i386 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
Broken libgl1-mesa-glx:i386 Depends on libglapi-mesa [ i386 ] < none -> 8.0.4-0ubuntu0.3 > ( libs ) (= 8.0.4-0ubuntu0.3)
  Considering libglapi-mesa:i386 0 as a solution to libgl1-mesa-glx:i386 1
  Holding Back libgl1-mesa-glx:i386 rather than change libglapi-mesa:i386
Investigating (0) xserver-xorg-lts-quantal [ amd64 ] < 1:7.7+1ubuntu4~precise1 > ( x11 )
Broken xserver-xorg-lts-quantal:amd64 Conflicts on libgl1-mesa-dri [ amd64 ] < none -> 8.0.4-0ubuntu0.3 > ( libs ) (>= 0~)
  Considering libgl1-mesa-dri:amd64 1 as a solution to xserver-xorg-lts-quantal:amd64 0
  Removing xserver-xorg-lts-quantal:amd64 rather than change libgl1-mesa-dri:amd64
Investigating (1) steam [ i386 ] < none -> 1.0.0.27ubuntu1 > ( games )
Broken steam:i386 Depends on libgl1-mesa-dri [ i386 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-dri:i386 2 as a solution to steam:i386 9999
  Re-Instated libgl1-mesa-dri:i386
Broken steam:i386 Depends on libgl1-mesa-glx [ i386 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-glx:i386 1 as a solution to steam:i386 9999
  Re-Instated libglapi-mesa:i386
  Re-Instated libgl1-mesa-glx:i386
Investigating (1) libgl1-mesa-dri-lts-quantal [ amd64 ] < 9.0-0ubuntu1~precise4 > ( libs )
Broken libgl1-mesa-dri-lts-quantal:amd64 Conflicts on libgl1-mesa-dri [ amd64 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-dri:amd64 1 as a solution to libgl1-mesa-dri-lts-quantal:amd64 33
  Added libgl1-mesa-dri:amd64 to the remove list
  Conflicts//Breaks against version 8.0.4-0ubuntu0.2 for libgl1-mesa-dri but that is not InstVer, ignoring
  Conflicts//Breaks against version 8.0.2-0ubuntu3 for libgl1-mesa-dri but that is not InstVer, ignoring
Broken libgl1-mesa-dri-lts-quantal:amd64 Conflicts on libgl1-mesa-dri [ i386 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-dri:i386 2 as a solution to libgl1-mesa-dri-lts-quantal:amd64 33
  Added libgl1-mesa-dri:i386 to the remove list
  Conflicts//Breaks against version 8.0.4-0ubuntu0.2 for libgl1-mesa-dri but that is not InstVer, ignoring
  Conflicts//Breaks against version 8.0.2-0ubuntu3 for libgl1-mesa-dri but that is not InstVer, ignoring
  Fixing libgl1-mesa-dri-lts-quantal:amd64 via keep of libgl1-mesa-dri:amd64
  Fixing libgl1-mesa-dri-lts-quantal:amd64 via keep of libgl1-mesa-dri:i386
Investigating (1) libgl1-mesa-glx [ amd64 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
Broken libgl1-mesa-glx:amd64 Depends on libglapi-mesa [ amd64 ] < none -> 8.0.4-0ubuntu0.3 > ( libs ) (= 8.0.4-0ubuntu0.3)
  Considering libglapi-mesa:amd64 0 as a solution to libgl1-mesa-glx:amd64 14
  Holding Back libgl1-mesa-glx:amd64 rather than change libglapi-mesa:amd64
Investigating (1) libnux-2.0-0 [ amd64 ] < 2.14.1-0ubuntu1 > ( libs )
Broken libnux-2.0-0:amd64 Depends on libgl1-mesa-glx [ amd64 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-glx:amd64 14 as a solution to libnux-2.0-0:amd64 12
  Try Installing libgl1-mesa-glx [ amd64 ] < none -> 8.0.4-0ubuntu0.3 > ( libs ) before changing libnux-2.0-0:amd64
Investigating (1) libglapi-mesa-lts-quantal [ amd64 ] < 9.0-0ubuntu1~precise4 > ( libs )
Broken libglapi-mesa-lts-quantal:amd64 Conflicts on libglapi-mesa [ amd64 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libglapi-mesa:amd64 0 as a solution to libglapi-mesa-lts-quantal:amd64 5
  Added libglapi-mesa:amd64 to the remove list
  Conflicts//Breaks against version 8.0.4-0ubuntu0.2 for libglapi-mesa but that is not InstVer, ignoring
  Conflicts//Breaks against version 8.0.2-0ubuntu3 for libglapi-mesa but that is not InstVer, ignoring
Broken libglapi-mesa-lts-quantal:amd64 Conflicts on libglapi-mesa [ i386 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libglapi-mesa:i386 0 as a solution to libglapi-mesa-lts-quantal:amd64 5
  Added libglapi-mesa:i386 to the remove list
  Conflicts//Breaks against version 8.0.4-0ubuntu0.2 for libglapi-mesa but that is not InstVer, ignoring
  Conflicts//Breaks against version 8.0.2-0ubuntu3 for libglapi-mesa but that is not InstVer, ignoring
  Fixing libglapi-mesa-lts-quantal:amd64 via keep of libglapi-mesa:amd64
  Fixing libglapi-mesa-lts-quantal:amd64 via keep of libglapi-mesa:i386
 Try to Re-Instate (1) libqt4-opengl:amd64
Investigating (1) libgl1-mesa-glx [ i386 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
Broken libgl1-mesa-glx:i386 Depends on libglapi-mesa [ i386 ] < none -> 8.0.4-0ubuntu0.3 > ( libs ) (= 8.0.4-0ubuntu0.3)
  Considering libglapi-mesa:i386 0 as a solution to libgl1-mesa-glx:i386 1
  Holding Back libgl1-mesa-glx:i386 rather than change libglapi-mesa:i386
Investigating (1) xorg [ amd64 ] < 1:7.6+12ubuntu2 > ( x11 )
Broken xorg:amd64 Depends on xserver-xorg [ amd64 ] < none -> 1:7.6+12ubuntu2 > ( x11 ) (>= 1:7.6+12ubuntu2)
  Considering xserver-xorg:amd64 3 as a solution to xorg:amd64 1
  Try Installing xserver-xorg [ amd64 ] < none -> 1:7.6+12ubuntu2 > ( x11 ) before changing xorg:amd64
Broken xorg:amd64 Depends on xserver-xorg-renamed [ amd64 ] < none > ( none )
  Considering xserver-xorg-lts-quantal:amd64 0 as a solution to xorg:amd64 1
  Added xserver-xorg-lts-quantal:amd64 to the remove list
  Fixing xorg:amd64 via keep of xserver-xorg-lts-quantal:amd64
Investigating (1) xserver-xorg-lts-quantal [ amd64 ] < 1:7.7+1ubuntu4~precise1 > ( x11 )
Broken xserver-xorg-lts-quantal:amd64 Depends on xserver-xorg-core-lts-quantal [ amd64 ] < 2:1.13.0-0ubuntu6.1~precise2 > ( x11 ) (>= 2:1.11)
  Considering xserver-xorg-core-lts-quantal:amd64 54 as a solution to xserver-xorg-lts-quantal:amd64 0
  Removing xserver-xorg-lts-quantal:amd64 rather than change xserver-xorg-core-lts-quantal:amd64
Investigating (2) steam [ i386 ] < none -> 1.0.0.27ubuntu1 > ( games )
Broken steam:i386 Depends on libgl1-mesa-dri [ i386 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-dri:i386 2 as a solution to steam:i386 9999
  Considering libgl1-mesa-dri:i386 2 as a solution to steam:i386 9999
  Considering libgl1-mesa-dri:i386 2 as a solution to steam:i386 9999
  Considering libgl1-mesa-dri-lts-quantal:i386 0 as a solution to steam:i386 9999
  Re-Instated libdrm-nouveau2:i386
  Re-Instated libglapi-mesa-lts-quantal:i386
  Re-Instated libllvm3.1:i386
  Re-Instated libgl1-mesa-dri-lts-quantal:i386
Broken steam:i386 Depends on libgl1-mesa-glx [ i386 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-glx:i386 1 as a solution to steam:i386 9999
  Considering libgl1-mesa-glx:i386 1 as a solution to steam:i386 9999
  Considering libgl1-mesa-glx:i386 1 as a solution to steam:i386 9999
  Considering libgl1-mesa-glx-lts-quantal:i386 0 as a solution to steam:i386 9999
  Re-Instated libgl1-mesa-glx-lts-quantal:i386
Investigating (2) libgl1-mesa-glx [ amd64 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
Broken libgl1-mesa-glx:amd64 Depends on libglapi-mesa [ amd64 ] < none -> 8.0.4-0ubuntu0.3 > ( libs ) (= 8.0.4-0ubuntu0.3)
  Considering libglapi-mesa:amd64 0 as a solution to libgl1-mesa-glx:amd64 14
  Holding Back libgl1-mesa-glx:amd64 rather than change libglapi-mesa:amd64
Investigating (2) libnux-2.0-0 [ amd64 ] < 2.14.1-0ubuntu1 > ( libs )
Broken libnux-2.0-0:amd64 Depends on libgl1-mesa-glx [ amd64 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-glx:amd64 14 as a solution to libnux-2.0-0:amd64 12
  Try Installing libgl1-mesa-glx [ amd64 ] < none -> 8.0.4-0ubuntu0.3 > ( libs ) before changing libnux-2.0-0:amd64
Investigating (2) xorg [ amd64 ] < 1:7.6+12ubuntu2 > ( x11 )
Broken xorg:amd64 Depends on xserver-xorg [ amd64 ] < none -> 1:7.6+12ubuntu2 > ( x11 ) (>= 1:7.6+12ubuntu2)
  Considering xserver-xorg:amd64 3 as a solution to xorg:amd64 1
  Try Installing xserver-xorg [ amd64 ] < none -> 1:7.6+12ubuntu2 > ( x11 ) before changing xorg:amd64
Investigating (3) steam [ i386 ] < none -> 1.0.0.27ubuntu1 > ( games )
Broken steam:i386 Depends on libgl1-mesa-dri [ i386 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-dri:i386 2 as a solution to steam:i386 9999
  Considering libgl1-mesa-dri:i386 2 as a solution to steam:i386 9999
  Considering libgl1-mesa-dri:i386 2 as a solution to steam:i386 9999
  Considering libgl1-mesa-dri-lts-quantal:i386 0 as a solution to steam:i386 9999
Broken steam:i386 Depends on libgl1-mesa-glx [ i386 ] < none -> 8.0.4-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-glx:i386 1 as a solution to steam:i386 9999
  Considering libgl1-mesa-glx:i386 1 as a solution to steam:i386 9999
  Considering libgl1-mesa-glx:i386 1 as a solution to steam:i386 9999
  Considering libgl1-mesa-glx-lts-quantal:i386 0 as a solution to steam:i386 9999
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 steam:i386 : Depends: libgl1-mesa-dri:i386
              Depends: libgl1-mesa-glx:i386
E: Unable to correct problems, you have held broken packages.

Getting a correct result requires the following:

$ sudo apt-get install libgl1-mesa-dri-lts-quantal:i386 libglapi-mesa-lts-quantal:i386 libgl1-mesa-glx-lts-quantal:i386 steam

Since we don't have enough information to say with certainty that all Conflicts from packages of a different architecture can be ignored, it seems we need apt's resolver to be smarter, and possibly give priority to implementors of virtual packages that are already installed for a different architecture when trying to satisfy dependencies.

Steve Langasek (vorlon) on 2013-02-19
Changed in apt (Ubuntu Precise):
importance: Undecided → Critical
Changed in apt (Ubuntu Quantal):
importance: Undecided → Critical
importance: Critical → High
Changed in apt (Ubuntu Raring):
importance: Undecided → High
status: New → Confirmed
status: Confirmed → Triaged
Changed in apt (Ubuntu Quantal):
status: New → Triaged
Changed in apt (Ubuntu Precise):
status: New → Triaged
David Kalnischkies (donkult) wrote :

(*-quantal sounds like a hack rather than a good solution, but so it be …)

Attached patch should prefer installing an other architecture of a M-A: same package (for the lake of a sensible term, lets call it sibling) if at least one architecture-sibling is already installed over everything else. As I haven't really tested it and I am not really active currently, it might kill your pet instead though.

Colin Watson (cjwatson) wrote :

I haven't done any broad testing, but this patch at least fixes the steam64 case. Thanks!

We should perhaps add a test case too ...

David Pitkin (dpitkin) on 2013-02-21
tags: added: ca-escalated
description: updated
Maarten Lankhorst (mlankhorst) wrote :

It seems to fail to install wine1.4 still.

Maarten Lankhorst (mlankhorst) wrote :

Still fails with that patch, the steps I'm doing:

pbuilder-dist precise amd64 login
mkdir -p "$HOME"
apt-get install vim wget xserver-xorg-lts-quantal
add all the deb-src lines to /etc/apt/sources.list
apt-get update
apt-get build-dep apt
apt-get source apt
cd apt*/
wget 'https://launchpadlibrarian.net/131840510/apt-lp-1130419-prefer-ma-same-siblings' -O- | patch -Np0
dpkg-buildpackage -b
cd ..
dpkg -i *.deb

apt-get install wine1.4

David Kalnischkies (donkult) wrote :

> We should perhaps add a test case too ...

Indeed. Polished a bit over mine and attached it now. All tests are happy with my patch, but they tend to be rather simple so I would have been more surprised if not.

Beware: The CompareProviders functoid the patch modifies isn't present for too long; I think I added it between P and Q. Might therefore be hard to backport this to P (could have the benefit of fixing other M-A corner cases though).

Maarten Lankhorst (mlankhorst) wrote :

This only seems to happen when libgl1-mesa-glx-lts-quantal:amd64 was not installed, for some reason despite being in recommends it wasn't installed in the pbuilder chroot. Manually fixing this allows wine1.4 to install correctly. So the fix works for me! :D

I guess the fix would be using apt-get install --install-recommends xserver-xorg-lts-quantal instead of apt-get install xserver-xorg-lts-quantalin the above thing.

Doug McMahon (mc3man) wrote :

As requested today in duped bug by Maarten -
(though maybe a moot point?? from prior comment

Tested 12.04.2 with a patched apt, wine installed fine adding the needed lts-quantal :i386 packages so the patch does work.
Used synaptic which would have behaved the same as USC, offering to install but removing all the lts-quantal packages
(& doing a poor job of replacing so a fix soon is well advised

Didn't try steam but will assume it would be ok as prior to patch steam did install & work fine, one would get a 'nag' terminal requesting install of libgl1-mesa-glx, ect. that could be dismissed.

Abhisek Mukherjee (abhisek) wrote :

Getting a correct result requires the following:

$ sudo apt-get install libgl1-mesa-dri-lts-quantal:i386 libglapi-mesa-lts-quantal:i386 libgl1-mesa-glx-lts-quantal:i386 steam

This fixes the installation correctly. Thank You!!

Dave Morley (davmor2) on 2013-02-25
tags: added: u1-on-production
ruediix@gmail.com (ruedii) wrote :

The dependencies tree seem to be severely broken on mesa-lts-quantel.

If I try to install it, they produce issues by asking to uninstall a huge list of packages.

ruediix@gmail.com (ruedii) wrote :

It seems to install tolerably once I run PPA-Purge on X-Swat updates.

However, there are still two programs that it uninstalls uneccessarily: GLMemPerf, and GLmark2ES

On 26/02/2013 14:59, <email address hidden> wrote:
> The dependencies tree seem to be severely broken on mesa-lts-quantel.
>
> If I try to install it, they produce issues by asking to uninstall a
> huge list of packages.

That's exactly what this bug is trying to resolve.

--
Kind regards,
Loong Jin

pulq (pulq-ustc) wrote :

>Getting a correct result requires the following:

>$ sudo apt-get install libgl1-mesa-dri-lts-quantal:i386 libglapi-mesa-lts-quantal:i386 libgl1-mesa-glx-lts-quantal:i386

it does not work for me.

Chow Loong Jin (hyperair) wrote :

On 28/02/2013 11:14, pulq wrote:
>> Getting a correct result requires the following:
>
>> $ sudo apt-get install libgl1-mesa-dri-lts-quantal:i386 libglapi-mesa-
> lts-quantal:i386 libgl1-mesa-glx-lts-quantal:i386
>
> it does not work for me.

If you scroll to the top, the bug status is still marked as triaged, not fix
released. Please be patient.

--
Kind regards,
Loong Jin

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.9.7.7ubuntu2

---------------
apt (0.9.7.7ubuntu2) raring; urgency=low

  * Cherry-pick from David's sid branch to fix a multiarch library
    installation problem:

  [ David Kalnischkies ]
  * apt-pkg/depcache.cc:
    - prefer to install packages which have an already installed M-A:same
      sibling while choosing providers (LP: #1130419)
 -- Steve Langasek <email address hidden> Fri, 01 Mar 2013 17:55:03 -0800

Changed in apt (Ubuntu Raring):
status: Triaged → Fix Released

Hello Steve, or anyone else affected,

Accepted apt into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/apt/0.8.16~exp12ubuntu10.9 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in apt (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
Doug McMahon (mc3man) wrote :

Using amd64 build of apt 0.8.16~exp12ubuntu10.9 on 12.04.2 lts stack with no i386: packages installed both wine & steam installed successfully with no issues or removals.
(tested both separately with same starting position of no i386 packages installed.

The only issue that will come up is that when *running* steam users will get a pop up terminal requesting the install of -
libgl1-mesa-dri:i386 & libgl1-mesa-glx:i386
Probably due to steam when starting running some updater script(s) that only look for those 2 packages??

The terminal can be dismissed & steam then updates/runs fine but if the user accepts the above installs then they'll likely end up with an unbootable install unless they make sure all needed lts-quantal packages are replaced with equivalent non lts ones which won't happen automatically.
This seems beyond the scope of this bug so tagging verification-done (in 12.04.2

tags: added: verification-done
removed: verification-needed
Doug McMahon (mc3man) wrote :

On 05/03/2013 08:52, Doug McMahon wrote:
> The only issue that will come up is that when *running* steam users will get
> a pop up terminal requesting the install of - libgl1-mesa-dri:i386 &
> libgl1-mesa-glx:i386 Probably due to steam when starting running some updater
> script(s) that only look for those 2 packages??

It seems that the steamdeps script looks for xserver-xorg-core-lts-quantal and
bases its decision on whether to install the libgl1-mesa-{dri,glx}:i386 or
libgl1-mesa-{dri,glx}-lts-quantal:i386 package. Could you check if that package
is installed on your system?

--
Kind regards,
Loong Jin

Doug McMahon (mc3man) wrote :

On 03/04/2013 09:49 PM, Chow Loong Jin wrote:
> On 05/03/2013 08:52, Doug McMahon wrote:
>> The only issue that will come up is that when *running* steam users will get
>> a pop up terminal requesting the install of - libgl1-mesa-dri:i386 &
>> libgl1-mesa-glx:i386 Probably due to steam when starting running some updater
>> script(s) that only look for those 2 packages??
> It seems that the steamdeps script looks for xserver-xorg-core-lts-quantal and
> bases its decision on whether to install the libgl1-mesa-{dri,glx}:i386 or
> libgl1-mesa-{dri,glx}-lts-quantal:i386 package. Could you check if that package
> is installed on your system?
>
Sorry - didn't notice that there was a new steam launcher, starting over
& using that one works just fine.
(installs curl, then on 1st. run installs the proper lts-quantal packages.
So all good here.

Chow Loong Jin (hyperair) wrote :

On 05/03/2013 11:20, Doug McMahon wrote:
>> >
> Sorry - didn't notice that there was a new steam launcher, starting over
> & using that one works just fine.
> (installs curl, then on 1st. run installs the proper lts-quantal packages.
> So all good here.

Great, thanks for confirming that.

--
Kind regards,
Loong Jin

Fabri Velas (fabrivelas) wrote :

I just upgraded this package in order to install wine (in synaptic), but there are still the following packages to be removed:
xserver-xorg-video-all-lts-quantal
xserver-xorg-video-ati-lts-quantal
xserver-xorg-video-intel-lts-quantal
xdiagnose
ubuntu-desktop
radeontool
intel-gpu-tools
This issue, however, is resolved for skype and acroread.

Steve Langasek (vorlon) wrote :

Fabri,

I can't reproduce this issue locally with the apt from -proposed (and can reproduce it with the apt from -updates). If you can reproduce it, please provide a transcript of apt running with '-o Debug::pkgProblemResolver=1'.

Download full text (14.9 KiB)

Just tested with the new proposed version, ia32-libs will still be removed

Reading package lists... Done
Building dependency tree
Reading state information... Done
Starting
Starting 2
Investigating (0) libvisual-0.4-plugins [ i386 ] < 0.4.0.dfsg.1-7 > ( sound )
Broken libvisual-0.4-plugins:i386 Depends on libgl1-mesa-glx [ i386 ] < 8.0.4-0ubuntu0.4 > ( libs )
  Considering libgl1-mesa-glx:i386 4 as a solution to libvisual-0.4-plugins:i386 3
Broken libvisual-0.4-plugins:i386 Depends on libgl1 [ i386 ] < none > ( none )
  Considering libgl1-mesa-swx11:i386 0 as a solution to libvisual-0.4-plugins:i386 3
  Added libgl1-mesa-swx11:i386 to the remove list
  Fixing libvisual-0.4-plugins:i386 via keep of libgl1-mesa-swx11:i386
Investigating (0) libglu1-mesa [ i386 ] < 8.0.4-0ubuntu0.4 > ( libs )
Broken libglu1-mesa:i386 Depends on libgl1-mesa-glx [ i386 ] < 8.0.4-0ubuntu0.4 > ( libs )
  Considering libgl1-mesa-glx:i386 4 as a solution to libglu1-mesa:i386 3
Broken libglu1-mesa:i386 Depends on libgl1 [ i386 ] < none > ( none )
  Considering libgl1-mesa-swx11:i386 0 as a solution to libglu1-mesa:i386 3
  Added libgl1-mesa-swx11:i386 to the remove list
  Fixing libglu1-mesa:i386 via keep of libgl1-mesa-swx11:i386
Investigating (0) libqt4-opengl [ i386 ] < 4:4.8.1-0ubuntu4.4 > ( libs )
Broken libqt4-opengl:i386 Depends on libgl1-mesa-glx [ i386 ] < 8.0.4-0ubuntu0.4 > ( libs )
  Considering libgl1-mesa-glx:i386 4 as a solution to libqt4-opengl:i386 2
Broken libqt4-opengl:i386 Depends on libgl1 [ i386 ] < none > ( none )
  Considering libgl1-mesa-swx11:i386 0 as a solution to libqt4-opengl:i386 2
  Added libgl1-mesa-swx11:i386 to the remove list
  Fixing libqt4-opengl:i386 via keep of libgl1-mesa-swx11:i386
Investigating (0) xserver-xorg-video-qxl [ amd64 ] < 0.0.16-2ubuntu0.1 > ( x11 )
Broken xserver-xorg-video-qxl:amd64 Depends on xorg-video-abi-11 [ amd64 ] < none > ( none )
  Considering xserver-xorg-core:amd64 1 as a solution to xserver-xorg-video-qxl:amd64 0
  Removing xserver-xorg-video-qxl:amd64 rather than change xorg-video-abi-11:amd64
Investigating (0) ia32-libs-multiarch [ i386 ] < 20090808ubuntu36 > ( universe/libs )
Broken ia32-libs-multiarch:i386 Depends on libglapi-mesa [ i386 ] < 8.0.4-0ubuntu0.4 > ( libs )
  Considering libglapi-mesa:i386 1 as a solution to ia32-libs-multiarch:i386 -1
  Removing ia32-libs-multiarch:i386 rather than change libglapi-mesa:i386
Investigating (1) libvisual-0.4-plugins [ i386 ] < 0.4.0.dfsg.1-7 > ( sound )
Broken libvisual-0.4-plugins:i386 Depends on libgl1-mesa-glx [ i386 ] < 8.0.4-0ubuntu0.4 > ( libs )
  Considering libgl1-mesa-glx:i386 4 as a solution to libvisual-0.4-plugins:i386 3
Broken libvisual-0.4-plugins:i386 Depends on libgl1 [ i386 ] < none > ( none )
  Considering libgl1-mesa-swx11:i386 0 as a solution to libvisual-0.4-plugins:i386 3
  Added libgl1-mesa-swx11:i386 to the remove list
  Fixing libvisual-0.4-plugins:i386 via keep of libgl1-mesa-swx11:i386
Investigating (1) libglu1-mesa [ i386 ] < 8.0.4-0ubuntu0.4 > ( libs )
Broken libglu1-mesa:i386 Depends on libgl1-mesa-glx [ i386 ] < 8.0.4-0ubuntu0.4 > ( libs )
  Considering libgl1-mesa-glx:i386 4 as a solution to libglu1-mesa:i386 3
Bro...

Steve Langasek (vorlon) wrote :

On Wed, Mar 06, 2013 at 06:03:20PM -0000, Cedric wrote:
> Just tested with the new proposed version, ia32-libs will still be
> removed

Please include the command you're running, not just the output.

Jonathan Reed (jdreed) wrote :

I was having a similar problem, in that installing ia32-libs wanted to remove the xorg quantal-lts packages. I just tested with apt 0.8.16~exp12ubuntu10.9 from proposed, and apt-get no longer wants to remove the quantal-lts xorg packages.

Fabri Velas (fabrivelas) wrote :
Download full text (10.0 KiB)

Thanks Steve, here is the output from the command with the debugging info:
version of apt: 0.8.16~exp12ubuntu10.9 (precise-proposed)
Linux 3.5.0-26-generic #40~precise1-Ubuntu SMP Thu Feb 28 13:48:15 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

First for wine:
sudo apt-get -o Debug::pkgProblemResolver=1 install wine
Reading package lists... Done
Building dependency tree
Reading state information... Done
Starting
Starting 2
Investigating (0) libcanberra0 [ amd64 ] < 0.28-3ubuntu3 > ( libs )
Broken libcanberra0:amd64 Depends on libasound2 [ amd64 ] < 1.0.25-1ubuntu10.2 > ( libs ) (>= 1.0.23)
  Considering libasound2:amd64 25 as a solution to libcanberra0:amd64 72
  Added libasound2:amd64 to the remove list
  Fixing libcanberra0:amd64 via keep of libasound2:amd64
Investigating (0) libasound2 [ amd64 ] < 1.0.25-1ubuntu10.2 > ( libs )
Broken libasound2:amd64 Breaks on libasound2 [ i386 ] < none -> 1.0.25-1ubuntu10.1 > ( libs ) (!= 1.0.25-1ubuntu10.2)
  Considering libasound2:i386 0 as a solution to libasound2:amd64 25
  Added libasound2:i386 to the remove list
  Conflicts//Breaks against version 1.0.25-1ubuntu10 for libasound2 but that is not InstVer, ignoring
  Fixing libasound2:amd64 via keep of libasound2:i386
Investigating (0) po-debconf [ amd64 ] < 1.0.16+nmu2ubuntu1 > ( devel )
Broken po-debconf:amd64 Depends on gettext [ amd64 ] < 0.18.1.1-5ubuntu3 > ( devel ) (>= 0.16)
  Considering gettext:amd64 3 as a solution to po-debconf:amd64 12
  Added gettext:amd64 to the remove list
  Fixing po-debconf:amd64 via keep of gettext:amd64
Investigating (0) grub-common [ amd64 ] < 1.99-21ubuntu3.9 > ( admin )
Broken grub-common:amd64 Depends on gettext-base [ amd64 ] < 0.18.1.1-5ubuntu3 > ( utils )
  Considering gettext-base:amd64 4 as a solution to grub-common:amd64 11
  Added gettext-base:amd64 to the remove list
  Fixing grub-common:amd64 via keep of gettext-base:amd64
Investigating (0) gettext-base [ amd64 ] < 0.18.1.1-5ubuntu3 > ( utils )
Broken gettext-base:amd64 Conflicts on gettext-base [ i386 ] < none -> 0.18.1.1-5ubuntu3 > ( utils )
  Considering gettext-base:i386 2 as a solution to gettext-base:amd64 4
  Added gettext-base:i386 to the remove list
  Fixing gettext-base:amd64 via keep of gettext-base:i386
Investigating (0) gettext [ amd64 ] < 0.18.1.1-5ubuntu3 > ( devel )
Broken gettext:amd64 Conflicts on gettext [ i386 ] < none -> 0.18.1.1-5ubuntu3 > ( devel )
  Considering gettext:i386 0 as a solution to gettext:amd64 3
  Added gettext:i386 to the remove list
  Fixing gettext:amd64 via keep of gettext:i386
Investigating (0) wine1.4-i386 [ i386 ] < none -> 1.4-0ubuntu4.1 > ( universe/otherosfs )
Broken wine1.4-i386:i386 Depends on libasound2 [ i386 ] < none -> 1.0.25-1ubuntu10.1 > ( libs ) (>= 1.0.23)
  Considering libasound2:i386 0 as a solution to wine1.4-i386:i386 0
  Holding Back wine1.4-i386:i386 rather than change libasound2:i386
Investigating (1) wine1.4 [ amd64 ] < none -> 1.4-0ubuntu4.1 > ( universe/otherosfs )
Broken wine1.4:amd64 Depends on wine1.4-i386 [ amd64 ] < none > ( none ) (= 1.4-0ubuntu4.1)
  Considering wine1.4-i386:i386 0 as a solution to wine1.4:amd64 3
  Holding Back wine1.4:amd64 rather than change wine1.4-i386:amd6...

Steve Langasek (vorlon) wrote :

On Thu, Mar 07, 2013 at 11:11:34PM -0000, Fabri Velas wrote:
> Broken libcanberra0:amd64 Depends on libasound2 [ amd64 ] < 1.0.25-1ubuntu10.2 > ( libs ) (>= 1.0.23)
> Considering libasound2:amd64 25 as a solution to libcanberra0:amd64 72
> Added libasound2:amd64 to the remove list
> Fixing libcanberra0:amd64 via keep of libasound2:amd64
> Investigating (0) libasound2 [ amd64 ] < 1.0.25-1ubuntu10.2 > ( libs )
> Broken libasound2:amd64 Breaks on libasound2 [ i386 ] < none -> 1.0.25-1ubuntu10.1 > ( libs ) (!= 1.0.25-1ubuntu10.2)
> Considering libasound2:i386 0 as a solution to libasound2:amd64 25
> Added libasound2:i386 to the remove list
> Conflicts//Breaks against version 1.0.25-1ubuntu10 for libasound2 but that is not InstVer, ignoring
> Fixing libasound2:amd64 via keep of libasound2:i386

Ok, this is an issue that's unrelated to the apt change. There is a new
version of libasound2 in precise-proposed, but you have the old version of
libasound2 from precise-updates installed for amd64, and apt doesn't manage
to pick a solution that upgrades libasound2:amd64 before installing
libasound2:i386.

This is an issue specific to having -proposed enabled but not having
upgraded all your packages to it. To avoid this issue, once you've
installed the apt from -proposed you can re-disable -proposed in your
software properties; then you should be able to install wine (and skype)
without problems.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Fabri Velas (fabrivelas) wrote :

Thanks Steve. It seems to work now but when -proposed is enabled!?! I am a bit confused...

Fabri Velas (fabrivelas) wrote :

...ah, and only if -proposed is enabled. If I disable it I get the error?!?

Steve Langasek (vorlon) wrote :

On Fri, Mar 08, 2013 at 09:04:41AM -0000, Fabri Velas wrote:
> Thanks Steve. It seems to work now but when -proposed is enabled!?! I
> am a bit confused...

That suggests that, in the meantime, you've updated to the -proposed version
of libasound2:amd64, so now the library versions match only *with* -proposed
enabled.

So:

re-enable -proposed
install the packages you want
re-disable -proposed

that way you don't keep getting unrelated pre-release software pulled into
your system.

Download full text (15.0 KiB)

Just tested with the new proposed version, ia32-libs will still be removed.

sudo apt-get -o Debug::pkgProblemResolver=1 install xserver-xorg-lts-quantal

Reading package lists... Done
Building dependency tree
Reading state information... Done
Starting
Starting 2
Investigating (0) libvisual-0.4-plugins [ i386 ] < 0.4.0.dfsg.1-7 > ( sound )
Broken libvisual-0.4-plugins:i386 Depends on libgl1-mesa-glx [ i386 ] < 8.0.4-0ubuntu0.4 > ( libs )
  Considering libgl1-mesa-glx:i386 4 as a solution to libvisual-0.4-plugins:i386 3
Broken libvisual-0.4-plugins:i386 Depends on libgl1 [ i386 ] < none > ( none )
  Considering libgl1-mesa-swx11:i386 0 as a solution to libvisual-0.4-plugins:i386 3
  Added libgl1-mesa-swx11:i386 to the remove list
  Fixing libvisual-0.4-plugins:i386 via keep of libgl1-mesa-swx11:i386
Investigating (0) libglu1-mesa [ i386 ] < 8.0.4-0ubuntu0.4 > ( libs )
Broken libglu1-mesa:i386 Depends on libgl1-mesa-glx [ i386 ] < 8.0.4-0ubuntu0.4 > ( libs )
  Considering libgl1-mesa-glx:i386 4 as a solution to libglu1-mesa:i386 3
Broken libglu1-mesa:i386 Depends on libgl1 [ i386 ] < none > ( none )
  Considering libgl1-mesa-swx11:i386 0 as a solution to libglu1-mesa:i386 3
  Added libgl1-mesa-swx11:i386 to the remove list
  Fixing libglu1-mesa:i386 via keep of libgl1-mesa-swx11:i386
Investigating (0) libqt4-opengl [ i386 ] < 4:4.8.1-0ubuntu4.4 > ( libs )
Broken libqt4-opengl:i386 Depends on libgl1-mesa-glx [ i386 ] < 8.0.4-0ubuntu0.4 > ( libs )
  Considering libgl1-mesa-glx:i386 4 as a solution to libqt4-opengl:i386 2
Broken libqt4-opengl:i386 Depends on libgl1 [ i386 ] < none > ( none )
  Considering libgl1-mesa-swx11:i386 0 as a solution to libqt4-opengl:i386 2
  Added libgl1-mesa-swx11:i386 to the remove list
  Fixing libqt4-opengl:i386 via keep of libgl1-mesa-swx11:i386
Investigating (0) xserver-xorg-video-qxl [ amd64 ] < 0.0.16-2ubuntu0.1 > ( x11 )
Broken xserver-xorg-video-qxl:amd64 Depends on xorg-video-abi-11 [ amd64 ] < none > ( none )
  Considering xserver-xorg-core:amd64 1 as a solution to xserver-xorg-video-qxl:amd64 0
  Removing xserver-xorg-video-qxl:amd64 rather than change xorg-video-abi-11:amd64
Investigating (0) ia32-libs-multiarch [ i386 ] < 20090808ubuntu36 > ( universe/libs )
Broken ia32-libs-multiarch:i386 Depends on libglapi-mesa [ i386 ] < 8.0.4-0ubuntu0.4 > ( libs )
  Considering libglapi-mesa:i386 1 as a solution to ia32-libs-multiarch:i386 -1
  Removing ia32-libs-multiarch:i386 rather than change libglapi-mesa:i386
Investigating (1) libvisual-0.4-plugins [ i386 ] < 0.4.0.dfsg.1-7 > ( sound )
Broken libvisual-0.4-plugins:i386 Depends on libgl1-mesa-glx [ i386 ] < 8.0.4-0ubuntu0.4 > ( libs )
  Considering libgl1-mesa-glx:i386 4 as a solution to libvisual-0.4-plugins:i386 3
Broken libvisual-0.4-plugins:i386 Depends on libgl1 [ i386 ] < none > ( none )
  Considering libgl1-mesa-swx11:i386 0 as a solution to libvisual-0.4-plugins:i386 3
  Added libgl1-mesa-swx11:i386 to the remove list
  Fixing libvisual-0.4-plugins:i386 via keep of libgl1-mesa-swx11:i386
Investigating (1) libglu1-mesa [ i386 ] < 8.0.4-0ubuntu0.4 > ( libs )
Broken libglu1-mesa:i386 Depends on libgl1-mesa-glx [ i386 ] < 8.0.4-0ubuntu0.4 > ( libs )
...

Steve Langasek (vorlon) wrote :

On Fri, Mar 08, 2013 at 11:00:16PM -0000, Cedric wrote:
> Just tested with the new proposed version, ia32-libs will still be
> removed.

> sudo apt-get -o Debug::pkgProblemResolver=1 install xserver-xorg-lts-quantal

This is not the test case for this bug. Why are you trying to install a
different X server stack on your system?

While ideally apt would choose the "right" solution for this case too, it's
a much harder problem for apt to correctly identify that a set of related
libraries should be replaced than it is for apt to correctly pick which
library to install. So this is out of scope for the present bug.

it's only the xserver-xorg for the LTS Stack.
When installing the ia32-libs on a LTS 12.04.2 am getting the same result.

Doug McMahon (mc3man) wrote :

Cedric (cedric-brandenbourger) wrote >
> it's only the xserver-xorg for the LTS Stack.
> When installing the ia32-libs on a LTS 12.04.2 am getting the same result.

Seems to be no issue installing ia32-libs (ia32-libs-multiarch) on 12.04.2 with apt updated to -proposed
Attached log of sim

As far as users wishing to upgrade an existing 12.04.1 to the lts stack it's not that hard but how isn't for here. More suited to Ubuntu questions or Ubuntu Forums (I'd go with forums as there could be some individual differences that an interactive forum is well suited to
(basically - use synaptic, take advantage of meta-packages, don't log out/restart till all needed are replaced

You are right, with the new version it's working on a 12.04.2.
But it's not working on a 12.04.1.
I know how to upgrade from 12.04.1 to 12.04.2, i never asked for that.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.8.16~exp12ubuntu10.9

---------------
apt (0.8.16~exp12ubuntu10.9) precise-proposed; urgency=low

  [ David Kalnischkies ]
  * apt-pkg/depcache.cc:
    - prefer to install packages which have an already installed M-A:same
      sibling while choosing providers (LP: #1130419)

  [ Steve Langasek ]
  * Invoke /etc/kernel/postinst.d/apt-auto-removal directly on upgrade for
    bug #923876, so that an 'apt-get autoremove' run before any new kernel
    packages have been installed gives the expected behavior.

apt (0.8.16~exp12ubuntu10.8) precise; urgency=low

  * Backport kernel auto-removal/retention policy from raring (LP: #923876)
    - debian/apt.auto-removal.sh, debian/rules, debian/apt.dirs: Add new
      script to /etc/kernel/postinst.d/ that ensures we always retain the
      currently-running, being-installed, and newest-installed kernels.
    - debian/apt.conf.autoremove: don't include linux-restricted-modules*,
      linux-image*, and linux-ubuntu-modules* in the never-removed list.
 -- Steve Langasek <email address hidden> Sat, 02 Mar 2013 20:22:43 +0000

Changed in apt (Ubuntu Precise):
status: Fix Committed → Fix Released
David Pitkin (dpitkin) on 2013-03-18
tags: removed: ca-escalated
Tommy_CZ (t-kijas) wrote :

Well, I installed xserver-xorg-lts-raring and when trying to install KDE4.11.2 it demands to remove xserver-xorg-lts-raring. Is it really fixed?

Adolfo Jayme (fitojb) on 2014-02-08
no longer affects: apt (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers