Ubuntu

Wubi installed 12.10 amd64 without configuring i386

Reported by DmitryKX on 2012-12-26
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Wubi
Undecided
Unassigned
apt (Ubuntu)
Undecided
Unassigned
ia32-libs (Ubuntu)
Undecided
Unassigned

Bug Description

See report at <https://bugs.launchpad.net/ubuntu/+source/ia32-libs/+bug/1016294/comments/36>.

User could not install ia32-libs-multiarch on a fresh amd64 install of 12.10 using Wubi, due to i386 not being configured as a foreign architecture.

[Workaround]

$ sudo dpkg --add-architecture i386
$ sudo apt-get update

On 26 December 2012 23:39, DmitryKX <email address hidden> wrote:
> The following packages have unmet dependencies:
> ia32-libs : Depends: ia32-libs-multiarch but it is not installable
> E: Unable to correct problems, you have held broken packages.

Provide also the output of:
$ apt-cache policy
$ apt-cache policy ia32-libs ia32-libs-multiarch

Have you determined that this is a bug in apt rather than in
ia32-libs-multiarch or some other package?

 status incomplete

Changed in apt (Ubuntu):
status: New → Incomplete

Also:
# apt-get install -oDebug::pkgProblemResolver=1 ia32-libs

Daniel Hartwig (wigs) wrote :

> Using Ubuntu 12.10 x86_64 on host system and in deboostrapped
> environment. I chrooted to deboostrapped environment and run:

Never mind the previous responses.

ia32-libs-multiarch is available only for i386, all libraries in ia32-libs are multiarch now making that package practically deprecated. What reason do you need this installed for?

In your chroot environment it is likely that dpkg is not using i386. This command will resolve that:
# dpkg --add-architecture i386 && apt-get update

This is not a bug in apt.

 status invalid

Changed in apt (Ubuntu):
status: Incomplete → Invalid
Daniel Hartwig (wigs) on 2012-12-27
description: updated
summary: - Can't install ia32-libs in chrooted environment
+ ia32-libs-multiarch but it is not installable (i386 not configured)
Daniel Hartwig (wigs) on 2013-01-14
Changed in ia32-libs (Ubuntu):
status: New → Invalid
Daniel Hartwig (wigs) on 2013-01-14
summary: - ia32-libs-multiarch but it is not installable (i386 not configured)
+ Wubi installed 12.10 amd64 without configuring i386
description: updated
Daniel Hartwig (wigs) wrote :

@ Wubi maintainers

Please triage this issue. It seems the installed system did not have i386 configured as foreign architecture which a regular 12.10 install would have.

Daniel Hartwig (wigs) wrote :

[I am not also assigning to debootstrap which has the same issue as this is unsupported. See bug #971761, comment #37.]

Brian Murray (brian-murray) wrote :

Investigating the wubi disk image, ubuntu-12.10-wubi-amd64.tar, the file /var/lib/dpkg/arch does not exist. So something needs to add i386 as an architecture.

Adam Conrad (adconrad) wrote :

11:15 < infinity> Oh, hrm. That could be because the dpkg postinst only adds i386 as an arch on fresh installs, but dpkg is never a fresh install.
11:15 < infinity> (Since debootstrap unpacks it without running postinsts, then reinstalls it, IIRC)
11:15 < infinity> We paper over that in both d-i and ubiquity by explicitly adding the arch, I believe.
11:17 < infinity> Assuming my theory about debootstrap is right, I can't think of a sane way to fix that other than having wubi also do the requisite papering over.
11:17 < cjwatson> ah, yeah, or have live-build do it
11:17 < infinity> Or live-build, sure.
11:17 < infinity> live-build probably makes more sense.
11:17 < cjwatson> makes the livefs bigger due to the extra Packages files
11:17 < infinity> Though, if...
11:17 < cjwatson> so probably better not do it across the board
11:17 < infinity> Was just going to say that.
11:17 < cjwatson> maybe do it in livecd-rootfs just for wubi?
11:18 < infinity> Could do it as the step right after the final apt-get update.
11:19 < cjwatson> infinity: right before ...
11:19 < cjwatson> infinity: we don't want to do it after for wubi, because then people don't have i386 indexes until they update
11:19 < cjwatson> wubi is a special case here due to the ghost-y nature of its installation

Steve Langasek (vorlon) wrote :

> Oh, hrm. That could be because the dpkg postinst only adds i386 as an arch on fresh installs, but dpkg is never a fresh install.
> (Since debootstrap unpacks it without running postinsts, then reinstalls it, IIRC)

What dpkg actually does is extract the contents of the packages, then call dpkg --unpack, and finally call dpkg --configure. So the maintainer scripts should be run with all the normal arguments.

Yash Shah (yash9414) on 2013-01-20
tags: added: it works
Steve Langasek (vorlon) on 2013-01-20
tags: removed: it works
Dominique Lasserre (lasall) wrote :

I can confirm this issue. I have seen multiple Wubi installations in my supporter forum ubuntuusers.de where this issue occurs.

Changed in wubi:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers