apt-get crashed with SIGSEGV during installation in pkgCacheGenerator::NewVersion ()

Bug #1067056 reported by Jean-Baptiste Lallement on 2012-10-15
58
This bug affects 7 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Critical
Colin Watson
Quantal
Critical
Colin Watson

Bug Description

Quantal Desktop 20121015.2

TEST CASE
1. Enable "Free Software Only" in the boot menu
2. Proceed with installation with the defaults

ACTUAL RESULT
Installation stops with
plugininstall.p[7036]: segfault at 7fc5aa977bf0 ip 00007fc5b40cf69d sp 00007fff71f815f0 error 6 in libapt-pkg.so.4.12.0[7fc5b403e000+11b000]

"""
pkgCacheGenerator::NewVersion (this=this@entry=0x7fffffffd520, Ver=..., VerStr=..., Next=0) at pkgcachegen.cc:731
pkgCacheGenerator::MergeListVersion (this=this@entry=0x7fffffffd520, List=..., Pkg=..., Version=..., OutVer=@0x7fffffffc668: 0x0) at pkgcachegen.cc:377
pkgCacheGenerator::MergeList (this=0x7fffffffd520, List=..., OutVer=0x0) at pkgcachegen.cc:222
debPackagesIndex::Merge (this=0x659c40, Gen=..., Prog=<optimized out>) at deb/debindexfile.cc:327
BuildCache (Gen=..., Progress=Progress@entry=0x7fffffffd760, CurrentSize=@0x7fffffffd4c8: 70817943, TotalSize=TotalSize@entry=121542502, Start=..., End=...) at pkgcachegen.cc:1184
pkgCacheGenerator::MakeStatusCache (List=..., Progress=0x7fffffffd760, OutMap=0x7fffffffd8b0, AllowMem=<optimized out>) at pkgcachegen.cc:1376
pkgCacheFile::BuildCaches (this=0x7fffffffd8a0, Progress=0x7fffffffd760, WithLock=true) at cachefile.cc:83
CacheFile::BuildCaches (this=this@entry=0x7fffffffd8a0, WithLock=WithLock@entry=true) at apt-get.cc:101
DoUpdate (CmdL=...) at apt-get.cc:1688
CommandLine::DispatchArg (this=0x7fffffffde50, Map=<optimized out>, NoMatch=<optimized out>) at contrib/cmndline.cc:339
main (argc=<optimized out>, argv=0x7fffffffe6c8) at apt-get.cc:3602
"""

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.12.12
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
CasperVersion: 1.328
Date: Mon Oct 15 22:02:13 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity initrd=/casper/initrd.lz quiet splash -- apt-setup/restricted=false apt-setup/multiverse=false
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121015.2)
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1067056

tags: added: iso-testing
tags: added: testcase
Jean-Baptiste Lallement (jibel) wrote :

Trace of "apt-get update" generated from inside /target after installation crashed.

Changed in ubiquity (Ubuntu Quantal):
milestone: none → ubuntu-12.10
summary: - libapt-pkg.so segfaults during execution of plugininstall.py
+ apt-get crashed with SIGSEGV during installation in
+ pkgCacheGenerator::NewVersion ()
description: updated
Colin Watson (cjwatson) on 2012-10-16
affects: ubiquity (Ubuntu Quantal) → apt (Ubuntu Quantal)
Jean-Baptiste Lallement (jibel) wrote :

Content of /etc/apt from /target during installation

Jean-Baptiste Lallement (jibel) wrote :

Content of /var/lib/apt from /target after the crash.

It contains the index of ddebs.u.c, but apt crashed anyway with these indexes.

Colin Watson (cjwatson) on 2012-10-16
Changed in apt (Ubuntu Quantal):
status: Confirmed → In Progress
assignee: nobody → Colin Watson (cjwatson)
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 0.9.7.5ubuntu5

---------------
apt (0.9.7.5ubuntu5) quantal; urgency=low

  * Revert "missing remap registration" change from 0.9.7.5ubuntu4; this
    iterator was already registered, and double registration causes a crash
    (LP: #1067056).
 -- Colin Watson <email address hidden> Tue, 16 Oct 2012 11:35:59 +0100

Changed in apt (Ubuntu Quantal):
status: Fix Committed → Fix Released
James Hunt (jamesodhunt) on 2012-10-16
Changed in apt (Ubuntu Quantal):
assignee: Colin Watson (cjwatson) → James Hunt (jamesodhunt)
assignee: James Hunt (jamesodhunt) → nobody
Colin Watson (cjwatson) on 2012-10-16
Changed in apt (Ubuntu Quantal):
assignee: nobody → Colin Watson (cjwatson)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers