My repository is broken: package libk5crypto3 1.10+dfsg~beta1-2ubuntu0.3 failed to install/upgrade: libk5crypto3:amd64 1.10+dfsg~beta1-2ubuntu0.3 cannot be configured because libk5crypto3

Bug #1053215 reported by T on 2012-09-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Undecided
Unassigned

Bug Description

My repository is broken

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libk5crypto3 1.10+dfsg~beta1-2ubuntu0.3
ProcVersionSignature: Ubuntu 3.2.0-27.43-generic 3.2.21
Uname: Linux 3.2.0-27-generic x86_64
ApportVersion: 2.0.1-0ubuntu11
Architecture: amd64
Date: Thu Sep 20 00:20:16 2012
DpkgHistoryLog:
 Start-Date: 2012-09-20 00:20:15
 Commandline: apt-get -f install
 Upgrade: libk5crypto3:i386 (1.10+dfsg~beta1-2ubuntu0.1, 1.10+dfsg~beta1-2ubuntu0.3), libkrb5-dev:amd64 (1.10+dfsg~beta1-2ubuntu0.2, 1.10+dfsg~beta1-2ubuntu0.3), krb5-multidev:amd64 (1.10+dfsg~beta1-2ubuntu0.2, 1.10+dfsg~beta1-2ubuntu0.3)
DpkgTerminalLog:
 dpkg: error processing libk5crypto3 (--configure):
  libk5crypto3:amd64 1.10+dfsg~beta1-2ubuntu0.3 cannot be configured because libk5crypto3:i386 is in a different version (1.10+dfsg~beta1-2ubuntu0.1)
 dpkg: error processing libk5crypto3:i386 (--configure):
  libk5crypto3:i386 1.10+dfsg~beta1-2ubuntu0.1 cannot be configured because libk5crypto3:amd64 is in a different version (1.10+dfsg~beta1-2ubuntu0.3)
ErrorMessage: libk5crypto3:amd64 1.10+dfsg~beta1-2ubuntu0.3 cannot be configured because libk5crypto3
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
SourcePackage: krb5
Title: package libk5crypto3 1.10+dfsg~beta1-2ubuntu0.3 failed to install/upgrade: libk5crypto3:amd64 1.10+dfsg~beta1-2ubuntu0.3 cannot be configured because libk5crypto3
UpgradeStatus: Upgraded to precise on 2012-05-18 (124 days ago)

T (t-squire87) wrote :
Steve Langasek (vorlon) wrote :

I don't understand the error here. It looks like the package manager is trying to upgrade the right packages to make things consistent, but then the dpkg log shows packages being configured out of order. Can you please run ' sudo apt-get install -f' in a terminal, and attach the full output here?

Changed in krb5 (Ubuntu):
status: New → Incomplete

Hey,

I've got a thread on Ubuntu forums on this issue. Link:
http://ubuntuforums.org/showthread.php?p=12258290&posted=1#post12258290

I've followed some steps on there to help resolve the issue. It is still
ongoing. I appreciate the help and I'm learning more about linux as this
goes on.

Here is the output from install -f:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer
required:
  libunity6 libqapt-runtime libboost-program-options1.46.1
  akonadi-backend-mysql libqapt1 shared-desktop-ontologies libntrack0
  ntrack-module-libnl-0 libntrack-qt4-1
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libkrb5-dev
Suggested packages:
  krb5-doc
The following packages will be upgraded:
  libkrb5-dev
1 upgraded, 0 newly installed, 0 to remove and 325 not upgraded.
1 not fully installed or removed.
Need to get 0 B/11.0 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: dependency problems prevent configuration of libkrb5-dev:
 libkrb5-dev depends on krb5-multidev (= 1.10+dfsg~beta1-2ubuntu0.2);
however:
  Version of krb5-multidev on system is 1.10+dfsg~beta1-2ubuntu0.3.
dpkg: error processing libkrb5-dev (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were
encountered while processing:
 libkrb5-dev
E: Sub-process /usr/bin/dpkg returned an error code (1)

Steve Langasek (vorlon) wrote :

Ok, something's behaving very wrong here. apt claims it's going to upgrade libkrb5-dev, then proceeds to try to configure the current version whose dependencies aren't satisfied. Bouncing this over to apt.

affects: krb5 (Ubuntu) → apt (Ubuntu)
Changed in apt (Ubuntu):
status: Incomplete → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers