package apt-xapian-index 0.44ubuntu3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 127

Bug #856627 reported by LaChild on 2011-09-22
40
This bug affects 4 people
Affects Status Importance Assigned to Milestone
apt-xapian-index (Ubuntu)
Undecided
Unassigned

Bug Description

This error showed up during an "apt-get upgrade" today.

ProblemType: Package
DistroRelease: Ubuntu 11.10
Package: apt-xapian-index 0.44ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Thu Sep 22 12:55:08 2011
DuplicateSignature:
 Setting up apt-xapian-index (0.44ubuntu3) ...
 apt-xapian-index: Building new index in background...
 /var/lib/dpkg/info/apt-xapian-index.postinst: 46: update-python-modules: not found
 dpkg: error processing apt-xapian-index (--configure):
  subprocess installed post-installation script returned error exit status 127
ErrorMessage: subprocess installed post-installation script returned error exit status 127
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.3)
PackageArchitecture: all
SourcePackage: apt-xapian-index
Title: package apt-xapian-index 0.44ubuntu3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 127
UpgradeStatus: No upgrade log present (probably fresh install)

LaChild (shafer-w2002) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt-xapian-index (Ubuntu):
status: New → Confirmed
Opaflamme (opaflamme) wrote :

A workaround is to install python-support. apt-xapian-index 0.44ubuntu3 have no python-support deps -> #858099

Lars Noodén (larsnooden) wrote :

The work-around that I used was to uninstall apt-xapian-index

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt-xapian-index - 0.44ubuntu4

---------------
apt-xapian-index (0.44ubuntu4) oneiric; urgency=low

  * Don't call update-python-modules in the postinst. LP: #856627.
 -- Matthias Klose <email address hidden> Sat, 24 Sep 2011 14:42:18 +0200

Changed in apt-xapian-index (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers