update-apt-xapian-index crashes with "InvalidArgumentError: Term too long (> 245): XSlibdevel"

Bug #669430 reported by Fabien Tassin on 2010-11-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apt-xapian-index (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned
pkg-create-dbgsym (Ubuntu)
Medium
Martin Pitt
Natty
Medium
Martin Pitt
qt4-x11 (Ubuntu)
High
Martin Pitt
Natty
High
Martin Pitt

Bug Description

Binary package hint: apt-xapian-index

reported by apport every morning on natty

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: apt-xapian-index 0.39ubuntu1
ProcVersionSignature: Ubuntu 2.6.36-1.7-generic 2.6.36
Uname: Linux 2.6.36-1-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Mon Nov 1 08:01:30 2010
ExecutablePath: /usr/sbin/update-apt-xapian-index
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100331)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/sbin/update-apt-xapian-index -q
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/sh
PythonArgs: ['/usr/sbin/update-apt-xapian-index', '-q']
SourcePackage: apt-xapian-index
Title: update-apt-xapian-index crashed with libqt4-declarative (= 4 in buildIndex()
UserGroups:

Fabien Tassin (fta) wrote :
tags: removed: need-duplicate-check
Fabien Tassin (fta) on 2010-11-01
visibility: private → public
Fabien Tassin (fta) wrote :

/etc/cron.daily/apt:
Traceback (most recent call last):
  File "/usr/sbin/update-apt-xapian-index", line 104, in <module>
    indexer.rebuild(opts.pkgfile)
  File "/usr/lib/pymodules/python2.6/axi/indexer.py", line 688, in rebuild
    self.buildIndex(dbdir, generator)
  File "/usr/lib/pymodules/python2.6/axi/indexer.py", line 664, in buildIndex
    db.add_document(doc)
xapian.InvalidArgumentError: Term too long (> 245): XSlibdevel
 libqt4-svg (= 4:4.7.1-0ubuntu4), libqt4-xml (= 4:4.7.1-0ubuntu4),
 libqt4-sql (= 4:4.7.1-0ubuntu4), libqt4-script (= 4:4.7.1-0ubuntu4),
 libqt4-scripttools (= 4:4.7.1-0ubuntu4), libqt4-xmlpatterns (= 4:4.7.1-0ubuntu4),
 libqt4-qt3support (= 4:4.7.1-0ubuntu4), libqt4-designer (= 4:4.7.1-0ubuntu4),
 libqt4-help (= 4:4.7.1-0ubuntu4), libqt4-test (= 4:4.7.1-0ubuntu4),
 libqt4-declarative (= 4:4.7.1-0ubuntu4), qt4-qmake (= 4:4.7.1-0ubuntu4), libx11-dev

summary: - update-apt-xapian-index crashed with libqt4-declarative (= 4 in
- buildIndex()
+ update-apt-xapian-index crashes with "InvalidArgumentError: Term too
+ long (> 245): XSlibdevel"
Fabien Tassin (fta) wrote :

i just had a closer look, it always fail on libqt4-dev-dbgsym, which looks strange in my cache (the Section part), confirmed in http://ddebs.ubuntu.com/dists/natty/main/binary-i386/Packages

# apt-cache show libqt4-dev-dbgsym
Package: libqt4-dev-dbgsym
Priority: extra
Section: libdevel
 libqt4-svg (= 4:4.7.1-0ubuntu4), libqt4-xml (= 4:4.7.1-0ubuntu4),
 libqt4-sql (= 4:4.7.1-0ubuntu4), libqt4-script (= 4:4.7.1-0ubuntu4),
 libqt4-scripttools (= 4:4.7.1-0ubuntu4), libqt4-xmlpatterns (= 4:4.7.1-0ubuntu4),
 libqt4-qt3support (= 4:4.7.1-0ubuntu4), libqt4-designer (= 4:4.7.1-0ubuntu4),
 libqt4-help (= 4:4.7.1-0ubuntu4), libqt4-test (= 4:4.7.1-0ubuntu4),
 libqt4-declarative (= 4:4.7.1-0ubuntu4), qt4-qmake (= 4:4.7.1-0ubuntu4), libx11-dev
Installed-Size: 63668
Maintainer: Kubuntu Developers <email address hidden>
Original-Maintainer: Debian Qt/KDE Maintainers <email address hidden>
Architecture: amd64
Source: qt4-x11
Version: 4:4.7.1-0ubuntu4
Depends: libqt4-dev (= 4:4.7.1-0ubuntu4)
Conflicts: libqt4-dbg, libqt4-webkit-dbg, libqt4-xmlpatterns-dbg, qt4-demos-dbg
Filename: pool/main/q/qt4-x11/libqt4-dev-dbgsym_4.7.1-0ubuntu4_amd64.ddeb
Size: 18516782
MD5sum: 8f73a69762ec51bcbbfbf8a0d239d5e9
SHA1: ba2c6ecd4b6cbbb511a44af2010675a961eeb106
SHA256: 16b123dbc292412768f47cbb7d8d23d392718bdbde24e5c80160919919c6aba7
Description: debug symbols for package libqt4-dev
 Qt is a cross-platform C++ application framework. Qt's primary feature
 is its rich set of widgets that provide standard GUI functionality.
 .
 This package contains the header development files and development programs
 used for building Qt 4 applications.
Homepage: http://www.qtsoftware.com

Martin Pitt (pitti) wrote :

I'll fix that in the ddeb creation, thanks! I keep the apt-xapian bug open, though, as this should be handled more gracefully.

Changed in pkg-create-dbgsym (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
status: New → In Progress
Kees Cook (kees) wrote :

Note that this is leaving very large caches behind in /var/cache/apt-xapian-index since it fails before cleanup...

Changed in apt-xapian-index (Ubuntu Natty):
importance: Undecided → Medium
status: New → Confirmed
milestone: none → natty-alpha-3
Changed in pkg-create-dbgsym (Ubuntu Natty):
milestone: none → natty-alpha-3
milestone: natty-alpha-3 → natty-alpha-2
Martin Pitt (pitti) wrote :

qt4-x11 needs a rebuild after the fixed pkg-create-dbgsym was published.

Changed in pkg-create-dbgsym (Ubuntu Natty):
status: In Progress → Fix Committed
Changed in qt4-x11 (Ubuntu Natty):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pkg-create-dbgsym - 0.46

---------------
pkg-create-dbgsym (0.46) natty; urgency=low

  * tests/dhtest.whitespace: Add a comment line in the middle of the Depends:
    field. This reproduces the failure in LP #669430.
  * tests/run: Check that ddebs have a correct Section: field. This catches
    above bug.
  * pkg_create_dbgsym: Filter out comment lines from debian/control before
    processing. (LP: #669430)
  * Use 3.0 (native) source format.
  * debian/control: Bump Standards-Version to 3.9.1.
 -- Martin Pitt <email address hidden> Fri, 31 Dec 2010 15:20:49 +0100

Changed in pkg-create-dbgsym (Ubuntu Natty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

The apt-xapian-index part isn't release critical.

Changed in apt-xapian-index (Ubuntu Natty):
milestone: natty-alpha-3 → none
status: Confirmed → Won't Fix
Changed in apt-xapian-index (Ubuntu):
status: Confirmed → Triaged
Changed in qt4-x11 (Ubuntu Natty):
milestone: none → natty-alpha-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.7.1-0ubuntu6

---------------
qt4-x11 (4:4.7.1-0ubuntu6) natty; urgency=low

  * No-change rebuild against fixed pkg-create-dbgsym. (LP: #669430)
 -- Martin Pitt <email address hidden> Fri, 31 Dec 2010 15:33:39 +0100

Changed in qt4-x11 (Ubuntu Natty):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers