update-apt-xapian-index crashed with DatabaseCorruptError in buildIndex()

Bug #631215 reported by Hayden Sartoris on 2010-09-06
This bug affects 220 people
Affects Status Importance Assigned to Milestone
apt-xapian-index (Ubuntu)
Undecided
Unassigned

Bug Description

I had recently installed some gstreamer packages on a fully updated 10.10 install. this bug report just popped up.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: apt-xapian-index 0.38ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
Date: Sun Sep 5 20:24:00 2010
ExecutablePath: /usr/sbin/update-apt-xapian-index
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901.1)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/sbin/update-apt-xapian-index --batch-mode --force --update
ProcEnviron:

PythonArgs: ['/usr/sbin/update-apt-xapian-index', '--batch-mode', '--force', '--update']
SourcePackage: apt-xapian-index
Title: update-apt-xapian-index crashed with DatabaseCorruptError in buildIndex()
UserGroups:

Hayden Sartoris (hsartoris) wrote :
affects: ubuntu → apt-xapian-index (Ubuntu)
tags: removed: need-duplicate-check
tags: added: bugpattern-needed
Steve Beattie (sbeattie) on 2010-09-18
visibility: private → public
OperVil (oper-88) wrote :

x86_64 same problem

I am able to reproduce this bug on a Natty i386 system (duplicate bug 729157). The traceback looks slightly different (it has "db.flush()" instead of "db.add_document(doc)").

tags: added: amd64 natty

I've just noticed that bug 709626, bug 721712, bug 726046, bug 726717, bug 728323, bug 728504, bug 728693, bug 728816, bug 729157, bug 712754, bug 713404, bug 713567, bug 713928, bug 713972, bug 714118, bug 714331, bug 717966, bug 719594, bug 720978, bug 721712, bug 726046, bug 726717, bug 728323, bug 728504, bug 728693, and bug 728816 (i.e. all the other recent duplicates of this bug) are for Natty as well, so I'm not the only Natty user who's experienced this! (I guess just nobody got around to marking this as affecting Natty).

I was running Natty Narwhal i386 _Desktop_ using TestDrive if that makes
a difference

On 03/04/2011 11:33 AM, Eliah Kagan wrote:
> I am able to reproduce this bug on a Natty i386 system (duplicate bug
> 729157). The traceback looks slightly different (it has "db.flush()"
> instead of "db.add_document(doc)").
>
> ** Tags added: amd64 natty
>

Changed in apt-xapian-index (Ubuntu):
status: New → Confirmed
Fabio Marconi (fabiomarconi) wrote :

update-apt-xapian-index crashed with DatabaseCorruptError in buildIndex(): Failed to unlink /var/cache/apt-xapian-index/index.3/postlist.baseB: No such file or directory

tags: removed: bugpattern-needed
tags: added: bugpattern-written
Brian Murray (brian-murray) wrote :

Looking at the duplicates of this bug the latest version affected seems to be apt-xapian-index 0.41ubuntu6 from Ubuntu 11.04. While I can't find a specific changelog entry indicating what fixed this it certainly seems fixed in Oneiric and Precise, subsequently I am setting this to Fix Released and will remove the bug pattern for it.

Changed in apt-xapian-index (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers