update-apt-xapian-index crashed with OSError in getmtime()

Bug #267330 reported by Alexander Dreyzen on 2008-09-07
This bug affects 459 people
Affects Status Importance Assigned to Milestone
apt-xapian-index
Opinion
Undecided
Sergiy Filzhak
apt-xapian-index (Ubuntu)
Medium
Colin Watson
Declined for Lucid by Sebastien Bacher
Maverick
Medium
Colin Watson
software-center (Ubuntu)
Medium
Colin Watson
Declined for Lucid by Sebastien Bacher
Maverick
Medium
Colin Watson

Bug Description

Binary package hint: apt-xapian-index

# AMD Puma platform
# HP Pavilion dv5z
# AMD Turion(TM) X2 Ultra Dual-Core Mobile Processor ZM-80 (2.1 GHz)
# 15.4" diagonal WXGA High-Definition HP Widescreen Display (1280 x 800)
# 2GB DDR2 System Memory (2 Dimm)
# ATI Radeon(TM) HD 3200 Graphics
# 160GB 5400RPM SATA Hard Drive
# Webcam
# 802.11a/b/g/n WLAN and Bluetooth
# 8X DVD+/-R/RW with Double Layer Support
# 6 Cell Lithium Ion Battery

Description: Ubuntu intrepid (development branch)
Release: 8.10

$ apt-cache policy apt-xapian-index
apt-xapian-index:
  Installed: 0.15
  Candidate: 0.15
  Version table:
 *** 0.15 0
        500 http://us.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 8.10 and 9.04
ExecutablePath: /usr/sbin/update-apt-xapian-index
InterpreterPath: /usr/bin/python2.5
Package: apt-xapian-index 0.15
PackageArchitecture: all
ProcAttrCurrent: unconfined
ProcCmdline: /usr/bin/python /usr/sbin/update-apt-xapian-index -q
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/sbin/update-apt-xapian-index', '-q']
SourcePackage: apt-xapian-index
Title: update-apt-xapian-index crashed with OSError in getmtime()
Uname: Linux 2.6.27-2-generic x86_64
UserGroups:

Related branches

manzur (sl-solaris) on 2009-03-11
description: updated

affect to karmic too

Hellsgator (hellsgate) wrote :

running Karmic. same bug.

Vlad Brovko (brovka75) wrote :

affect to karmic too

Richard Cavell (richardcavell) wrote :

I also have this bug on 64-bit Karmic alpha 4.

Appeared on Karmic Alpha 4 + latest updates when the system was trying to upload a 'large' amount of data for 'bug': https://bugs.edge.launchpad.net/ubuntu/+source/acroread/+bug/367080

I am using 3G internet.

SolidSteel144 (milesrdz) wrote :

Karmic Alpha 6... :(

Possumus (possumus) wrote :

Karmic Alpha 6 here too

Th. Sievers (th-sievers) wrote :

9.10 beta amd64

9.10 beta amd64 too

Fatih Bostancı (fbostanci) wrote :

9.10 beta i386 ..

Th. Sievers (th-sievers) wrote :

9.10 beta amd64

aquarius (tsolakg) wrote :

?

dotnokato (dotnokato) wrote :

9.10 beta AMD64 too.

9.10 beta amd64 again. Not sure what caused this. I was just using Synaptic to clear out some old kernels... don't know...

Peter Watts (watto-one) on 2009-10-14
Changed in apt-xapian-index (Ubuntu):
status: New → Confirmed
ova (cionca.ovidiu) wrote :

9.10 beta i386

Andros83 (mail-ceandrea) wrote :

9.10 beta 64bit too.

sultan (gerard-snoek) wrote :

9.10 beta i386

Changed in apt-xapian-index (Ubuntu):
importance: Undecided → Medium
Kevin Brightwell (nava2) wrote :

9.10 beta, x64.

Apport tried to report the same bug.

N/A (unknownusertodelete) wrote :

9.10 rc i386

Is an apport bug, should be enough information here, marking Triaged.

Changed in apt-xapian-index (Ubuntu):
status: Confirmed → Triaged
nick TS (nick-thewlis-smith) wrote :

just trying to sort out problem with pulseaudio and browsing synaptic mgr

tags: added: metabug
Caue Rego (caue-rego) wrote :

I have no idea why the little icon appeared to me, on my Karmic live-cd.

But just after it crashed, I decided to try and run this same command using sudo, and it seems like it worked:

ubuntu@ubuntu:~$ sudo update-apt-xapian-index
Rebuilding Xapian index: done.

Thespian (jesse-mundis) wrote :

problem seen on aspire netbook running ubuntu netbook remix off a flash drive.

tags: added: bugpattern-needed
dino99 (9d9) wrote :

got this error on Lucid a2 updated:

have made in console: sudo apt-get install -f
(returned a warning about a known issue with wine 1.1.36)
then give this problem.

tags: added: bugpattern-written
removed: bugpattern-needed
Changed in apt-xapian-index (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Roger Ward (rogerw) wrote :

also on 64bit Ubuntu 10.4 (dev/alpha branch)

Nicolas DERIVE (kalon33) wrote :

happens under latest lucid 32bit too.

Anthony Hook (anthonyhook) wrote :

Yeah, I just had this happen when I launched Synaptic on 10.04.

Roy (rdstrac) wrote :

Also on Intel Quad running 10.04 Alpha 3 during system update.

bancaldo (bancaldo-gmail) wrote :

got this error on Lucid a3

Oytun (oytunnew18) wrote :

got this error on ubuntu 10.04 alpha x86 lucid

got this error using ubuntu-10.04-beta1-dvd-amd64.iso

dino99 (9d9) wrote :

got again a crash into /var/crash

got these outputs into .xsession-errors immediatly after i installed the Lucid B1 updates, (nothing logged before ):

Nautilus-Share-Message: Called "net usershare info" but it failed: « net usershare » a retourné l'erreur 255 : net usershare: cannot open usershare directory /var/lib/samba/usershares. Error Aucun fichier ou dossier de ce type
Please ask your system administrator to enable user sharing.

Traceback (most recent call last): File "/usr/sbin/update-apt-xapian-index", line 631, in <module>
    addons = readPlugins(PLUGINDIR, progress)
  File "/usr/sbin/update-apt-xapian-index", line 278, in readPlugins
    addon = Addon(file)
  File "/usr/sbin/update-apt-xapian-index", line 246, in __init__
    self.info = self.obj.info()
  File "/usr/share/apt-xapian-index/plugins/apttags.py", line 29, in info
    return dict(timestamp = os.path.getmtime(file))
  File "/usr/lib/python2.6/genericpath.py", line 54, in getmtime
    return os.stat(filename).st_mtime
OSError: [Errno 2] No such file or directory: '/var/cache/apt/pkgcache.bin'
checking for valid crashreport now
update-apt-xapian-index

dino99 (9d9) wrote :

new wine was installed (updated) too.

Mzombira (mzombira) wrote :

that affect 10.4 too :)

annerswat (werbung-annerswat) wrote :

I also have this bug on 64-bit Karmic Beta 1.

Franck (alci) wrote :

Another me too on Lucid beta (amd64). Happens when I open synpatic and click on 'Update'

PJO (lexicographer) wrote :

+1 on Lucid beta 1 (Intel).

May have been coincidental but I had just adjusted the size of the left hand panel;

The crash report is as per #33 up to OSError, then with

 OSError: [Errno 2] No such file or directory: '/var/cache/apt/pkgcache.bin'

"sudo update-apt-xapian-index"

yielded a message about a deprecated object, then

"The index /var/lib/apt-xapian-index is up to date"

msieloff (m-sieloff-web) wrote :

Me too on lucid beta 1.

goevolve (goevolve336) wrote :

Another on Lucid Beta 1 x86 - updating synaptic

Changed in apt-xapian-index (Ubuntu):
status: Triaged → Fix Committed
Changed in apt-xapian-index (Ubuntu):
status: Fix Committed → Fix Released
Gary M (garym) on 2010-08-08
Changed in apt-xapian-index (Ubuntu):
status: Fix Released → Confirmed
37 comments hidden view all 117 comments
Fabio Marconi (fabiomarconi) wrote :

Upgrading from Lucid.

tags: added: regression-release
Changed in apt-xapian-index (Ubuntu):
status: Confirmed → Fix Released
tags: added: regression-potential
removed: regression-release
KrzysiekT (cytruss-xl) wrote :

Same here -Maverick beta ,using Synaptic

Danny Stieben (dmaxel) wrote :

Got this while on Maverick beta, using synaptic

Xvani (fredrile+launchpad) wrote :

WHY is this declined for Maverick? Clearly seems to be a problem.
I got it using software center, Maverick Beta.

Anita (anita90) wrote :

Maverick beta, using Synaptic

BenginM (sary) wrote :

This effect me on Maverick beta.

This fix has been declined for Maverick? (re: Declined for Maverick by Sebastien Bacher)

This bug is occurring with the latest Maverick Beta!

Changed in apt-xapian-index (Ubuntu):
status: Fix Released → Confirmed
bnet (brian-nettles) wrote :

Error on Maverick when using software center.

$ apt-cache policy apt-xapian-index
apt-xapian-index:
  Installed: 0.38ubuntu1
  Candidate: 0.38ubuntu1

dhanhurley (dhanhurley) wrote :

ACER ASPIRE 9300 ....AMD Turion(TM) X2 Mobile Technology TL-50..........
I think it was installing MYTHTV that caused the problem.
Have UNINSTALLED MYTHTV.....i do not think this computer can handle much MULTIMEDIA
I ran the following and got a thumbs-up.......
# update-apt-xapian-index
The index /var/lib/apt-xapian-index is up to date
Ciao....Dhan

dhanhurley (dhanhurley) wrote :

Excuse me,forgot,
ACER ASPIRE 9300 ....AMD Turion(TM) X2 Mobile Technology TL-50........UBUNTU 10.10 MAVERICK

MaKo (uwimbux) wrote :

Error al abrir synaptics para instalar usb-modeswitch ubuntu 10.10 beta

Jonathan Yip (helkaluin) wrote :

Error occurs when using Synaptic or Software Center, but seemingly not if using apt-get.

Maverick Beta. Popcon is enabled.

stefaca (stefaca) wrote :

mavercik beta. bug when use update manager, sometimes synaptic

mavercik beta. bug when use update manager, sometimes synaptic²

Ian Ross (iankross) wrote :

Meerkat Alpha 3
Doing updates

Tappy (robintapp) wrote :

Just got this one in meerkat

stefaca (stefaca) wrote :

asus 1201n, ion chip set, intel atom n330 cpu, MM10.10beta

dino99 (9d9) wrote :

finally, purging / reinstalling all the related installed xapian packages, have fixed this issue on my end: updated i386 maverick with apt-xapian-index 0.38ubuntu1

i've to say that a bunch of python files have been purged/reinstalled too, so i cant say if this issue is related to one of the python file or not. (might be old / wrong conf / settings to blame)

Colin Watson (cjwatson) wrote :

I see a few bits that Martin missed in his earlier change. I'll have another go at this.

Changed in apt-xapian-index (Ubuntu Maverick):
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)
status: Confirmed → Triaged
Colin Watson (cjwatson) wrote :

I have a fix. Just checking with Enrico on the right version numbering for getting this into Debian.

Changed in apt-xapian-index (Ubuntu Maverick):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt-xapian-index - 0.39

---------------
apt-xapian-index (0.39) unstable; urgency=low

  [ Enrico Zini ]
  * Fixed tests on Ubuntu (Thanks Michael Vogt for the patch)
  * Added cataloged-times plugin by Michael Vogt
  * Handle multiple invocations of indexer via dbus
  * Described axi-cache in the package description

  [ Colin Watson ]
  * Fix more crashes when the Dir::Cache::pkgcache file doesn't exist, along
    the same lines as Martin Pitt's change in 0.38 (LP: #267330).
  * Use the new MSetItem attribute API, introduced in Xapian 1.0.0, rather
    than the sequence API which was removed in 1.1.0 (closes: #595916).
  * Create the XDG cache directory with appropriate permissions if it
    doesn't exist.
  * Set better NAME sections in manual pages.
 -- Colin Watson <email address hidden> Fri, 10 Sep 2010 12:15:25 +0000

Changed in apt-xapian-index (Ubuntu Maverick):
status: In Progress → Fix Released
T Kortehisto (kortehisto) wrote :

Just had this bug after I upgraded all the packages. Using 10.10 beta 64 bit.

Colin Watson (cjwatson) wrote :

@T Kortehisto: The fix reached the archive after you posted your message, so you can't possibly have installed it. Wait for apt-xapian-index 0.39 to be available on your mirror and then try again.

latinhawwk (latinhawk) wrote :

I just installed the fix and it crashed trying to update.

On Fri, Sep 10, 2010 at 02:19:08PM -0000, latinhawwk wrote:
> I just installed the fix and it crashed trying to update.

Please provide all the details you have of this crash. (It may be some
different bug.)

  On 09/10/2010 11:38 AM, Colin Watson wrote:
> On Fri, Sep 10, 2010 at 02:19:08PM -0000, latinhawwk wrote:
>> I just installed the fix and it crashed trying to update.
> Please provide all the details you have of this crash. (It may be some
> different bug.)
>
I went through the update in Synaptic. It downloaded the new version.
When it was installing it all seemed fine. When I closed Synaptic an
error bubble was on the status bar saying that it had crashed.

On Fri, Sep 10, 2010 at 03:51:11PM -0000, latinhawwk wrote:
> I went through the update in Synaptic. It downloaded the new version.
> When it was installing it all seemed fine. When I closed Synaptic an
> error bubble was on the status bar saying that it had crashed.

That error bubble should offer you the opportunity to file a bug. Can
you please do so? If you've already dismissed it, there should still be
a .crash file for update-apt-xapian-index in /var/crash; you can run:

  ubuntu-bug /var/crash/_usr_sbin_update-apt-xapian-index.0.crash

(replace this with whatever the exact file name is) to file a bug, and
we can then determine whether that has anything to do with this bug.

  On 09/10/2010 12:49 PM, Colin Watson wrote:
> On Fri, Sep 10, 2010 at 03:51:11PM -0000, latinhawwk wrote:
>> I went through the update in Synaptic. It downloaded the new version.
>> When it was installing it all seemed fine. When I closed Synaptic an
>> error bubble was on the status bar saying that it had crashed.
> That error bubble should offer you the opportunity to file a bug. Can
> you please do so? If you've already dismissed it, there should still be
> a .crash file for update-apt-xapian-index in /var/crash; you can run:
>
> ubuntu-bug /var/crash/_usr_sbin_update-apt-xapian-index.0.crash
>
> (replace this with whatever the exact file name is) to file a bug, and
> we can then determine whether that has anything to do with this bug.
>
I just filed a new bug report on this.

VF (fviktor) wrote :

It also happens on Ubuntu 10.10 beta (i386). It happened after rebooting, logging in to the upgraded system and starting up Synaptic.

Viktor: Yes, I uploaded the fix some days after the Ubuntu 10.10 beta
was released. (There's no need for further comments pointing out that
this is broken in the beta; if you encounter this problem, try
upgrading.)

Bernd Laser (bernd-laser) wrote :

I did upgrade today, but the bug is still there.

Colin Watson (cjwatson) wrote :

On Sat, Sep 11, 2010 at 03:17:35PM -0000, Bernd Laser wrote:
> I did upgrade today, but the bug is still there.

Are you absolutely sure that it's exactly the same bug? There are other
ways in which update-apt-xapian-index can fail, and not all of them are
this bug. You should have a crash file - I provided instructions for
filing it a few comments back.

Changed in apt-xapian-index:
assignee: nobody → Sergiy Filzhak (sergiy-filzhak)

Noticed apport crash report in upper right hand side of the screen, clicked and was dup of this bug.

lsb_release -rd
Description: Ubuntu maverick (development branch)
Release: 10.10

apt-cache policy apt-xapian-index
apt-xapian-index:
  Installed: 0.39
  Candidate: 0.39
  Version table:
 *** 0.39 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

Changed in apt-xapian-index (Ubuntu Maverick):
status: Fix Released → New
Colin Watson (cjwatson) wrote :

On Sun, Sep 12, 2010 at 07:32:11PM -0000, rusivi wrote:
> Noticed apport crash report in upper right hand side of the screen,
> clicked and was dup of this bug.

The dup detector is not being very helpful here - I need your actual
crash file, as I suspect it will be slightly different. Please attach
your crash file to this bug. You should find it in
/var/crash/_usr_sbin_update-apt-xapian-index.0.crash, or something very
similar. You may need to use root privileges to read it.

bnet (brian-nettles) wrote :

Title: update-apt-xapian-index crashed with OSError in getmtime()
Crash file attached

brian@DEXTER:~$ lsb_release -rd
Description: Ubuntu maverick (development branch)
Release: 10.10
brian@DEXTER:~$ apt-cache policy apt-xapian-index
apt-xapian-index:
  Installed: 0.39
  Candidate: 0.39
  Version table:
 *** 0.39 0
        500 http://archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status
brian@DEXTER:~$ uname -a
Linux DEXTER 2.6.35-20-generic #29-Ubuntu SMP Fri Sep 3 14:49:14 UTC 2010 i686 GNU/Linux

Colin Watson:

Attached is the requested file.

Colin Watson (cjwatson) wrote :

@bnet: Thanks! The remainder of this isn't an apt-xapian-index bug -
it's a bug caused by an apt-xapian-index *plugin* shipped by
software-center. I've opened a new task and will provide a branch
fixing this shortly.

Changed in apt-xapian-index (Ubuntu Maverick):
status: New → Fix Released
Changed in software-center (Ubuntu Maverick):
status: New → Triaged
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Medium
Colin Watson (cjwatson) wrote :

On Sun, Sep 12, 2010 at 09:10:28PM -0000, rusivi1 wrote:
> Attached is the requested file.

Thanks. Your crash is different from bnet's (since there are two buggy
plugins involved, both in software-center), but it will also be fixed by
the branch I just submitted there.

Gary Lasker (gary-lasker) wrote :

Thanks Colin! Your branch is merged to trunk.

Changed in software-center (Ubuntu Maverick):
status: Triaged → Fix Committed
Colin Watson (cjwatson) wrote :

software-center (2.1.19) maverick; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/widgets/mkit.py:
    - fix crash during action_bar refresh (LP: #635044)
  * softwarecenter/backend/channel.py:
    - always display the partner channel, even if its
      source is not enabled (LP: #635003)
  * softwarecenter/db/application.py,
    softwarecenter/db/database.py,
    softwarecenter/view/appview.py,
    softwarecenter/view/softwarepane.py:
    - make StoreDatabase.get_appname return None if the
      name is not defined in the xapian doc
    - consolidate code to generate application name and
      summary for display in the UI to a single place
    - wire applist, appdetails and the navigation bar
      to use it (LP: #636004)

  [ Kiwinote ]
  * data/software-center.menu.in:
    - fix typo to now use applications-ocaml icon, thanks mpt (LP: #635732)
  * softwarecenter/backend/channel.py:
    - allow 'for purchase' to have an icon in non-English locales (LP: #636242)
  * softwarecenter/db/application.py:
    - try to open deb file, except on any sort of error (LP: #633379)
    - simplify when we use which warnings for deb files (LP: #635015)
    - reload pkg cache object and xapian doc if it turns out that the pkgname
      of a deb file is different than what we guessed on basis of the file name
  * softwarecenter/utils.py:
    - fix crash when desktop_file is None (LP: #635596)
  * softwarecenter/view/appdetailsview_gtk.py:
    - use the display name for app entry in 'where is it' (LP: #635464)
    - restore correct padding in addons status bar (LP: #625230)
  * minor tweaks to lp:~gary-lasker/software-center/title-summary-fixes
    - use installed state in status bar for reinstallable debs (LP: #635015)

  [ Matthew Paul Thomas ]
  * data/software-center.menu.in:
    - fix incorrect Category value in the xml for the Debugging
      subcategory of Developer Tools (LP: #538911)

  [ Colin Watson ]
  * Fix update-apt-xapian-index crashes when the Dir::Cache::pkgcache file
    doesn't exist (LP: #267330).

  [ Michael Vogt ]
  * softwarecenter/backend/aptd.py:
    - fix "reload()" in enable_channel() and only update the particular
      channel file
  * softwarecenter/distro/Ubuntu.py:
    - fix crash for icons loaded from extras.ubuntu.com
  * merged lp:~mmcg069/software-center/Bug635375 (LP: #635375)
  * merged lp:~mmcg069/software-center/tiny-pathbar-tweak
  * merged lp:~mmcg069/software-center/Bug625443 (LP: #625443)

 -- Michael Vogt <email address hidden> Tue, 14 Sep 2010 12:16:47 +0200

Changed in software-center (Ubuntu Maverick):
status: Fix Committed → Fix Released
Changed in apt-xapian-index:
status: New → Opinion
Displaying first 40 and last 40 comments. View all 117 comments or add a comment.