update-apt-xapian-index crashed with KeyError in __getitem__()

Bug #194731 reported by David Adam on 2008-02-23
332
This bug affects 7 people
Affects Status Importance Assigned to Milestone
apt-xapian-index (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: apt-xapian-index

~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

apt-xapian-index version 0.4

Patch in bug #178726 applied.

ProblemType: Crash
Architecture: i386
Date: Sat Feb 23 22:32:28 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/sbin/update-apt-xapian-index
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: ath_hal
Package: apt-xapian-index 0.4 [modified: usr/share/apt-xapian-index/plugins/apttags.py]
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/sbin/update-apt-xapian-index
ProcCwd: /home/david
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/sbin/update-apt-xapian-index']
SourcePackage: apt-xapian-index
Title: update-apt-xapian-index crashed with KeyError in __getitem__()
Uname: Linux rook 2.6.24-8-generic #1 SMP Thu Feb 14 20:40:45 UTC 2008 i686 GNU/Linux
UserGroups:

David Adam (zanchey) wrote :
David Adam (zanchey) wrote :

This has been fixed by apt-xapian-index 0.5, released upstream Thu, 07 Feb 2008.

apt-xapian-index 0.6 is now available (released Tue, 19 Feb 2008).

Ming Hua (minghua) wrote :

Apt-xapian-index 0.6 has been recently synced in hardy. David, would you please test if this bug has been fixed? Thanks.

David Adam (zanchey) wrote :

Confirmed fixed by apt-xapian-index 0.6.

Changed in apt-xapian-index:
status: New → Fix Released
Tomasz Czapiewski (xeros) wrote :

The same bug does affect my system too:
"update-apt-xapian-index crashed with KeyError in __getitem__()"
Package: apt-xapian-index_0.16_all.deb
Clean Kubuntu Jaunty install (amd64 build from 30 Mar 2009) + updates today.
LANG=pl_PL.UTF-8

Tomasz Czapiewski (xeros) wrote :

Someone else need to confirm this regression in Jaunty.

Changed in apt-xapian-index:
status: Fix Released → New
SBKch (ssbkch) wrote :

Same for me, bug occurs often when i open synaptic, i'm running alpha6 with newest upgrades.

dlamer (l-wojtus) wrote :

I confirm, bug occurs very often (every few minutes) when synaptic is running.

Piotr Stefanczyk (sashx) wrote :

I confirm - Ubuntu 9.04 with newest updates.

mkay (mmkkaayy) wrote :

I confirm this bug... Ubuntu 9.04 with newest updates.

The bug used to occure when i was trying to find something in Synaptic (quick search). Now it is just OK.

OK Thank you

2009/4/5 jakub <email address hidden>

> The bug used to occure when i was trying to find something in Synaptic
> (quick search). Now it is just OK.
>
> --
> update-apt-xapian-index crashed with KeyError in __getitem__()
> https://bugs.launchpad.net/bugs/194731
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Tomasz Czapiewski (xeros) wrote :

Please check the apt-xapian-index bug in Jaunty if it might be a bug #359570. Before I confirmed it here I didn't follow carefully on traceback and apport suggested me this bug. It's my mistake. The bug that I experience is definately bug #359570, not this one.

Kiefer (kiefer-poczta) on 2009-04-14
Changed in apt-xapian-index (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers