python3-xapian not installed when apt-xapian-index upgraded

Bug #1680090 reported by dino99 on 2017-04-05
82
This bug affects 14 people
Affects Status Importance Assigned to Milestone
apt-xapian-index (Ubuntu)
High
Brian Murray
Zesty
High
Brian Murray
xapian-bindings (Ubuntu)
High
Brian Murray
Zesty
High
Brian Murray

Bug Description

Test Case
---------
1) install apt-xapian-index on a yakkety system
2) observe python3-xapian1.3 is installed too
3) edit /etc/apt/sources.list to zesty
4) run apt-get update
5) run apt-get install apt-xapian-index
6) observe python3-xapian1.3 is still installed and that python3-xapian is not

With -proposed enabled python3-xapian1.3 will be removed and python3-xapian will be installed.

Regression Potential
--------------------
It's possible python3-xapian doesn't really have everything we need so some testing of apt-xapian-index should be done.

Recently got this uploaded:

apt-xapian-index (0.47ubuntu12) zesty; urgency=medium

  * d/control: Drop the explicit Depends/Build-Depends on
    python3-xapian1.3 since that was a development snapshot we only used
    in our port to Python 3. Straight up python3-xapian (1.4) has
    everything we need. (LP: #1660216)
    -- Barry Warsaw <...@...> Mon, 03 Apr 2017 13:29:18 -0400

But 1.3.5 continue to be used by default. Python3-xapian1.3 is now declared as orphan.
So the system is not switching itself to 1.4.3

The orphaned package have to be purged manually, and apt-xapian-index is removed. The upgrade cant be made directly due to conflict. At last apt-xapian-index has to be reinstalled.
After that tweak, the index is working as expected.

ProblemType: BugDistroRelease: Ubuntu 17.04
Package: apt-xapian-index 0.47ubuntu12
ProcVersionSignature: Ubuntu 4.10.0-17.19-generic 4.10.8
Uname: Linux 4.10.0-17-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.4-0ubuntu3
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Apr 5 15:26:33 2017
PackageArchitecture: allSourcePackage: apt-xapian-index
UpgradeStatus: No upgrade log present (probably fresh install)

dino99 (9d9) wrote :
summary: - Upgrade to 1.4.3 not self made from 1.3.5
+ python3-xapian not installed when apt-xapian-index upgraded
Brian Murray (brian-murray) wrote :

While apt-xapian-index gained a depends on python3-xapian, python3-xapian1.3 also provides that package so during an upgrade python3-xapian1.3 is kept and python3-xapian is not installed. If the dependency for apt-xapian-index is made a versioned one then python3-xapian will get installed.

Changed in apt-xapian-index (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Brian Murray (brian-murray)
description: updated

Hello dino99, or anyone else affected,

Accepted apt-xapian-index into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apt-xapian-index/0.47ubuntu13 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in apt-xapian-index (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

The apt-xapian-index change is insufficient as python3-xapian1.3 wasn't removed first.

Selecting previously unselected package python3-xapian.
Preparing to unpack .../python3-xapian_1.4.3-1_amd64.deb ...
Unpacking python3-xapian (1.4.3-1) ...
dpkg: error processing archive /var/cache/apt/archives/python3-xapian_1.4.3-1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/python3/dist-packages/xapian/__init__.py', which is also in package python3-xapian1.3 1.3.4-0ubuntu1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../apt-xapian-index_0.47ubuntu13_all.deb ...
Unpacking apt-xapian-index (0.47ubuntu13) over (0.47ubuntu11) ...
Errors were encountered while processing:
 /var/cache/apt/archives/python3-xapian_1.4.3-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Changed in xapian-bindings (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Brian Murray (brian-murray)
Jos Geluk (t-jos) wrote :

Is there a workaround for this bug? On my system apt has stopped working altogether because of this broken pipe error.

Solitaire (bill-s0l) wrote :

Look like it's fixed.

Yesterday I purged both "python3-xapian" and "apt-xapian-index".

Few minutes ago i reinstalled apt-xapian-index and python3-xapian via synaptic, it worked with no issues being reported.

Adam Conrad (adconrad) wrote :

Hello dino99, or anyone else affected,

Accepted xapian-bindings into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xapian-bindings/1.4.3-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xapian-bindings (Ubuntu Zesty):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

With the xapian-bindings upload this looks better now:

(yakkety-amd64)root@impulse:/home/bdmurray# apt-get install apt-xapian-index
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  libxapian-1.3-5
Use 'apt autoremove' to remove it.
The following additional packages will be installed:
  libxapian30 python3-xapian
Suggested packages:
  app-install-data python3-xdg xapian-tools xapian-doc
The following packages will be REMOVED:
  python3-xapian1.3
The following NEW packages will be installed:
  libxapian30 python3-xapian
The following packages will be upgraded:
  apt-xapian-index
1 upgraded, 2 newly installed, 1 to remove and 153 not upgraded.
Need to get 1161 kB of archives.

Setting to verification-done.

tags: added: verification-done
removed: verification-needed
dino99 (9d9) wrote :

@Brian

Today i've started with Zesty system which was not used/updated since a week or so. Proposed is activated, so i've got the supposed fix: the upgrade still display an error related to the /var/apt/cache package, the upgrade failed. Need to purge the installed *xapian* packages before to be able to install apt-xapian-index

dino99 (9d9) on 2017-04-22
tags: added: verification-needed
removed: verification-done
Changed in apt-xapian-index (Ubuntu):
status: Fix Committed → In Progress
Changed in apt-xapian-index (Ubuntu Zesty):
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt-xapian-index - 0.47ubuntu13

---------------
apt-xapian-index (0.47ubuntu13) zesty; urgency=medium

  * d/control: Change the dependency on python3-xapian to a versioned one so
    that on upgrades the package will be installed and python3-xapian1.3 will
    be removed. (LP: #1680090)

 -- Brian Murray <email address hidden> Wed, 12 Apr 2017 09:10:22 -0700

Changed in apt-xapian-index (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xapian-bindings - 1.4.3-1ubuntu1

---------------
xapian-bindings (1.4.3-1ubuntu1) zesty; urgency=medium

  * d/control: Add a conflicts / replaces on python3-xapian1.3 for upgrades.
    (LP: #1680090)

 -- Brian Murray <email address hidden> Thu, 13 Apr 2017 11:47:36 -0700

Changed in xapian-bindings (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers