jaunty alternate cd media change error

Bug #316618 reported by jerrylamos
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apt-setup (Ubuntu)
Fix Released
High
Colin Watson

Bug Description

Today's download ubuntu alternate from Daily ubuntu 20090112
MD5SUM checks fine.
Check CD for defects checks fine.
Manual install proceeds quite a while then suddenly gets a "media change" error.
CD has not been changed.
Cannot eject and re-insert CD, it's locked.
Wild guess, has install decided the CD drive is a different type?

Attached is lspci -vvnn

Anything I can try?

Thanks, Jerry

Related branches

Revision history for this message
jerrylamos (jerrylamos) wrote :
Revision history for this message
Colin Watson (cjwatson) wrote :

Could you boot the installer with DEBCONF_DEBUG=developer on the kernel command line, then send me /var/log/syslog from the running installer after reproducing this bug? You can extract the log file using "Save debug logs" from the installer's main menu (select "Go back" until you get to it).

Changed in debian-installer:
status: New → Incomplete
Revision history for this message
jerrylamos (jerrylamos) wrote : Re: [Bug 316618] Re: jaunty alternate cd media change error
  • syslog Edit (2.7 MiB, application/octet-stream; name="syslog")

 Attached is the syslog after the failure.? The end of the syslog has gobs of media change error messages most of which are redundant as I was trying to get to any kind of <go back>.
The only option on the media change screen? was? <continue>, no <go back>, so I broke out of install with an Alt-F4 (or was it F5) and used a command line Alt-F2 to save /var/log/syslog to a usb file, then booted a jaunty for this reply.
The media change error occurs just after:
scanning the mirror
at:
Select and Install Software
1%

It asks for exactly the CD that is in the drive,
"Jaunty Jackalope" -Alpha i386 (20090112.1)
as I remember.

Anything you'd like me to try, let me know.

Thanks, Jerry

-----Original Message-----
From: Colin Watson <email address hidden>
To: <email address hidden>
Sent: Tue, 13 Jan 2009 12:54 pm
Subject: [Bug 316618] Re: jaunty alternate cd media change error

Could you boot the installer with DEBCONF_DEBUG=developer on the kernel
command line, then send me /var/log/syslog from the running installer
after reproducing this bug? You can extract the log file using "Save
debug logs" from the installer's main menu (select "Go back" until you
get to it).

** Changed in: debian-installer (Ubuntu)
       Status: New => Incomplete

--
jaunty alternate cd media change error
https://bugs.launchpad.net/bugs/316618
You received this bug notification because you are a direct subscriber
of the bug.

Revision history for this message
jerrylamos (jerrylamos) wrote :

/var/log/syslog sent to Colin.

Thanks, Jerry

Colin Watson (cjwatson)
Changed in debian-installer:
assignee: nobody → kamion
importance: Undecided → High
status: Incomplete → Confirmed
Revision history for this message
jerrylamos (jerrylamos) wrote :

As a check, I downloaded Alpha 2 alternate. No media change error on the same hardware.

Jerry

Revision history for this message
Colin Watson (cjwatson) wrote :

Frustratingly, I can't reproduce this, despite thinking it's important and probably something I broke recently ...

Could you please try this again, still with DEBCONF_DEBUG=developer, but add the following special steps:

 * When it asks you for your hostname, stop, and press Alt-F2 to switch to the second console.
 * Type 'nano /var/lib/dpkg/info/pkgsel.postinst' (without the quotes), and change 'set -e' on the second line to 'set -ex'. Save and exit.
 * Do the same thing with /usr/lib/apt-setup/generators/40cdrom, /usr/lib/apt-setup/generators/41cdset, and /usr/bin/load-install-cd.
 * Press Alt-F1 to switch back to the main installer console, and continue.
 * Attach the new /var/log/syslog when you're done.

Revision history for this message
Dave Morley (davmor2) wrote :

New syslog

Revision history for this message
jerrylamos (jerrylamos) wrote :

Colin, here's syslog after following your directions and getting the media change error again.

Jerry

Revision history for this message
Colin Watson (cjwatson) wrote :

Thanks to both of you; I think I have this figured out now.

Changed in debian-installer:
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt-setup - 1:0.37ubuntu9

---------------
apt-setup (1:0.37ubuntu9) jaunty; urgency=low

  * Use cdrom-detect/cdrom_fs when remounting the CD to ensure that we do so
    using the same filesystem.
  * Make sure apt-cdrom doesn't unmount the CD in the first place if cd_type
    ends with /single (LP: #316618).

 -- Colin Watson <email address hidden> Wed, 14 Jan 2009 15:04:44 +0000

Changed in apt-setup:
status: Fix Committed → Fix Released
Revision history for this message
jerrylamos (jerrylamos) wrote :

Colin,

Is the fix below involved in the current manual install failure where install "can't write the partition table" because "there is a device still mounted", namely "/cdrom"?? Bug #318485

Thanks, Jerry

-----Original Message-----
From: Launchpad Bug Tracker <email address hidden>
To: <email address hidden>
Sent: Wed, 14 Jan 2009 10:10 am
Subject: [Bug 316618] Re: jaunty alternate cd media change error

This bug was fixed in the package apt-setup - 1:0.37ubuntu9

---------------
apt-setup (1:0.37ubuntu9) jaunty; urgency=low

  * Use cdrom-detect/cdrom_fs when remounting the CD to ensure that we do so
    using the same filesystem.
  * Make sure apt-cdrom doesn't unmount the CD in the first place if cd_type
    ends with /single (LP: #316618).

 -- Colin Watson <email address hidden> Wed, 14 Jan 2009 15:04:44 +0000

** Changed in: apt-setup (Ubuntu)
       Status: Fix Committed => Fix Released

--
jaunty alternate cd media change error
https://bugs.launchpad.net/bugs/316618
You received this bug notification because you are a direct subscriber
of the bug.

Revision history for this message
Colin Watson (cjwatson) wrote :

I don't *think* so, but it's not impossible. Rest assured that I have not forgotten about this change and will take it into account when debugging.

Revision history for this message
MountainX (dave-mountain) wrote :

Probably related, and could be a work-around for those having this issue:
http://ubuntuforums.org/showpost.php?p=10420985&postcount=13

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers