[Xenial] 2015-12-25 ISOs (multiple ones) leave 'deb' line for CDROM uncommented after install

Bug #1529297 reported by Thomas Ward on 2015-12-25
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
apt-setup (Ubuntu)
Critical
Colin Watson

Bug Description

If this is in the wrong location, please repoint this to the right package.

During an Installation test case for Ubuntu Server, using the 2015-12-25 ISOs on the test case for an Ubuntu Server ISO, it was discovered that after installation the /etc/apt/sources.list file has two CDROM lines present, which would rely on the installation ISOs. One is commented, but the second is not, and out of the box, apt-get and updating does not work.

Workaround is to comment out that second cdrom line which was uncommented, then updates and such work as expected.

Thomas Ward (teward) on 2015-12-25
summary: - [Xenial] 2015-12-25 ISO leaves 'deb' line for CDROM uncommented at
- install
+ [Xenial] 2015-12-25 Server ISO leaves 'deb' line for CDROM uncommented
+ after install

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Phill Whiteside (phillw) wrote :

This has been traced back from alternate lubuntu installer, which fail to install.

Thomas Ward (teward) wrote :

Note that my testing on this was on Server ISO specifically, and Phill's issues were on the Lubuntu Alternate installer (and then traced backwards).

summary: - [Xenial] 2015-12-25 Server ISO leaves 'deb' line for CDROM uncommented
- after install
+ [Xenial] 2015-12-25 ISOs (multiple ones) leave 'deb' line for CDROM
+ uncommented after install
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1529297

tags: added: iso-testing
Thomas Ward (teward) wrote :

Confirmed on the 20151230 image as well. Per Colin Watson, attaching that image's /var/log/installer/syslog.

Colin Watson (cjwatson) on 2015-12-30
affects: debian-installer (Ubuntu) → apt-setup (Ubuntu)
Colin Watson (cjwatson) on 2015-12-30
Changed in apt-setup (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Colin Watson (cjwatson)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt-setup - 1:0.104ubuntu2

---------------
apt-setup (1:0.104ubuntu2) xenial; urgency=medium

  * Fix mismerge that caused us not to disable the CD at the end of
    installation if any mirrors are present in the case of complete CD
    images (LP: #1529297).

 -- Colin Watson <email address hidden> Wed, 30 Dec 2015 20:18:05 +0000

Changed in apt-setup (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers