drop extras.ubuntu.com

Bug #1409555 reported by Dimitri John Ledkov on 2015-01-11
152
This bug affects 38 people
Affects Status Importance Assigned to Milestone
apt-setup (Ubuntu)
Undecided
Unassigned
kubuntu-meta (Ubuntu)
Undecided
Unassigned
lubuntu-meta (Ubuntu)
Undecided
Unassigned
software-center (Ubuntu)
Undecided
Unassigned
ubuntu-gnome-meta (Ubuntu)
Undecided
Unassigned
ubuntu-meta (Ubuntu)
Undecided
Unassigned
ubuntu-release-upgrader (Ubuntu)
High
Unassigned
ubuntukylin-meta (Ubuntu)
Undecided
Unassigned
ubuntustudio-meta (Ubuntu)
Undecided
Unassigned
xubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Related branches

lp:~xnox/apt-setup/lp1409555
Stephan Graber: Pending requested 2015-01-11
Ubuntu Core Development Team: Pending requested 2015-01-11
lp:~xnox/software-center/lp1409555
Rodney Dawes: Approve on 2015-03-24
Michael Vogt: Approve on 2015-01-12
lp:~xnox/ubuntu-release-upgrader/lp1409555
Michael Vogt: Approve on 2015-01-29
Brian Murray: Pending requested 2015-01-12
Ubuntu Core Development Team: Pending requested 2015-01-12
description: updated
Changed in kubuntu-meta (Ubuntu):
status: New → In Progress
Changed in ubuntu-gnome-meta (Ubuntu):
status: New → In Progress
Changed in ubuntu-meta (Ubuntu):
status: New → In Progress
Changed in ubuntukylin-meta (Ubuntu):
status: New → In Progress
Changed in ubuntustudio-meta (Ubuntu):
status: New → In Progress
Changed in xubuntu-meta (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 13.10-0ubuntu5

---------------
software-center (13.10-0ubuntu5) vivid; urgency=medium

  * Drop ubuntu-extras-keyring dependency. (LP: #1409555).
 -- Dimitri John Ledkov <email address hidden> Sun, 11 Jan 2015 23:51:10 +0000

Changed in software-center (Ubuntu):
status: New → Fix Released
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-meta - 1.316

---------------
kubuntu-meta (1.316) vivid; urgency=medium

  * Refreshed dependencies
  * Added kimageformat-plugins to desktop-recommends [amd64 arm64 armhf
    i386 ppc64el], full-recommends [amd64 arm64 armhf i386 ppc64el]
  * Added qt5-image-formats-plugins to desktop-recommends, full-
    recommends
  * Removed ubuntu-extras-keyring from desktop (LP: #1409555)
 -- Dimitri John Ledkov <email address hidden> Mon, 12 Jan 2015 23:29:53 +0000

Changed in kubuntu-meta (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-gnome-meta - 0.36

---------------
ubuntu-gnome-meta (0.36) vivid; urgency=medium

  * Refreshed dependencies
  * Removed ubuntu-extras-keyring from desktop (LP: #1409555)
 -- Dimitri John Ledkov <email address hidden> Mon, 12 Jan 2015 23:40:37 +0000

Changed in ubuntu-gnome-meta (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntukylin-meta - 0.5

---------------
ubuntukylin-meta (0.5) vivid; urgency=medium

  * update.cfg: switch to vivid.
  * Refreshed dependencies
  * Added ttf-ancient-fonts-symbola to desktop-recommends
  * Removed nautilus-open-terminal from desktop
  * Removed ubuntu-extras-keyring from desktop (LP: #1409555)
 -- Dimitri John Ledkov <email address hidden> Tue, 13 Jan 2015 00:18:19 +0000

Changed in ubuntukylin-meta (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.328

---------------
ubuntu-meta (1.328) vivid; urgency=medium

  * update.cfg: Switch to vivid.
  * Refreshed dependencies
  * Added ttf-ancient-fonts-symbola to desktop-recommends
  * Removed ubuntu-extras-keyring from desktop (LP: #1409555)
 -- Dimitri John Ledkov <email address hidden> Mon, 12 Jan 2015 23:54:22 +0000

Changed in ubuntu-meta (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntustudio-meta - 0.129

---------------
ubuntustudio-meta (0.129) vivid; urgency=medium

  * Manually drop ubuntu-extras-keyring. (LP: #1409555)
 -- Dimitri John Ledkov <email address hidden> Tue, 13 Jan 2015 00:24:41 +0000

Changed in ubuntustudio-meta (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-meta - 2.186

---------------
xubuntu-meta (2.186) vivid; urgency=medium

  * Refreshed dependencies
  * Removed ubuntu-extras-keyring from core, desktop (LP: #1409555)
 -- Dimitri John Ledkov <email address hidden> Tue, 13 Jan 2015 00:40:41 +0000

Changed in xubuntu-meta (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-meta - 0.57

---------------
lubuntu-meta (0.57) vivid; urgency=medium

  * Refreshed dependencies
  * Removed ubuntu-extras-keyring from core [amd64 armhf i386 powerpc] (LP: #1409555)
 -- Dimitri John Ledkov <email address hidden> Tue, 13 Jan 2015 01:47:26 +0000

Changed in lubuntu-meta (Ubuntu):
status: New → Fix Released
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt-setup (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1409555

tags: added: iso-testing
Jonathan Riddell (jr) on 2015-01-21
tags: added: kubuntu
Changed in kubuntu-meta (Ubuntu):
milestone: none → ubuntu-15.04
tags: added: block-proposed
Dave Stroud (bigdavesr) wrote :

it shows fix released for ubuntu gnome but upgrade still fails. because no vivid extras cant be found

On 7 February 2015 at 19:25, Dave Stroud <email address hidden> wrote:
> it shows fix released for ubuntu gnome but upgrade still fails. because
> no vivid extras cant be found

This problem needs to be fixed in _all_ affected packages. Which is
still in progress.
This is not indication that particular products have been fixed.
--
Regards,

Dimitri.

tags: removed: block-proposed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:15.04.5

---------------
ubuntu-release-upgrader (1:15.04.5) vivid; urgency=medium

  * Remove extras.ubuntu.com (LP: #1409555)
  * Fix resource warnings & logging.warn deprecation warning.
 -- Dimitri John Ledkov <email address hidden> Sat, 07 Feb 2015 16:17:12 +0000

Changed in ubuntu-release-upgrader (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt-setup - 1:0.80ubuntu7

---------------
apt-setup (1:0.80ubuntu7) vivid; urgency=medium

  * Remove extras.ubuntu.com. (LP: #1409555)
  * Regenerate translations (needs later re-import from Launchpad?!)
  * Drop extras.ubuntu.com release files
 -- Dimitri John Ledkov <email address hidden> Sun, 08 Feb 2015 20:01:29 +0000

Changed in apt-setup (Ubuntu):
status: Confirmed → Fix Released
Changed in software-center:
status: New → Fix Committed
Rodney Dawes (dobey) on 2015-12-18
no longer affects: software-center
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers