Ubuntu

apt-move fails to move any packages

Reported by Rob Johnston on 2012-03-04
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
apt-move (Debian)
Fix Released
Unknown
apt-move (Ubuntu)
Undecided
Unassigned

Bug Description

The program appears to run correctly in that no error is reported, but no packages are moved. This action work on Ubuntu 10.04 and 10.10, but fails on 11.10 and 12.04 Beta1.

Expected result:
Packages located at /var/cache/apt/archives will be moved to subdirectories under /mirrors/debian/pool.

Actual result:
The subdirectories named "dists" and "pool" are created, but nothing below that is created.

Steps to reproduce:

After a fresh install, install apt-move:
# sudo apt-get install apt-move

Then run apt-move:
#sudo apt-move update

Output is similar to the following...
    dpkg: warning: obsolete option '--print-installation-architecture', please use '--print-architecture' instead.

    Updating from local Packages files...

    Moving files...
    Skipping files:
    /var/cache/apt/archives/apt-move_4.2.27-1ubuntu10_amd64.deb
    Moving Files:
    <NOTE: a list of all packages under /var/cache/apt/archives is output here>

    File deletes disabled, skipping.

    Creating Packages files...
    Creating Release files...

    All done, exiting.

Now look to see what was done:
#ls /mirrors/debian

The "dists" and "pool" subdirectories appear, but the following two commands reveal emptyness... nothing is contained in them.
#ls /mirrors/debian/dists
#ls /mirrors/debian/pool

Note that if the option in /etc/apt-move.conf named COPYONLY=no then the files in /var/cache/apt/archives will be deleted, so set it to COPYONLY=yes so this test can be re-run easily. Also, fixing the warning given by dpkg has no effect.

#lsb_release -rd
Description: Ubuntu 11.10
Release: 11.10

#apt-cache policy apt-move
apt-move:
  Installed: 4.2.27-1ubuntu10
  Candidate: 4.2.27-1ubuntu10
  Version table:
 *** 4.2.27-1ubuntu10 0
        500 http://ca.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: apt-move 4.2.27-1ubuntu10
ProcVersionSignature: Ubuntu 3.0.0-16.28-generic 3.0.17
Uname: Linux 3.0.0-16-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Sun Mar 4 14:51:16 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427.1)
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 LC_MESSAGES=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: apt-move
UpgradeStatus: Upgraded to oneiric on 2012-02-04 (29 days ago)
modified.conffile..etc.apt.move.conf: [modified]
mtime.conffile..etc.apt.move.conf: 2012-03-01T22:03:24.573157

Rob Johnston (rob-johnston) wrote :
Rob Johnston (rob-johnston) wrote :

Forgot to mention, an "apt-get update" after a fresh install will not fix the problem on the affected versions. All tested were done on ubuntu-*-desktop-amd64.

summary: - apt-move fails to actually move packages
+ apt-move fails to actually move any packages
summary: - apt-move fails to actually move any packages
+ apt-move fails to move any packages
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt-move (Ubuntu):
status: New → Confirmed
Damir Prebeg (damir-prebeg) wrote :

I have completely the same problem, please fix it!

Changed in apt-move (Debian):
status: Unknown → Fix Released
Jorge Suárez de Lis (ys) wrote :

Please, someone merge the patch fix_perl_implicit_split_deprecation.patch from Debian in Ubuntu 12.04, since apt-move is not working at all because of this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.