apt-mirror will not automatically create directories if base_path is non-default

Bug #727011 reported by Rob Verduijn on 2011-03-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apt-mirror (Debian)
Fix Released
Unknown
apt-mirror (Ubuntu)
Low
Micah Gersten
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: apt-mirror

Hello,

I've been trying to get apt-mirror to use a different directory than the default one.
I noticed that the base-path setting in the apt-mirror config file is ignored.

After looking at the perl script I saw that the check for the three working directories is done before the processing of the config file.
Thus the alternative path setting would not be applied until after the setting of the work directories.
After putting that piece of code behind the processing of the config file code the alternative path worked.

I've attached a patch file that fixes the problem.

Rob Verduijn

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: apt-mirror 0.4.8-3
ProcVersionSignature: Ubuntu 2.6.35-25.44-generic 2.6.35.10
Uname: Linux 2.6.35-25-generic i686
Architecture: i386
Date: Tue Mar 1 08:35:37 2011
PackageArchitecture: all
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: apt-mirror

Rob Verduijn (rob-verduijn) wrote :
tags: added: patch
Micah Gersten (micahg) wrote :

Thank you for reporting this to Ubuntu. I just tried this package yesterday and had this issue that it wouldn't create the directories for me. I'm taking a look at your patch now.

Changed in apt-mirror (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → Low
status: New → In Progress
Micah Gersten (micahg) on 2011-03-22
summary: - apt-mirror ignores base-path setting in config file
+ apt-mirror will not automatically create directories if base_path is
+ non-default
Micah Gersten (micahg) on 2011-03-23
tags: added: patch-forwarded-debian
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt-mirror - 0.4.8-3ubuntu1

---------------
apt-mirror (0.4.8-3ubuntu1) natty; urgency=low

  * fix LP: #727011 - apt-mirror will not automatically create directories if
    base_path is non-default; Thanks to Rob Verduijn for the patch
    - add debian/patches/create_dirs.patch
    - update debian/patches/series
 -- Micah Gersten <email address hidden> Tue, 22 Mar 2011 23:19:53 -0500

Changed in apt-mirror (Ubuntu):
status: In Progress → Fix Released
Changed in apt-mirror (Debian):
status: Unknown → New
Rob Verduijn (rob-verduijn) wrote :

Hello,

This bug is also present in natty narwal

The fix is exactly to apply exactly the same patch mentioned above.

Should I start writing the bug report for oneiric as well ?

Rob

Rob Verduijn (rob-verduijn) wrote :

you're right,

I made a mistake my apologies
(note to self, do not write bug reports when tired)

I've been working with lucid and natty all day, it was the lucid version that has the same problem.
Which is not really surprising since that one predates all the other versions

So the apt-mirror script on lucid 10.4.3 also has this bug, the same patch can be applied.

Rob

Changed in apt-mirror (Debian):
status: New → Fix Released
annunaki2k2 (russell-knighton) wrote :

This bug is still present in Lucid.

Any chance it can be back ported to Lucid? I've attached a patch made on the current Lucid version.

Benjamin Drung (bdrung) wrote :

I will put this patch into a debdiff and upload it to precise-proposed if you update the description to add a test case, impact, regression potential as described on [1].

[1] https://wiki.ubuntu.com/StableReleaseUpdates

Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in apt-mirror (Ubuntu Lucid):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.