apt-mirror i18n files

Bug #368419 reported by Thomy23 on 2009-04-28
84
This bug affects 17 people
Affects Status Importance Assigned to Milestone
apt-mirror (Ubuntu)
Wishlist
Brandon Holtsclaw

Bug Description

I have a problem with apt-mirror, it doesn't mirror the i18n files on the remote target (i.e. ftp://ftp.ubuntu.com/ubuntu/dists/intrepid/main/i18n/). Is there a solution available?

Description: Ubuntu 8.04.2
Release: 8.04
Package: ii apt-mirror 0.4.5-1ubuntu1.1~8.04prevu1 APT sources mirroring tool
(i backported apt-mirror from intrepid because of the .bz2 files bug in 0.4.5)

Greets Thomas

Changed in apt-mirror (Ubuntu):
assignee: nobody → Brandon Holtsclaw (imbrandon)
Brandon Holtsclaw (imbrandon) wrote :

for an immediate fix you could use postmirror.sh to rsync these files, I'll look deeper into the issue and see if we cant come up with a more elegant solution though.

Brandon Holtsclaw (imbrandon) wrote :

upon further inspection the correct solution for this is to mirror the files via postmirror.sh , examples have been added in the 0.4.7 release, and 0.4.7 has been backported.

here is a url for the example(s)
http://apt-mirror.svn.sourceforge.net/viewvc/apt-mirror/trunk/postmirror.sh?revision=38&view=markup

Changed in apt-mirror (Ubuntu):
importance: Undecided → Wishlist
status: New → Won't Fix
Colin Watson (cjwatson) wrote :

Please reconsider this; as of Ubuntu 11.10, even English package descriptions are in Translations-en rather than Packages. Given that, I think this deserves to be built-in rather than require scripting.

chrone (chrone81) wrote :

i can confirm that this bug still exist on ubuntu 11.10 amd64. the default mirror.list configuration is still on natty, not oneiric. that's a bummer. :(

here's the apache error log:
[Sun Mar 11 17:02:16 2012] [error] [client 127.0.0.1] File does not exist: /var/www/ubuntu/dists/oneiric-updates/universe/i18n

Varga Péter (vpetike) wrote :

I can confirm that this bug is there in 12.04, i386. Still no mirroring of i18n.

Andy Brook (andyb-chp) wrote :

In my humble opinion it's bugs like this that really hurt Ubuntu chances in the corporate world, it's certainly causing us some pain. We've just setup an internal apt-mirror and now found that it isn't going to work, and hacking in rsync to fill in the gaps isn't really an option as it's punching extra holes in the firewall.

Can I encourage people to click at the top to say this bug affects you if you are affected. Thanks.

Yazz D. Atlas (entropyworks) wrote :

Annoying bug filling up error logs...

Brandon Holtsclaw (imbrandon) wrote :

This is now fixed in the 0.4.9 release.

Changed in apt-mirror (Ubuntu):
status: Won't Fix → Fix Committed
Benjamin Drung (bdrung) wrote :

Setting to fix released, because apt-mirror 0.4.9-1 is in raring.

Changed in apt-mirror (Ubuntu):
status: Fix Committed → Fix Released

Will 0.4.9-1 get into Precise?

Does the fix correct the mirroring of the i18n packages?

(trying to rsync from postmirror.sh doesn't work reliably anyway. Whatever the server(s) are that it rsyncs to have very limited connection numbers... my rsyncs never succeeded reliably.)

it does fix the i18n files , they are syncd as part of apt-mirrors normal
files now ... as for precise i'm not sure.

On Fri, Apr 26, 2013 at 8:59 AM, Craig Constantine <
<email address hidden>> wrote:

> Will 0.4.9-1 get into Precise?
>
> Does the fix correct the mirroring of the i18n packages?
>
> (trying to rsync from postmirror.sh doesn't work reliably anyway.
> Whatever the server(s) are that it rsyncs to have very limited
> connection numbers... my rsyncs never succeeded reliably.)
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/368419
>
> Title:
> apt-mirror i18n files
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/apt-mirror/+bug/368419/+subscriptions
>

--
*Brandon Holtsclaw*
Voice / SMS: 816-974-6106
LinkedIn: http://linkedin.com/in/brandonholtsclaw
Blog: http://www.brandonholtsclaw.com <http://brandonholtsclaw.com>

Benjamin Drung (bdrung) wrote :

For precise, you need to follow the SRU process [1] by cherry-picking the fix from 0.4.9-1 and apply it to the precise version.

[1]

can you point me to the actual change... I don't see it under Raring or Raring-proposed under source...

SRU: thanks.

...but I meant, can you point me into a source repo/file/whatever that shows the actual change which constitutes the fix...

apt-mirror isn't mission critical for me; I'll just smash the fix into my installation (if possible.) I've no time to learn the SRU process and to petition to have this fix ushered into Precise.

Benjamin Drung (bdrung) wrote :

You could download the precise and raring version of apt-mirror and compare them with diff:

pull-lp-source apt-mirror raring
pull-lp-source apt-mirror precise
diff -pruN apt-mirror-0.4.8/ apt-mirror-0.4.9/ > diff

Rod Smith (rodsmith) wrote :

I'm having this problem with a mirror (using Trusty) of Xenial files.

Colin Watson (cjwatson) wrote :

Rod, this was probably bug 1544806, now fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers