Comment 5 for bug 174314

Daniel Hahler (blueyed) wrote :

I had apport redirect me to this bug report just now.

The test case does not crash for me either anymore (after making sure that libqt4-core is installed before / at all).

The traceback from this report is:

 Traceback (most recent call last):
   File "/usr/bin/apt-listchanges", line 237, in <module>
     main()
   File "/usr/bin/apt-listchanges", line 142, in main
     (news, changelog) = pkg.extract_changes(config.which, fromversion, config.reverse)
   File "/usr/share/apt-listchanges/DebianFiles.py", line 159, in extract_changes
     changelog = reduce(find_first, changelog_filenames + changelog_filenames_native, None)
   File "/usr/share/apt-listchanges/DebianFiles.py", line 156, in <lambda>
     find_first = lambda acc, fname: acc or self.read_changelog(os.path.join(tempdir, fname), since_version, reverse)
   File "/usr/share/apt-listchanges/DebianFiles.py", line 217, in read_changelog
     fd = gzip.GzipFile(filename)
   File "/usr/lib/python2.7/gzip.py", line 89, in __init__
     fileobj = self.myfileobj = __builtin__.open(filename, mode or 'rb')
 IOError: [Errno 40] Too many levels of symbolic links: '/tmp/apt-listchangesfKmDOW/usr/share/doc/ntrack-module-libnl-0/changelog.Debian.gz'

I am re-assigning it to apt-listchanges, because it appears to be a more generic problem.