apt-listchanges crashed with IOError "Too many levels of symbolic links" with libqt4-core

Bug #174314 reported by Hari on 2007-12-06
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apt-listchanges (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: apt-listchanges

It happened during an 'aptitude dist-upgrade'

TEST CASE (invalid):
$ wget http://launchpadlibrarian.net/10756952/libqt4-core_4.3.3-0ubuntu1_amd64.deb
$ apt-listchanges -a libqt4-core_4.3.3-0ubuntu1_amd64.deb

ProblemType: Crash
Architecture: amd64
Date: Thu Dec 6 11:47:46 2007
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/apt-listchanges
InterpreterPath: /usr/bin/python2.5
Package: apt-listchanges 2.74ubuntu3
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/apt-listchanges --apt
ProcCwd: /home/harinath
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=en_IN.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/apt-listchanges', '--apt']
SourcePackage: apt-listchanges
Title: apt-listchanges crashed with IOError in __init__()
Uname: Linux hariville.hurrynot.org 2.6.24-1-generic #1 SMP Thu Nov 29 18:47:10 GMT 2007 x86_64 GNU/Linux
UserGroups:

Hari (harinath) wrote :
Daniel Hahler (blueyed) wrote :

Confirmed. I'm adding a testcase to the description.

Changed in apt-listchanges:
importance: Undecided → Medium
status: New → Confirmed
Daniel Hahler (blueyed) on 2007-12-08
description: updated
Daniel Hahler (blueyed) wrote :

Re-assigning to qt4-x11, because it's a bug with the libqt4-core package.
As far as I can see this regressed in version 4.3.3-0ubuntu1, while 4.3.2-0ubuntu3.1 is ok.

Changed in apt-listchanges:
status: Confirmed → Triaged
Jonathan Thomas (echidnaman) wrote :

The testcase doesn't crash in Kubuntu 9.04.

Changed in qt4-x11 (Ubuntu):
status: Triaged → Fix Released
Daniel Hahler (blueyed) wrote :

I had apport redirect me to this bug report just now.

The test case does not crash for me either anymore (after making sure that libqt4-core is installed before / at all).

The traceback from this report is:

 Traceback (most recent call last):
   File "/usr/bin/apt-listchanges", line 237, in <module>
     main()
   File "/usr/bin/apt-listchanges", line 142, in main
     (news, changelog) = pkg.extract_changes(config.which, fromversion, config.reverse)
   File "/usr/share/apt-listchanges/DebianFiles.py", line 159, in extract_changes
     changelog = reduce(find_first, changelog_filenames + changelog_filenames_native, None)
   File "/usr/share/apt-listchanges/DebianFiles.py", line 156, in <lambda>
     find_first = lambda acc, fname: acc or self.read_changelog(os.path.join(tempdir, fname), since_version, reverse)
   File "/usr/share/apt-listchanges/DebianFiles.py", line 217, in read_changelog
     fd = gzip.GzipFile(filename)
   File "/usr/lib/python2.7/gzip.py", line 89, in __init__
     fileobj = self.myfileobj = __builtin__.open(filename, mode or 'rb')
 IOError: [Errno 40] Too many levels of symbolic links: '/tmp/apt-listchangesfKmDOW/usr/share/doc/ntrack-module-libnl-0/changelog.Debian.gz'

I am re-assigning it to apt-listchanges, because it appears to be a more generic problem.

Changed in qt4-x11 (Ubuntu):
status: Fix Released → Triaged
affects: qt4-x11 (Ubuntu) → apt-listchanges (Ubuntu)
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt-listchanges - 3.15

---------------
apt-listchanges (3.15) unstable; urgency=medium

  * Handle `Too many levels of symbolic links' (ELOOP) error while searching
    for possible changelog file names (LP: #174314).

  * Updated debconf translations:
    + Dutch (Frans Spiesschaert, closes: #874278);
    + French (Alban Vidal, closes: #872200);
    + German (Helge Kreutzmann, closes: #877432);
    + Portuguese (Rui Branco, closes: #870084);
    + Russian (Lev Lamberov, closes: #883878).
  * Updated program translations:
    + Dutch (Frans Spiesschaert, closes: #874288);
    + German (Helge Kreutzmann, closes: #878320);
    + Japanese (Hideki Yamane, closes: #880042).
  * Updated man page translations:
    + French (Jean-Pierre Giraud, closes: #874023).

  * Cleanup English text of debconf templates, based on Justin B Rye's input
    in https://lists.debian.org/debian-l10n-english/2017/07/msg00005.html.
    Update debconf translations and unfuzzy them when possible.
  * debian/control:
    + add Rules-Requires-Root: no;
    + Standards-Version: 4.1.2.

 -- Robert Luberda <email address hidden> Fri, 22 Dec 2017 22:07:29 +0100

Changed in apt-listchanges (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers