[Blocker] Upgrades are failing with error : Dpkg::Tools::Options::/usr/bin/apt-listchanges::InfoFD should be greater than 2

Bug #1614191 reported by dino99 on 2016-08-17
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
apt-listchanges (Ubuntu)
Undecided
Unassigned

Bug Description

Since the apt-listchanges upgrade, installing packages now fails with:

apt-listchanges: APT_HOOK_INFO_FD environment variable is incorrectly defined
(Dpkg::Tools::Options::/usr/bin/apt-listchanges::InfoFD should be greater than 2).
E: Sub-process /usr/bin/apt-listchanges --apt || test $? -ne 10 returned an error code (1)
E: Failure running script /usr/bin/apt-listchanges --apt || test $? -ne 10
A package failed to install. Trying to recover:

and nothing happen then (no recovery). Got that issue when trying to upgrade openprinting-ppds 20160817

Tried to downgrade apt-listchanges to 2.89 also fails with the same error

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: apt-listchanges 3.3ubuntu2
ProcVersionSignature: Ubuntu 4.8.0-1.2-generic 4.8.0-rc2
Uname: Linux 4.8.0-1-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Aug 17 19:28:08 2016
PackageArchitecture: all
SourcePackage: apt-listchanges
UpgradeStatus: No upgrade log present (probably fresh install)

dino99 (9d9) wrote :
description: updated
summary: - Upgrades are failing with error
+ Upgrades are failing with error : Dpkg::Tools::Options::/usr/bin/apt-
+ listchanges::InfoFD should be greater than 2
dino99 (9d9) on 2016-08-17
summary: - Upgrades are failing with error : Dpkg::Tools::Options::/usr/bin/apt-
- listchanges::InfoFD should be greater than 2
+ [Blocker] Upgrades are failing with error :
+ Dpkg::Tools::Options::/usr/bin/apt-listchanges::InfoFD should be greater
+ than 2
dino99 (9d9) wrote :

Feedback

Closing the gnome-shell session and doing a cold reboot solve that problem: the queued packages has been upgraded without getting this error.
I am not closing that report as i'm not sure about a needed fix, or a simple warning comment added into the changelog to help users understanding this issue.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apt-listchanges (Ubuntu):
status: New → Confirmed
Kyle Robbertze (krobbertze) wrote :

If rebooting does not fix it adding

DPkg::Tools::Options::/usr/bin/apt-listchanges::InfoFD "20";

to /etc/apt/apt.conf.d/20listchanges does

Eric (eric-grimaldi) wrote :

I needed to remove this file:
/usr/bin/apt-listchanges --apt || test $? -lt 10
from:
/etc/apt/apt.conf.d/20listchanges

It's ok for me now, hope that can help...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt-listchanges - 3.13

---------------
apt-listchanges (3.13) unstable; urgency=low

  * Fix changelog parser to mark files as being in the Debian changelog
    format *before* checking if the latest version has been seen already.
  * Refactor apt-listchanges.py to remove duplicated code.
  * Rewrite main loop of program in order to limit a number of calls to
    `apt-get changelog':
    1. First group packages by the source package and next process all binary
       packages from the same source package at once.
    2. Sort the packages in each group by their binary versions descending.
    3. Exclude those of them whose versions were already seen or are lower
       (except for the binnmu suffix) than the maximal version, i.e. the
       version of the first package in the group.
    4. Process the remaining packages until valid changelog or news entries
       are found, and call `apt-get changelog' on the first package if and
       only if no such changelog entries are found, and apt-listchanges is
       not configured to display the news entries only.
  * Override the LESS environment variable to make sure it does not contain
    certain flags like -F that might cause less program to quit before even
    user is able to see the files generated by the program.
  * Fix an issue with showing changelog entries with unrecognised urgencies
    (see #866358): map such an urgency to a non-zero value and use proper
    `is None' check for testing the mapped value.
  * Fix an exception, introduced in 2.87, occurring when the `--since' option
    is used with the invalid number of `.deb' files. Clarify the error message
    shown in such a case.
  * In the `--verbose' mode when apt-listchanges is configured to display
    `news' only append the informational notes to the news entries instead
    of creating changelog entries.
  * Don't permit `--since' and `--show-all' to be used together. Also make
    sure that passing one of them in the command line overrides any eventual
    config file setting related to the other one.
  * Fix a spelling typo in `retrieve' (closes: #866644).

 -- Robert Luberda <email address hidden> Sat, 01 Jul 2017 13:30:25 +0200

Changed in apt-listchanges (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers