Ubuntu

FFe: Sync apt-build 0.12.42 (universe) from Debian experimental (main)

Reported by Francisco Machado Magalhães Neto on 2011-12-16
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apt-build (Debian)
Fix Released
Unknown
apt-build (Ubuntu)
Undecided
Unassigned

Bug Description

Original bug report:
apt-build does not install the packages

apt-build does not install the compilled packages, and I have to do it manually, using dpkg. It breaks the packages tree, and then the update system see my compilled packages as outdated.
In portuguese, it shows the following error message:
E: O valor 'apt-build' é inválido para APT::Default-Release como tal lançamento não está disponível na origem

Dominique Lasserre (lasall) wrote :

This bug will be fixed with Apt::Get::AllowUnauthenticated=true . Wishlist report to create signed repository is here: #620300

Changed in apt-build (Debian):
importance: Undecided → Unknown
status: New → Unknown
Changed in apt-build (Ubuntu):
status: New → Confirmed
Changed in apt-build (Debian):
status: Unknown → New
Changed in apt-build (Debian):
status: New → Fix Released
JC Hulce (soaringsky) wrote :

Source: apt-build Source-Version: 0.12.42

We believe that the bug you reported is fixed in the latest version of apt-build, which is due to be installed in the Debian FTP archive:

apt-build_0.12.42.dsc to main/a/apt-build/apt-build_0.12.42.dsc apt-build_0.12.42.tar.gz to main/a/apt-build/apt-build_0.12.42.tar.gz apt-build_0.12.42_mipsel.deb to main/a/apt-build/apt-build_0.12.42_mipsel.deb

A summary of the changes between this version and the previous one is attached.

Thank you for reporting the bug, which will now be closed. If you have further comments please address them to <email address hidden>, and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software pp. Dominique Lasserre <email address hidden> (supplier of updated apt-build package)

(This message was generated automatically at their request; if you believe that there is a problem with it please contact the archive administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----Hash: SHA256

Format: 1.8 Date: Fri, 24 Feb 2012 02:02:46 +0100 Source: apt-build Binary: apt-build Architecture: source mipsel Version: 0.12.42 Distribution: experimental Urgency: low Maintainer: Debian QA Group <email address hidden> Changed-By: Dominique Lasserre <email address hidden> Description: apt-build - frontend to apt to build, optimize and install packages Closes: 179850 291565 292169 314155 315102 316572 369173 391449 392844 425044 434859 507881 511853 592006 596296 624365 660590 Changes: apt-build (0.12.42) experimental; urgency=low . * QA upload. * Bump source format to 3.0 (native). * Added archive suite. Clear solution for #639859. * Allow non authenticated installation from apt-build repository. Closes: #316572, #369173 * Added new cpu-type profiles to debconf templates. * Changed default make option in template (-j`cpu_cores`). Set question priority to "high". * debian/dirs: Removed due to its redundancy. * Prevent empty directory for build_dir and repository_dir (use loop). Closes: #511853 * Move debconf-only related content from postinst to config file and pimp debconf stuff (configuration file handling). * --yes (assume-yes) functionality is now recognized by aptitude. Also renamed help information from apt-get and apt-cache to aptget and aptcache. (thanks to Bryant Wong) Closes: #392844 * Improved source version and name handling. Closes: #314155, #315102, #425044, #434859 * Pull correct build dependencies. Closes: #624365 * Compilation with cmake is supported (no code changes). Closes: #507881 * Build with local version number (suffix +aptbuild). Closes: #391449, #592006 * Support sources stored at /Dir::Etc::sourceparts. Closes: #596296 * Rebuild Packages.gz after repository cleaning. * Patch from Kumar Appaiah: Allow package builds without binary packages registered in sources. Closes: #179850, #291565, #292169 * Unregister conffiles located in /etc/apt/sources.list.d/. Changes are completely managed by debconf and maintainer scripts. Closes: #660590 * Bump debhelper compatibility mode to 9. * Bump Standards version to 3.9.3.

JC Hulce (soaringsky) wrote :

Please sync 0.12.42 from debian

Fabrice Coutadeur (fabricesp) wrote :

Hi,

the changelog for 0.12.42 is huge:
apt-build (0.12.42) experimental; urgency=low

   * QA upload.
   * Bump source format to 3.0 (native).
   * Added archive suite. Clear solution for #639859.
   * Allow non authenticated installation from apt-build repository. Closes:
     #316572, #369173
   * Added new cpu-type profiles to debconf templates.
   * Changed default make option in template (-j`cpu_cores`). Set question
     priority to "high".
   * debian/dirs: Removed due to its redundancy.
   * Prevent empty directory for build_dir and repository_dir (use loop).
     Closes: #511853
   * Move debconf-only related content from postinst to config file and pimp
     debconf stuff (configuration file handling).
   * --yes (assume-yes) functionality is now recognized by aptitude. Also
     renamed help information from apt-get and apt-cache to aptget and aptcache.
     (thanks to Bryant Wong) Closes: #392844
   * Improved source version and name handling. Closes: #314155, #315102,
     #425044, #434859
   * Pull correct build dependencies. Closes: #624365
   * Compilation with cmake is supported (no code changes). Closes: #507881
   * Build with local version number (suffix +aptbuild). Closes: #391449,
     #592006
   * Support sources stored at /Dir::Etc::sourceparts. Closes: #596296
   * Rebuild Packages.gz after repository cleaning.
   * Patch from Kumar Appaiah: Allow package builds without binary packages
     registered in sources. Closes: #179850, #291565, #292169
   * Unregister conffiles located in /etc/apt/sources.list.d/. Changes are
     completely managed by debconf and maintainer scripts. Closes: #660590
   * Bump debhelper compatibility mode to 9.
   * Bump Standards version to 3.9.3.

 -- Dominique Lasserre <email address hidden> Fri, 24 Feb 2012 02:02:46 +0100

Subscribing Ubuntu Release to get their opinion on that sync.

summary: - apt-build does not install the packages
+ FFe: Sync apt-build 0.12.42 (universe) from Debian experimental (main)
description: updated
Stefano Rivera (stefanor) wrote :

I'd like it if there was some testing, but it's a leaf package so I'm inclined to accept it.

Fabrice Coutadeur (fabricesp) wrote :

Hi,

I've successfully built and installed apt-build in a precise chroot. I've also been able to run it, compiling, installing and purging an app with it.

So it seems to be safe to sync. Waiting for an official ack from ubuntu-release before syncing.

thanks,
Fabrice

Stefano Rivera (stefanor) wrote :

FFe granted.

Changed in apt-build (Ubuntu):
status: Confirmed → Triaged
Fabrice Coutadeur (fabricesp) wrote :

This bug was fixed in the package apt-build - 0.12.42
Sponsored for JC Hulce (soaringsky)

---------------
apt-build (0.12.42) experimental; urgency=low

  * QA upload.
  * Bump source format to 3.0 (native).
  * Added archive suite. Clear solution for #639859.
  * Allow non authenticated installation from apt-build repository. Closes:
    #316572, #369173
  * Added new cpu-type profiles to debconf templates.
  * Changed default make option in template (-j`cpu_cores`). Set question
    priority to "high".
  * debian/dirs: Removed due to its redundancy.
  * Prevent empty directory for build_dir and repository_dir (use loop).
    Closes: #511853
  * Move debconf-only related content from postinst to config file and pimp
    debconf stuff (configuration file handling).
  * --yes (assume-yes) functionality is now recognized by aptitude. Also
    renamed help information from apt-get and apt-cache to aptget and aptcache.
    (thanks to Bryant Wong) Closes: #392844
  * Improved source version and name handling. Closes: #314155, #315102,
    #425044, #434859
  * Pull correct build dependencies. Closes: #624365
  * Compilation with cmake is supported (no code changes). Closes: #507881
  * Build with local version number (suffix +aptbuild). Closes: #391449,
    #592006
  * Support sources stored at /Dir::Etc::sourceparts. Closes: #596296
  * Rebuild Packages.gz after repository cleaning.
  * Patch from Kumar Appaiah: Allow package builds without binary packages
    registered in sources. Closes: #179850, #291565, #292169
  * Unregister conffiles located in /etc/apt/sources.list.d/. Changes are
    completely managed by debconf and maintainer scripts. Closes: #660590
  * Bump debhelper compatibility mode to 9.
  * Bump Standards version to 3.9.3.

 -- Dominique Lasserre <email address hidden> Fri, 24 Feb 2012 02:02:46 +0100

Changed in apt-build (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.