libdb4.6-dev dependency problem

Bug #371746 reported by Jean-Baptiste Mardelle on 2009-05-04
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apr-util (Ubuntu)

Bug Description

Binary package hint: libaprutil1-dev

Trying to install libsvn-dev is impossible, because it depends on libaprutil1-dev, which itself depends on libdb4.6-dev.

But librdf0-dev depends on libdb4.7-dev.

It means you cannot install librdf0-dev and libsvn-dev on the same system, but both packages are usefull to build KDE for example...

Using Ubuntu 9.04 (i386)
libsvn-dev version 1.5.4dfsg1-ubuntu2
libaprutil1-dev version 1.2.12+dfsg-8
librdf0-dev version 1.0.8-1

Adam Jiang (jiang-adam) wrote :

I can confirm this on my site.

Using Ubunt 9.04 (i386)
~/workspace/packaging/subversion/subversion-1.5.6$ LC_ALL=C sudo apt-get install librdf0-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  librdf0-dev: Depends: libdb-dev
E: Broken packages

Johan Ekblad (jka-omicron) wrote :

same here, is this resolved in 9.10 ?

Ilya Barygin (randomaction) wrote :

Yes, this is fixed in 9.10.

Changed in apr-util (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers