update fails, "AppStream cache update failed."

Bug #1601971 reported by katsiki on 2016-07-11
80
This bug affects 15 people
Affects Status Importance Assigned to Milestone
appstream (Ubuntu)
High
Unassigned

Bug Description

Booted 16.04 amd64 from DVD, opened a gnome-terminal and ran,

ubuntu@ubuntu:~$ sudo apt-get update
Ign:1 cdrom://Ubuntu 16.04 LTS _Xenial Xerus_ - Release amd64 (20160420.1) xenial InRelease
Hit:2 cdrom://Ubuntu 16.04 LTS _Xenial Xerus_ - Release amd64 (20160420.1) xenial Release
Get:4 http://archive.ubuntu.com/ubuntu xenial InRelease [247 kB]
Get:5 http://security.ubuntu.com/ubuntu xenial-security InRelease [94.5 kB]
Get:6 http://archive.ubuntu.com/ubuntu xenial-updates InRelease [94.5 kB]
Get:7 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages [119 kB]
Get:8 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages [1,201 kB]
Get:9 http://archive.ubuntu.com/ubuntu xenial/main Translation-en [568 kB]
Get:10 http://security.ubuntu.com/ubuntu xenial-security/main Translation-en [45.3 kB]
Get:11 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [44.0 kB]
Get:12 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [50.8 kB]
Get:13 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 DEP-11 Metadata [158 B]
Get:14 http://archive.ubuntu.com/ubuntu xenial/main amd64 DEP-11 Metadata [733 kB]
Get:15 http://archive.ubuntu.com/ubuntu xenial/main DEP-11 64x64 Icons [409 kB]
Get:16 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [252 kB]
Get:17 http://archive.ubuntu.com/ubuntu xenial-updates/main Translation-en [99.8 kB]
Get:18 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [186 kB]
Get:19 http://archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [150 kB]
Get:20 http://archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 DEP-11 Metadata [157 B]
Fetched 4,293 kB in 1s (2,360 kB/s)

** (appstreamcli:2593): CRITICAL **: Error while moving old database out of the way.
AppStream cache update failed.
Reading package lists... Done

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: appstream 0.9.4-1
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CasperVersion: 1.376
CurrentDesktop: Unity
Date: Mon Jul 11 19:24:40 2016
LiveMediaBuild: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: appstream
UpgradeStatus: No upgrade log present (probably fresh install)

katsiki (fong-caltech) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in appstream (Ubuntu):
status: New → Confirmed
katsiki (fong-caltech) wrote :

Ubuntu Desktop Live DVD 14.04.1 gives the same error. Simply booted into Live mode, opened a gnome-terminal, and tried to update,

ubuntu@ubuntu:~$ sudo apt-get update
Ign:1 cdrom://Ubuntu 16.04.1 LTS _Xenial Xerus_ - Release amd64 (20160719) xenial InRelease
Hit:2 cdrom://Ubuntu 16.04.1 LTS _Xenial Xerus_ - Release amd64 (20160719) xenial Release
Hit:4 http://security.ubuntu.com/ubuntu xenial-security InRelease
Hit:5 http://archive.ubuntu.com/ubuntu xenial InRelease
Hit:6 http://archive.ubuntu.com/ubuntu xenial-updates InRelease

** (appstreamcli:5561): CRITICAL **: Error while moving old database out of the way.
AppStream cache update failed.
Reading package lists... Done

I didn't make any other changes to the configuration, or install any other software.

Matthias Klumpp (ximion) wrote :

Is /var/cache/ writable for root? (and /var/cache/app-info/xapian for that matter)

katsiki (fong-caltech) wrote :

ubuntu@ubuntu:~$ ll -d /var/cache
drwxr-xr-x 1 root root 120 Jul 19 20:54 /var/cache/
ubuntu@ubuntu:~$ ll -d /var/cache/app-info/xapian
drwxr-xr-x 1 root root 80 Jul 26 18:54 /var/cache/app-info/xapian/

kikito (cma54) wrote :

hello.

livedvd today :

same as katsiki.

kikito (cma54) wrote :

maybe a link with #1565965 ?

Changed in appstream (Ubuntu):
importance: Undecided → High
kikito (cma54) wrote :

installation today : still exists. . .

Khionu Terabite (abstractkitty) wrote :

I've re setup a Live Boot USB twice, and I always encounter the issue, without fail. I find the actual ?error code? that comes after `appstreamcli` differs widely, though

Still present in ubuntu-16.04.1-desktop-amd64.iso

An strace shows the following:

rename("/var/cache/app-info/xapian/default", "/var/cache/app-info/xapian/default_old") = -1 EXDEV (Invalid cross-device link)

Doing "sudo mv /var/cache/app-info/xapian/default /var/cache/app-info/xapian/default_old" followed by "sudo mv /var/cache/app-info/xapian/default_old /var/cache/app-info/xapian/default" makes it work thereafter.

Matthias Klumpp (ximion) wrote :

Sounds like some OverlayFS weirdness...

sumit (sumitchawda) wrote :

I too have same issue I installed Ubuntu 16.04 along with Windows 7. I was using Live on installation using ROM. I got an error during installation that it failed to install GRUB with warning that I can not use this installation as first boot over hdd.
I tried running boot-repair and it failed with attached error.
Looking for help.

katsiki (fong-caltech) wrote :

I also get an error with installation to SSD:

sudo apt-get update
Hit:1 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Get:2 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Get:3 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Hit:4 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease
Fetched 204 kB in 10s (18.6 kB/s)
AppStream cache update completed, but some metadata was ignored due to errors.
Reading package lists... Done

katsiki (fong-caltech) wrote :

I forgot to add that installation was with ubuntu-16.04.1-desktop-amd64.iso.

Aadithya S (aadityarulez) wrote :

Bug also confirmed in 16.04.2 live boot. So far,this seems to work :
https://bugs.launchpad.net/ubuntu/+source/appstream/+bug/1601971/comments/11

Vladimir Mokrozub (mogaba2009) wrote :

Can confirm this error with LTSP-client running 16.04.3:

root@vma-test:~# apt-get update
Сущ:1 http://ru.archive.ubuntu.com/ubuntu xenial InRelease
Сущ:2 http://ru.archive.ubuntu.com/ubuntu xenial-updates InRelease
Сущ:3 http://security.ubuntu.com/ubuntu xenial-security InRelease

** (appstreamcli:1622): CRITICAL **: Error while moving old database out of the way.
AppStream cache update failed.

This fixes it:
https://bugs.launchpad.net/ubuntu/+source/appstream/+bug/1601971/comments/11

I was having this same problem. daniel-gimpelevich (#11) FTW

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers