Activity log for bug #1579712

Date Who What changed Old value New value Message
2016-05-09 11:12:16 Matthias Klumpp bug added bug
2016-05-09 11:39:58 Matthias Klumpp description The cache refresh is blocked on a strdup on a non-NULL-terminated string in some very rare occasions (very rare because this bug is present for almost 3y without a single report). It regardless of that is very annoying if it happens, and also unpredictable, so it should be fixed. See the linked upstream bug report for details. [Impact] * The cache refresh is blocked on a strdup on a non-NULL-terminated string in some very rare occasions (very rare because this bug is present for almost 3y without a single report). * Fixing this bug resolves the issue for people who might experience it. * See https://github.com/ximion/appstream/issues/35 for details. [Test Case 1] * Run `sudo appstreamcli refresh --force` * The AppStream cache should be updated, no change in behavior should be seen. [Test Case 2] * In case you were experiencing the almost-infinite hang when running `sudo appstreamcli refresh --force`, this issue should be fixed with the SRU. [Regression Potential] * Very low, since this only fixes the decompression code. There should be no sideeffects of that (given that the patch itself doesn't break anything, which it shouldn't, since it has been tested upstream for a while) [Other Info] * This fix has been applied upstream: https://github.com/ximion/appstream/commit/f33c520c37e2ba51d92402220250b8d501a2bf43 * A smaller version of the patch (one-liner) is available, at the expense of not having reduced memory usage: https://github.com/ximion/appstream/commit/378941787d3584b3eb31a6ebe40e0aacc10e180a
2016-05-09 11:40:38 Matthias Klumpp nominated for series Ubuntu Xenial
2016-05-09 12:02:03 Matthias Klumpp attachment added Fix for LP#1574896 and LP#1579712 https://bugs.launchpad.net/ubuntu/+source/appstream/+bug/1579712/+attachment/4659196/+files/appstream-SRU_LP1574896_LP1579712.debdiff
2016-05-09 12:28:57 Ubuntu Foundations Team Bug Bot tags patch
2016-05-09 12:29:04 Ubuntu Foundations Team Bug Bot bug added subscriber Ubuntu Sponsors Team
2016-05-10 13:42:18 Iain Lane bug task added appstream (Ubuntu Xenial)
2016-05-12 10:57:24 Martin Pitt appstream (Ubuntu Xenial): status New Fix Committed
2016-05-12 10:57:25 Martin Pitt bug added subscriber Ubuntu Stable Release Updates Team
2016-05-12 10:57:29 Martin Pitt bug added subscriber SRU Verification
2016-05-12 10:57:35 Martin Pitt tags patch patch verification-needed
2016-05-12 18:51:02 Mathew Hodson appstream (Ubuntu Xenial): importance Undecided Medium
2016-05-12 18:51:06 Mathew Hodson appstream (Ubuntu Xenial): milestone xenial-updates
2016-05-12 18:51:10 Mathew Hodson appstream (Ubuntu): milestone xenial-updates
2016-05-13 14:20:38 Matthias Klumpp appstream (Ubuntu): status Fix Committed Fix Released
2016-05-17 19:33:35 Neil Mayhew bug added subscriber Neil Mayhew
2016-05-19 18:39:21 Neil Mayhew tags patch verification-needed patch verification-done
2016-05-19 23:09:23 Joe Barnett bug added subscriber Joe Barnett
2016-05-20 00:08:25 Peter Bennett bug added subscriber Peter Bennett
2016-05-20 00:27:43 Grant bug added subscriber Grant
2016-05-20 01:29:06 Matthias Klumpp appstream (Ubuntu): assignee Matthias Klumpp (ximion)
2016-05-20 02:31:47 Matthias Klumpp appstream (Ubuntu Xenial): importance Medium High
2016-05-20 02:51:31 Marco Biscaro bug added subscriber Marco Biscaro
2016-05-20 03:45:04 Matthias Klumpp summary Refresh hangs due to strdup on non-NULL terminated string Refresh hangs indefinitely, appstreamcli using 100% CPU
2016-05-20 03:49:16 Matthias Klumpp description [Impact] * The cache refresh is blocked on a strdup on a non-NULL-terminated string in some very rare occasions (very rare because this bug is present for almost 3y without a single report). * Fixing this bug resolves the issue for people who might experience it. * See https://github.com/ximion/appstream/issues/35 for details. [Test Case 1] * Run `sudo appstreamcli refresh --force` * The AppStream cache should be updated, no change in behavior should be seen. [Test Case 2] * In case you were experiencing the almost-infinite hang when running `sudo appstreamcli refresh --force`, this issue should be fixed with the SRU. [Regression Potential] * Very low, since this only fixes the decompression code. There should be no sideeffects of that (given that the patch itself doesn't break anything, which it shouldn't, since it has been tested upstream for a while) [Other Info] * This fix has been applied upstream: https://github.com/ximion/appstream/commit/f33c520c37e2ba51d92402220250b8d501a2bf43 * A smaller version of the patch (one-liner) is available, at the expense of not having reduced memory usage: https://github.com/ximion/appstream/commit/378941787d3584b3eb31a6ebe40e0aacc10e180a [Impact]  * The cache refresh is blocked on a strdup on a non-NULL-terminated string in some very rare occasions (very rare because this bug is present for almost 3y without a single report).  * Fixing this bug resolves the issue for people who might experience it.  * See https://github.com/ximion/appstream/issues/35 for details. [Test Case 1]  * Run `sudo appstreamcli refresh --force`  * The AppStream cache should be updated, no change in behavior should be seen. [Test Case 2]  * In case you were experiencing the almost-infinite hang when running `sudo appstreamcli refresh --force`, this issue should be fixed with the SRU. [Regression Potential]  * Very low, since this only fixes the decompression code. There should be no sideeffects of that (given that the patch itself doesn't break anything, which it shouldn't, since it has been tested upstream for a while) [Other Info]  * This fix has been applied upstream: https://github.com/ximion/appstream/commit/f33c520c37e2ba51d92402220250b8d501a2bf43  * A smaller version of the patch (one-liner) is available, at the expense of not having reduced memory usage: https://github.com/ximion/appstream/commit/378941787d3584b3eb31a6ebe40e0aacc10e180a #### /!\ Installing the bugfix from xenial-proposed, without going through APT: To install the fixed packages manually, please execute the following commands (for amd64, adjust URLs for other architectures): ``` cd /tmp && mkdir asfix cd asfix wget https://launchpad.net/ubuntu/+archive/primary/+files/appstream_0.9.4-1ubuntu1_amd64.deb wget https://launchpad.net/ubuntu/+archive/primary/+files/libappstream3_0.9.4-1ubuntu1_amd64.deb sudo dpkg -i libappstream3*.deb sudo dpkg -i appstream*.deb ```
2016-05-20 04:58:31 Vincent Cheng bug added subscriber Vincent Cheng
2016-05-20 05:00:35 Olli Niemi bug added subscriber Olli Niemi
2016-05-20 05:01:30 Reyes Yang bug added subscriber Reyes Yang
2016-05-20 05:04:11 Jason Gerard DeRose bug added subscriber Jason Gerard DeRose
2016-05-20 05:06:07 Edwin Khoo bug added subscriber Edwin Khoo
2016-05-20 05:08:52 Kevin Ochs bug added subscriber Kevin Ochs
2016-05-20 05:10:17 Ondra bug added subscriber Ondra
2016-05-20 05:48:56 Kenichi Ito bug added subscriber Kenichi Ito
2016-05-20 06:43:04 Joolz bug added subscriber Joolz
2016-05-20 06:55:38 Colin Law bug added subscriber Colin Law
2016-05-20 07:01:19 Markus Lindberg bug added subscriber Markus Lindberg
2016-05-20 07:29:52 SimonJ bug added subscriber SimonJ
2016-05-20 07:31:22 S Wenham bug added subscriber S Wenham
2016-05-20 07:36:01 Jakob van Kruijssen bug added subscriber cardamon
2016-05-20 07:37:38 Aki Vehtari bug added subscriber Aki Vehtari
2016-05-20 07:40:26 Romano Giannetti bug added subscriber Romano Giannetti
2016-05-20 08:05:12 Dariusz Gadomski bug added subscriber Dariusz Gadomski
2016-05-20 08:05:13 Luis Arias bug added subscriber Luis Arias
2016-05-20 08:18:22 Marcello Nuccio bug added subscriber Marcello Nuccio
2016-05-20 08:18:44 JB5 bug added subscriber JB5
2016-05-20 08:22:29 Gianfranco Costamagna bug added subscriber LocutusOfBorg
2016-05-20 08:35:54 Launchpad Janitor appstream (Ubuntu Xenial): status Fix Committed Fix Released
2016-05-20 08:36:18 Martin Pitt removed subscriber Ubuntu Stable Release Updates Team
2016-05-20 08:45:31 Juan Manuel bug added subscriber Juan Manuel
2016-05-20 08:46:31 pablomme bug added subscriber pablomme
2016-05-20 08:52:48 Aleksandrs bug added subscriber Aleksandrs
2016-05-20 09:33:16 freexe bug added subscriber freexe
2016-05-20 10:12:39 Michael Träger bug added subscriber Michael Träger
2016-05-20 10:19:24 Frédéric Grosshans bug added subscriber Frédéric Grosshans
2016-05-20 10:45:38 Mantas Kriaučiūnas bug added subscriber Mantas Kriaučiūnas
2016-05-20 10:45:49 Mantas Kriaučiūnas bug added subscriber Baltix GNU/Linux system developers
2016-05-20 10:45:57 Mantas Kriaučiūnas bug added subscriber Baltix GNU/Linux activists
2016-05-20 10:47:48 Shih-Yuan Lee bug added subscriber Shih-Yuan Lee
2016-05-20 11:02:54 Stephan Springer bug added subscriber Stephan Springer
2016-05-20 12:01:48 Michael Kiermaier bug added subscriber Michael Kiermaier
2016-05-20 12:46:18 Ondra removed subscriber Ondra
2016-05-20 13:32:39 John bug added subscriber John
2016-05-20 14:17:07 Vjpiton bug added subscriber Vjpiton
2016-05-20 14:17:12 Vjpiton removed subscriber Vjpiton
2016-05-20 14:34:47 svasiljev bug added subscriber svasiljev
2016-05-20 15:36:40 René Walendy bug added subscriber Ren�alendy
2016-05-20 16:51:14 mindaugasd bug added subscriber mindaugasd
2016-05-20 17:21:48 Adam Dingle bug added subscriber Adam Dingle
2016-05-20 21:52:51 Grant removed subscriber Grant
2016-05-21 04:02:25 nyan2014 bug added subscriber nyan2014
2016-05-21 06:41:41 Ljiljan Veselinovic information type Public Public Security
2016-05-21 06:41:51 Ljiljan Veselinovic information type Public Security Public
2016-05-21 11:58:12 DerKlops bug added subscriber DerKlops
2016-05-21 14:29:07 Peter Bennett removed subscriber Peter Bennett
2016-05-23 09:15:17 Fredrik Staxäng bug added subscriber Fredrik Staxäng
2016-05-23 09:39:08 mindaugasd removed subscriber mindaugasd
2016-05-23 13:01:11 John removed subscriber John
2016-05-23 16:12:24 Joe Barnett removed subscriber Joe Barnett
2016-07-14 13:40:52 Aaron Peromsik bug added subscriber Aaron Peromsik
2016-12-18 22:16:47 nyan2014 removed subscriber nyan2014