[upstream] K3B does not show AudioVideo category @ GNOME

Bug #1558346 reported by Robert Ancell on 2016-03-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Software
Fix Released
Medium
appstream-glib (Ubuntu)
Low
Unassigned
k3b (Ubuntu)
Undecided
Unassigned

Bug Description

k3b does not show in Audio and Video categories in GNOME Software. This is because it is in the "AudioVideo" category which is not shown in GNOME Software. By comparison, Brasero is in the "AudioVideo;Audio;Video" categories and does show.

Robert Ancell (robert-ancell) wrote :

The fastest fix is to update src/k3b.desktop and change:

Categories=KDE;Qt;AudioVideo;DiscBurning;System;Filesystem;

to:

Categories=KDE;Qt;AudioVideo;Audio;Video;DiscBurning;System;Filesystem;

I have filed a bug upstream to see what they think.

Changed in gnome-software:
importance: Unknown → Medium
status: Unknown → Confirmed
Matthias Klumpp (ximion) wrote :

Since "AudioVideo" is a standardized main category, I think this is a bug in GNOME Software not properly recognizing it...
See https://standards.freedesktop.org/menu-spec/latest/apa.html
Technically, there is nothing wrong with the k3b .desktop file.

summary: - k3b does not show in Audio and Video categories
+ k3b does not show in Audio and Video categories @ GNOME

Yeah, it's technically correct. However, it seems useful to be able to find K3b when looking under Audio or Video.

summary: - k3b does not show in Audio and Video categories @ GNOME
+ Does not show AudioVideo category

I looked at filing a K3b bug but upstream seems dead.

Changed in gnome-software (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Matthias Klumpp (ximion) wrote :

Yeah, but I think this is a bug: "it is in the "AudioVideo" category which is not shown in GNOME Software" -> GNOME software should just treat the "AudioVideo" category as "Audio" and "Video", since it's an XDG main category (and likely to be found in many other files, not just k3b).

hi!

got a mostly neutral example:

[Desktop Entry]
Type=Application
Name=MKVToolNix GUI
Name[sr]=Мкв-алатница
GenericName=Matroska files creator and tools
GenericName[ca]=Eines i creador de fitxers Matroska
GenericName[de]=Matroska-Dateien erstellen und mit ihnen arbeiten
GenericName[es]=Creador de ficheros Matroska
GenericName[fr]=Créateur de fichiers Matroska
GenericName[sr]=Програм за стварање и обрађивање Матрошка датотека.
GenericName[zh_CN]=Matroska 文件创建器
GenericName[zh_TW]=Matroska 檔製作軟體
Icon=mkvtoolnix-gui
Exec=mkvtoolnix-gui %F
Terminal=false
MimeType=application/x-mkvtoolnix-gui-settings;video/x-matroska;audio/x-matroska;
Categories=AudioVideo;AudioVideoEditing;
InitialPreference=-5

summary: - Does not show AudioVideo category
+ K3B does not show AudioVideo category @ GNOME

This bug was fixed in the package k3b - 2.0.3-0ubuntu5

---------------
k3b (2.0.3-0ubuntu5) xenial; urgency=medium

  * debian/patches/cmake-duplicate-doc.diff:
    - Fix FTBFS

 -- Robert Ancell <email address hidden> Fri, 18 Mar 2016 12:35:36 +1300

Changed in k3b (Ubuntu):
status: New → Fix Released

The landing Menu Categorie in Kubuntu is called Multimedia, where --stuff-- Apps from Audio, Video and AudioVideo (neither fish nor flesh - but covering both) appear. Just Multimedia.

Another one (third party):

[Desktop Entry]
Version=1.0
Icon=qarte
Name=Qarte
Comment=Download the archives of arte.
Comment[fr]=Téléchargez les archives de arte+7
Exec=qarte
Terminal=false
Type=Application
Categories=AudioVideo;
StartupNotify=false
Name[fr_BE]=Qarte
Name[de_DE]=Qarte

Please dont possibly change headlines - I run through lists regularely in order to help KDE-packagers in Kubuntu to keep their back off while preparing beta-2. Headlines should be most meaningful. Thanks.

summary: - K3B does not show AudioVideo category @ GNOME
+ [upstream] K3B does not show AudioVideo category @ GNOME

@ robert-ancell:

re comment#4: Can asure you taht the project is still alive

https://bugs.kde.org/component-report.cgi?product=k3b

Couldn't find anything related.

Changed in debian:
status: Unknown → Confirmed
Changed in gnome-software:
status: Confirmed → In Progress
no longer affects: debian

Ubuntu 16.04 with Software 3.20.1~git20160331.78d1aab-0ubuntu2
Now I can see K3b in Audio and Video categories. So I think you can mark this bug as "Fix released" for "gnome-software (Ubuntu)"

Matthias Klumpp (ximion) wrote :

This is resolved in appstream-glib (and therefore in GNOME Software) now.
Thanks for reporting the issue!

affects: gnome-software (Ubuntu) → appstream-glib (Ubuntu)
Changed in appstream-glib (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-software:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.