"Problem already known" alert and Launchpad page still open post-release

Bug #989779 reported by Matthew Paul Thomas on 2012-04-27
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Undecided
Robert LeDoux
Precise
Undecided
Unassigned

Bug Description

apport 2.0.1-0ubuntu6, Ubuntu 12.04

[Problem]
Any crash because of a known bug results in a Launchpad page opening in a Web browser.

[Impact]
Auto-opening Launchpad Web pages for millions of users of 12.04 LTS who don't even know what Launchpad is.

[Test Case]

1. Encounter a crash that Apport already knows about (either a bug pattern or an apport-duplicates record). For example, bug 968534:
    a. Set your locale to en-GB.
    b. Open Input Method Switcher.
    c. Choose "Do not use Input Method", and click OK.
    d. In the resulting "Information" alert, click OK.

2. In the error alert, check "Send an error report to help fix this problem", and choose "Continue". (If the error alert does not appear, it's either because this example crash has been fixed, or because of bug 989800.)

What happens:
* A "Problem already known" alert appears, saying "This problem was already reported in the bug report displayed in the web browser. Please check if you can add any further information that might be helpful for the developers."
* A Launchpad bug report page opens in a Web browser.

What should happen: No alert, and no Launchpad Web page.

<https://wiki.ubuntu.com/ErrorTracker#details>: "If you choose to send an error report, the alert should disappear immediately. Data should be collected (if it hasn’t been already), and reports should be sent in the background, with *no* progress or success/failure feedback."

description: updated
description: updated
description: updated

Hello Matthew, or anyone else affected,

Accepted apport into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Changed in apport (Ubuntu Precise):
status: New → Fix Committed
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Precise:
I have reproduced the problem with apport 2.0.1-0ubuntu6 in precise-updates and have verified that the version of apport 2.0.1-0ubuntu7 in -proposed fixes the issue.

I did the following tests:
1. Verification with a bug already reported:
ran: the following command in a terminal
  $ zenity --list --column="bug" --checklist option
and clicked on 'Ok' . zenity segfaults

2. Verification with a new bug that the report is processed and uploaded
Inserted of a syntax error in /usr/bin/update-manager then run update-manager

With 2.0.1-0ubuntu6 and alert dialog and launchpad opens, with 2.0.1-0ubuntu7 no alert dialog and launchpad doesn't open. New reports (the u-m case) are uploaded to the crashdb ( .upload file in /var/crash)

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.0.1-0ubuntu7

---------------
apport (2.0.1-0ubuntu7) precise-proposed; urgency=low

  * Fix (LP: #989779). Don't show the duplicate warning when we're just
    reporting to daisy.ubuntu.com.
 -- Evan Dandrea <email address hidden> Fri, 27 Apr 2012 16:53:11 +0100

Changed in apport (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
Bob Bib (bobbib) wrote :

Does it have something to do with bug #984856 ?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.0.1-0ubuntu7

---------------
apport (2.0.1-0ubuntu7) precise-proposed; urgency=low

  * Fix (LP: #989779). Don't show the duplicate warning when we're just
    reporting to daisy.ubuntu.com.
 -- Evan Dandrea <email address hidden> Fri, 27 Apr 2012 16:53:11 +0100

Changed in apport (Ubuntu):
status: Confirmed → Fix Released
Robert LeDoux (rbrtldx) on 2012-05-05
Changed in apport (Ubuntu):
assignee: nobody → Robert LeDoux (rbrtldx)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers