Data collection progress window is still appearing post-release

Bug #989698 reported by Matthew Paul Thomas
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Fix Released
High
Martin Pitt
Precise
Fix Released
High
Martin Pitt

Bug Description

apport 2.0.1-0ubuntu6, Ubuntu 12.04

1. Encounter a crash.
2. When the error alert appears, check "Send an error report to help fix this problem", and choose "Continue".

What happens: A progress window appears.

What should happen: No progress window. <https://wiki.ubuntu.com/ErrorTracker#details>: "If you choose to send an error report, the alert should disappear immediately. Data should be collected (if it hasn’t been already), and reports should be sent in the background, with *no* progress or success/failure feedback."

It is okay for the data collection process to be interactive pre-release, but it is not okay for it to be interactive post-release. And with no interaction involved, it is not useful to show progress for something that you gain no benefit from waiting for.

(This does not apply to manual reporting, e.g. using the ubuntu-bug command.)

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
summary: - Data collection progress window is still appearing post-release
+ Data collection progress / "Problem already known" still appearing post-
+ release
summary: - Data collection progress / "Problem already known" still appearing post-
- release
+ Data collection progress window is still appearing post-release
Revision history for this message
Bob Bib (bobbib) wrote :

Isn't it a kind of duplicate of bug #989779 ?

Revision history for this message
Bob Bib (bobbib) wrote :

And no, it's not a real duplicate of bug #989779, as it's not fixed by fix of that bug.

tags: added: precise
Martin Pitt (pitti)
Changed in apport (Ubuntu):
importance: Undecided → High
Changed in apport (Ubuntu Precise):
importance: Undecided → High
Changed in apport (Ubuntu):
status: Confirmed → Triaged
Changed in apport (Ubuntu Precise):
status: New → Triaged
Changed in apport (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Revision history for this message
Martin Pitt (pitti) wrote :

Note that some packages provide interactive hooks, which will still be presented after clicking "submit"; that's a corner case, though, and that does not depend on the progress bar being visible.

Revision history for this message
Martin Pitt (pitti) wrote :

GTK interface fixed in trunk r2323.

Changed in apport (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote :

KDE interface fixed in trunk 2324.

Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package apport - 2.1-0ubuntu1

---------------
apport (2.1-0ubuntu1) quantal; urgency=low

  * New upstream release:
    - packaging.py, install_packages(): Add permanent_rootdir flag and if set,
      only unpack newly downloaded packages. Implement it for the apt/dpkg
      backend. Thanks Evan Dandrea.
    - apport-retrace: Add --sandbox-dir option for keeping a permanent sandbox
      (unpacked packages). This provides a considerable speedup. Thanks Evan
      Dandrea.
    - crash-digger: Add --sandbox-dir option and pass it to apport-retrace.
    - Fix the whole code to be PEP-8 compatible, and enforce this in test/run
      by running the "pep8" tool.
    - GTK UI tests: Ensure that there are no GLib/GTK warnings or criticals.
    - Support Python 3. Everything except the launchpad crashdb backend now
      works with both Python 2 and 3. An important change is that the load(),
      write(), and write_mime() methods of a ProblemReport and apport.Report
      object now require the file stream to be opened in binary mode.
    - data/apport: Ignore a crash if the executable was modified after the
      process started. This often happens if the package is upgraded and a
      long-running process is not stopped before. (LP: #984944)
    - Add test cases for apport-unpack.
    - apport-retrace: Add information about outdated packages to the
      "RetraceOutdatedPackages" field.
    - ui.py: Drop python-xdg dependency, use ConfigParser to read the .desktop
      files.
    - apport-gtk: Work around GTK crash when trying to set pixmap on an
      already destroyed parent window. (LP: #938090)
    - data/dump_acpi_tables.py: Fix crash on undefined variable with
      non-standard tables. (LP: #982267)
    - backends/packaging-apt-dpkg.py: Fix crash if a package is installed, but
      has no candidates in apt. (LP: #980094)
    - data/general-hooks/generic.py: Bump minimum free space requirement from
      10 to 50 MB. 10 is not nearly enough particularly for /tmp. (LP: #979928)
    - hookutils.py, recent_logfile(): Use a default limit of 10000 lines and
      call "tail" instead of reading the whole file. This protects against
      using up all memory when there are massive repeated log messages.
      (LP: #984256)
    - apport-gtk: Do not assume that an icon requested for size 42 actually
      delivers size 42; some themes do not have this available and deliver a
      smaller one instead, causing overflows. Also, copy the image as
      gtk_icon_theme_load_icon() returns a readonly result which we must not
      modify. (LP: #937249)
    - ui.py: Don't show the duplicate warning when the crash database does not
      accept the problem type, and they are just being sent to whoopsie.
      Thanks Evan Dandrea. (LP: #989779)
    - report.py: Correctly escape the file path passed to gdb.
    - apport-gtk, apport-kde: Do not show the information collection progress
      dialog if the crash database does not accept this kind of report. In that
      case whoopsie will upload it in the background and the dialog is not
      necessary. (LP: #989698)
  * data/general-hooks/ubuntu.py, data/general-hooks/automatix.py...

Read more...

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote :

Precise fix uploaded to -proposed, needs ubuntu-sru review now.

Changed in apport (Ubuntu Precise):
assignee: nobody → Martin Pitt (pitti)
status: Triaged → Fix Committed
Revision history for this message
Chris Halse Rogers (raof) wrote : Please test proposed package

Hello Matthew, or anyone else affected,

Accepted apport into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Revision history for this message
Colan Schwartz (colan) wrote :

If apport now does everything in the background, how do you know which bug you're reporting? If you want so subscribe, mark it as affecting you or add comments manually, there's no way to do this because a browser window doesn't come up. Also, you can avoid reporting if you know it's a duplicate.

Is all of this functionality gone, or is there some way to bring the pre-Precise behaviour back (for power users at least)?

At the very least, users should be able to subscribe to bugs that are affecting them so that they may monitor the situation.

Revision history for this message
Martin Pitt (pitti) wrote :

It's not reporting a Launchpad bug any more, but to http://errors.ubuntu.com. There are no bugs to subscribe to any more. Please see https://blueprints.launchpad.net/ubuntu/+spec/foundations-p-crash-database . In previous stable releases, apport did not pop up at all, so this is not at all a functional regression wrt. bug reporting (it certainly can be discussed whether it's an annoying workflow interruption, or confusing, or whatever).

The functionality is not gone, reporting to Launchpad has just been disabled after-release in /etc/apport/crashdb.conf.

Revision history for this message
Martin Pitt (pitti) wrote :

Can someone please test the proposed package and confirm that the progress dialog does not appear any more after clicking "Report"?

Revision history for this message
C de-Avillez (hggdh2) wrote :

I am guessing "2. click continue" means any of the options to report ("Leave closed" and "relaunch"), since there is no "continue" anymore.

No progress dialog is shown for version 2.0.1-0ubuntu8 on precise proposed. Marking verification-done.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.0.1-0ubuntu8

---------------
apport (2.0.1-0ubuntu8) precise-proposed; urgency=low

  * apport-{gtk,kde}: Do not show the information collection progress dialog
    if the crash database does not accept this kind of report. In that case
    whoopsie will upload it in the background and the dialog is not necessary.
    Patch cherry-picked from trunk. (LP: #989698)
 -- Martin Pitt <email address hidden> Fri, 18 May 2012 17:37:46 +0200

Changed in apport (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers