apport-gtk consumes 100% of cpu and never seems to finish processing libreoffice-writer crash

Bug #970837 reported by Craig Magina on 2012-04-01
122
This bug affects 26 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Unassigned

Bug Description

Start libreoffice-writer and click on New, then Labels. It will hang and then crash.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: apport-gtk 2.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic 3.2.13
Uname: Linux 3.2.0-21-generic x86_64
ApportVersion: 2.0-0ubuntu2
Architecture: amd64
Date: Sun Apr 1 10:16:41 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120325)
PackageArchitecture: all
SourcePackage: apport
UpgradeStatus: No upgrade log present (probably fresh install)

Craig Magina (craig.magina) wrote :
Craig Magina (craig.magina) wrote :

Since apport keeps hanging indefinitely trying to collect data for this crash, here is an strace of the crash.

summary: - libreoffice-writer crashes when you try and use New->Labels
+ apport-gtk consumes 100% cpu and doesn't seem to ever finish processing
+ thea libreoffice crash
summary: - apport-gtk consumes 100% cpu and doesn't seem to ever finish processing
- thea libreoffice crash
+ apport-gtk consumes 100% of cpu and never seems to finish processing
+ libreoffice-writer crash
Craig Magina (craig.magina) wrote :

File attached is for the bug apport was trying to process.

Changed in apport (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
importance: Undecided → Medium
Martin Pitt (pitti) wrote :

I can reproduce the LibO crash, get the Apport popup, but that just takes some 30 seconds to process, then it's done. So I cannot reproduce the "never seems to finish" part for apport.

You said you would attach the .crash file you tried to process, but did not actually attach it.

Unassigning canonical-desktop-team, I'm subscribed and will follow up to responses. Thanks!

Changed in apport (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for apport (Ubuntu) because there has been no activity for 60 days.]

Changed in apport (Ubuntu):
status: Incomplete → Expired
zlatko (zlatko23) wrote :

I am experiencing this on Ubuntu 12.10. Apport hangs and I see several processes running:

 8675 root 20 0 357m 118m 48m R 100.1 3.1 4:41.22 apport-gtk
 7953 root 20 0 372m 134m 48m R 98.8 3.5 5:35.32 apport-gtk
 8229 root 20 0 360m 124m 48m R 98.1 3.2 5:12.41 apport-gtk

After 3-10 minutes everything is back to normal.
Actually my system was pretty stale so far, I notice this behavior after kernel upgrade to 3.5.0-26

TomaszChmielewski (mangoo-wpkg) wrote :

Every time I reboot, I have apport-gtk processes starting over and over again, each of them consuming 100% CPU.

After a while, the computer is so slow and there are so many apport-gtk processes, that the only solution is to do "pkill -9 apport-gtk".

Rafał Ochmański (rmopl) wrote :

I have the same problem as TomaszChmielewski. When I agree to report a problem, apport-gtk process starts and then another one starts, and then another... It seems that apport is causing the problems other apports are trying to report.

Because of that most (maybe all? apport doesn't report whether the process was completed) of my problems go unreported which is a shame because lately I have been experiencing GPU lockups that definitely should get some attention.

Changed in apport (Ubuntu):
status: Expired → New
tags: added: quantal
Romulo Ceccon (romuloceccon) wrote :

I'm able to confirm the problem as described by TomaszChmielewski. I'm running Ubuntu 12.10 64bit.

Just after logging in apport will pop up a message informing me about a GPU hang and then I go through all the steps to send the crash report. However, the process consumes 100% cpu and spends quite some time between each step. Also other apport processes are spawned, maybe because apport itself is causing some problems, as reported by Rafał Ochmański.

Attached is an strace of the first apport instance spawned when I tried to reproduce the problem. I had to cancel 3 or 4 other instances (using the "cancel" button of the popup) before the first instance finished by itself, which took about 4 minutes (more than 3 minutes of cpu time as reported by "top").

Changed in apport (Ubuntu):
status: New → Confirmed
Will (war59312) wrote :

Just got bit by this myself.

And it has caused my disk to run out of space. 150GB gone. :(

Will (war59312) wrote :

So it created 391 apport_core files of size 268.4 MB in /tmp.

Running "sudo rm /tmp/apport_core*" fixed it.

Hans Deragon (deragon) wrote :

Tried to reprodruce the problem, but I failed to do so; LibreOffice Writer did not crash. 12.04 here. If someone can find another mean to reproduce the problem, that would be great.

On Ubuntu 14.04. Apport hangs if I delete one wifi network in the list in network editor and quickly before it disappears delete the some network repeately. The network editor hangs till killing the apport process.

snapy (sdfjsfjaei-hans) wrote :

I have this problem with Ubuntu 15.10, where `apport` uses near 100% of the CPU.

Bost (rostislav-svoboda) wrote :

I have this problem with Ubuntu 15.10, where `apport` uses near 100% of the CPU, too.
My /tmp/apport_core_0p34bafe was ~100MB large. After the process terminated itself the file is gone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers