apport-gtk crashed with ValueError in crash_signature_addresses(): invalid literal for int() with base 16: '0x4d7b3hostname3'

Bug #953104 reported by Benjamin on 2012-03-12
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Martin Pitt

Bug Description

comes after clicked "Show Details" in an another apport Window..

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: apport-gtk 1.94.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic i686
ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
Date: Mon Mar 12 16:16:57 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/share/apport/apport-gtk
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20111129.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gtk
PythonArgs: ['/usr/share/apport/apport-gtk']
SourcePackage: apport
Title: apport-gtk crashed with ValueError in crash_signature_addresses(): invalid literal for int() with base 16: '0x4d7b3hostname3'
UpgradeStatus: Upgraded to precise on 2012-03-11 (0 days ago)
UserGroups: adm cdrom dip lpadmin mythtv plugdev sambashare sudo

Benjamin (nailartcenter) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
David Clayton (dcstar) wrote :

Came up on my AMD-64 system as well. I mounted my old 10.04 /home folder and installed Evolution when it occurred.

Benjamin (nailartcenter) on 2012-03-14
description: updated
Edward Donovan (edward.donovan) wrote :

Same trigger as above -- apport popped up after compiz crash, and I clicked 'show details.' Then I got another apport window, reporting the first apport's crash.

Ed Liddle (ed-computerteq) wrote :

The error message showed up for me when I unlocked the screen. I am using a desktop PC with an atom processor and a solid state hard drive with an encrypted home folder.

Martin Pitt (pitti) wrote :

So this would happen if your hostname looks like a hexadecimal number, the anonymization would filter it out.

Changed in apport (Ubuntu):
importance: Undecided → High
assignee: nobody → Martin Pitt (pitti)
status: Confirmed → In Progress
Martin Pitt (pitti) on 2012-03-22
Changed in apport (Ubuntu):
status: In Progress → Fix Committed
status: Fix Committed → Triaged
Martin Pitt (pitti) wrote :

Fixed in trunk r2248.

Changed in apport (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package apport - 1.95-0ubuntu1

---------------
apport (1.95-0ubuntu1) precise; urgency=low

  [ Martin Pitt ]
  * New upstream release:
    - apport-gtk, apport-kde: When reporting a "system crash", don't say "...
      of this program version", but "...of this type", as we don't show a
      program version in the initial dialog
      (https://wiki.ubuntu.com/ErrorTracker#error) (LP: #961065)
    - problem_report.py, write_mime(): Do not put a key inline if it is bigger
      than 1 kB, to guard against very long lines. (LP: #957326)
    - etc/cron.daily/apport: Do not remove whoopsie's *.upload* stamps every
      day, only if they are older than a week. whoopsie comes with its own
      cron job which deals with them. Thanks Steve Langasek. (LP: #957102)
    - report.py, mark_ignore(): Fix crash if executable went away underneath
      us. (LP: #961410)
    - apport-gtk: Do not compare current continue button label against a
      translated string. Instead just remember whether or not we can restart
      the application. (LP: #960439)
    - hookutils.py, command_output(): Add option to keep the locale instead of
      disabling it.
    - hookutils.py, command_output(): Actually make the "input" parameter
      work, instead of causing an eternal hang. Add tests for all possible
      modes of operation.
    - hooktuils.py: Change root_command_output() and
      attach_root_command_outputs() to disable translated messages
      (LC_MESSAGES=C) only as part of the command to be run, not already for
      the root prefix command. This will keep the latter (gksu, kdesudo, etc.)
      translated. (LP: #961659)
    - apport-gtk: Cut off text values after 4000 characters, as Gtk's TreeView
      does not get along well with huge values. KDE's copes fine, so continue
      to display the complete value there. (LP: #957062)
    - apport-gtk: Make details window resizable in bug reporting mode.
    - crashdb.py, known(): Check the address signature duplicate database if
      the symbolic signature exists, but did not find any result. (LP: #103083)
    - ui.py: Run anonymization after checking for duplicates, to prevent host
      or user names which look like hex numbers to corrupt the stack trace.
      (LP: #953104)
    - apport-gtk: Require an application to both have TERM and SHELL in its
      environment to consider it a command line application that was started
      by the user. (LP: #962130)
    - backends/packaging-apt-dpkg.py, _check_files_md5(): Fix double encoding,
      which caused UnicodeDecodeErrors on non-ASCII characters in an md5sum
      file. (LP: #953682)
    - apport-kde, apport-gtk: Only show "Relaunch" if the report has a
      ProcCmdline, otherwise we cannot restart it. (LP: #956173)
    - apport-gtk, apport-kde: Show the ExecutablePath while we're collecting
      data for the crash report. Thanks Evan Dandrea. (LP: #938707).
  * debian/copyright: Change to copyright format 1.0.
  * debian/control: Bump Standards-Version to 3.9.3.

  [ Brian Murray ]
  * data/general-hooks/ubuntu.py: use main.log to determine UpgradeStatus not
    apt.log (LP: #886111)
 -- Martin Pitt <<email address hidden>...

Read more...

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers