OS crash alert unnecessarily includes Ubuntu version number

Bug #948015 reported by Matthew Paul Thomas on 2012-03-06
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Apport
Low
Unassigned
apport (Ubuntu)
Low
Unassigned

Bug Description

apport 1.94-0ubuntu1
apport 1.95-0ubuntu1

1. Invoke an internal error.

What happens: An alert appears with the primary text "Sorry, Ubuntu 12.04 has experienced an internal error.".

What should happen: An alert appears with the primary text "Sorry, Ubuntu has experienced an internal error.". <https://wiki.ubuntu.com/ErrorTracker#os-crash>

The Ubuntu version number isn't relevant to the problem.

Matthew Paul Thomas (mpt) wrote :
Brian Murray (brian-murray) wrote :

When using Ubuntu 12.04 and experiencing crash reports I too have noticed that the version number is included in the operating system crash alert dialog.

Changed in apport (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2012-03-09
Changed in apport (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Low
assignee: nobody → Martin Pitt (pitti)
no longer affects: apport
Martin Pitt (pitti) on 2012-03-09
Changed in apport (Ubuntu):
status: In Progress → Triaged
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

Evan already fixed this in trunk.

Changed in apport (Ubuntu):
status: In Progress → Fix Committed
assignee: Martin Pitt (pitti) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.94.1-0ubuntu2

---------------
apport (1.94.1-0ubuntu2) precise; urgency=low

  * Merge from trunk:
    - ui.py: Ensure that the report file is readable by the crash reporting
      daemon after running through collect_info(). Thanks Evan Dandrea.
    - apport-gtk, apport-kde: Set the window title to the distribution name, as
      per http://wiki.ubuntu.com/ErrorTracker#error . Thanks Evan Dandrea.
      (LP: #948015)
    - test/run: Ignore obsolete packages on the system, to avoid breaking the
      GUI tests due to them.
    - hookutils.py, attach_alsa(): Add the full "pacmd list" output instead of
      just sinks and sources. Thanks David Henningsson.
    - apport-gtk: Fix handling of non-ASCII strings in message dialogs.
      (LP: #865394)
 -- Martin Pitt <email address hidden> Fri, 09 Mar 2012 16:52:53 +0100

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
Matthew Paul Thomas (mpt) wrote :

Still happening in apport 1.95-0ubuntu1. Reopening.

Changed in apport (Ubuntu):
status: Fix Released → New
description: updated
Evan (ev) on 2012-11-01
tags: added: whoopsie-daisy
Evan (ev) on 2012-11-30
Changed in apport:
importance: Undecided → Low
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments