apport-collect crashes when run

Bug #947519 reported by C de-Avillez on 2012-03-05
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Martin Pitt

Bug Description

While trying to help another user to diagnose & collect data on his problem, we found 'apport-collect' to be crashing on 12.04:

[cerdea-aws]cerdea@xango4:/build/buildd/qa-kernel-sru-tests$ apport-collect 947507
Traceback (most recent call last):
  File "/usr/share/apport/apport-gtk", line 468, in <lambda>
    GLib.idle_add(lambda: self.collect_info(on_finished=self.ui_update_view))
  File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 830, in collect_info
    if (self.report['ProblemType'] == 'Crash' and 'Stacktrace' in self.report) or \
  File "/usr/lib/python2.7/UserDict.py", line 23, in __getitem__
    raise KeyError(key)
KeyError: 'ProblemType'

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: apport 1.94-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportLog:

ApportVersion: 1.94-0ubuntu1
Architecture: amd64
CrashReports:
 600:1003:134:59806:2012-03-05 12:18:29.261241000 -0600:2012-03-05 12:18:30.261241000 -0600:/var/crash/_usr_bin_pasaffe.1003.crash
 600:1003:134:5705792:2012-03-04 11:36:27.999040000 -0600:2012-03-04 11:36:28.999040000 -0600:/var/crash/_usr_bin_nautilus.1003.crash
 664:1003:134:0:2012-03-05 12:18:32.885234006 -0600:2012-03-05 12:18:32.885234006 -0600:/var/crash/_usr_bin_pasaffe.1003.upload
Date: Mon Mar 5 15:24:49 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110705.1)
PackageArchitecture: all
SourcePackage: apport
UpgradeStatus: Upgraded to precise on 2012-02-19 (15 days ago)

C de-Avillez (hggdh2) wrote :
Brian Murray (brian-murray) wrote :

This likely happens because ProblemType isn't defined when using apport-collect.

Changed in apport (Ubuntu):
importance: Undecided → High
status: New → Triaged
assignee: nobody → Martin Pitt (pitti)
Colin Watson (cjwatson) wrote :

It wasn't very clean, but I managed to work around this by using apport-cli and making sure not to attempt to view the report.

Martin Pitt (pitti) on 2012-03-06
Changed in apport (Ubuntu):
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

I wrote a test case to reproduce this now.

Martin Pitt (pitti) wrote :

Fixed in trunk r2219.

Changed in apport (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.94-0ubuntu2

---------------
apport (1.94-0ubuntu2) precise; urgency=low

  * Merge from trunk:
     - collect_info(): Do not assume that reports have a "ProblemType" field.
       This is not the case when updating a bug. (LP: #947519)
     - Re-enable inadvertently disabled "bug report for uninstalled package"
       test.
     - Update translations from Launchpad.
 -- Martin Pitt <email address hidden> Tue, 06 Mar 2012 11:37:17 +0100

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers