apport-cli crashed with UnicodeDecodeError in _get_details(): 'ascii' codec can't decode byte 0xe2 in position 0: ordinal not in range(128)

Bug #946207 reported by Simon Watson on 2012-03-04
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Undecided
Martin Pitt

Bug Description

Failed whilst trying to report a bug in unity

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: apport 1.94-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic i686
ApportLog:

ApportVersion: 1.94-0ubuntu1
Architecture: i386
Date: Sun Mar 4 09:30:22 2012
ExecutablePath: /usr/bin/apport-cli
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Release i386 (20101007)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/apport-cli unity
ProcEnviron:
 TERM=xterm
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
PythonArgs: ['/usr/bin/apport-cli', 'unity']
SourcePackage: apport
Title: apport-cli crashed with UnicodeDecodeError in _get_details(): 'ascii' codec can't decode byte 0xe2 in position 0: ordinal not in range(128)
UpgradeStatus: Upgraded to precise on 2011-12-22 (72 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Simon Watson (simon-swat) wrote :
tags: removed: need-duplicate-check
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2012-03-07
Changed in apport (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Martin Pitt (pitti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.94.1-0ubuntu1

---------------
apport (1.94.1-0ubuntu1) precise; urgency=low

  * New upstream bug fix release. Changes since our previous snapshot:
    - apport-cli: Consistently handle unicode vs. byte arrays. (LP: #946207)
    - report.py, anonymize(): Fix crash when the hostname or user name contain
      non-ASCII characters. (LP: #945230)
    - packaging-apt-dpkg.py: Fix UnicodeDecodeError on unexpected md5sum output.
      (LP: #921037)
    - apport-gtk: Fix handling of non-ASCII strings in message dialogs.
      (LP: #620579)
 -- Martin Pitt <email address hidden> Wed, 07 Mar 2012 14:47:31 +0100

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers