apport-gtk crashed with UnicodeDecodeError in anonymize(): 'ascii' codec can't decode byte 0xc3 in position 10: ordinal not in range(128)

Bug #945230 reported by David Callé on 2012-03-02
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Undecided
Martin Pitt

Bug Description

After an internal error window appeared.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: apport-gtk 1.94-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.94-0ubuntu1
Architecture: amd64
CheckboxSubmission: 2bb19fbc7d4d85fa38556ed45b75e4fa
CheckboxSystem: 3e53d3ea5811723345f19eff5070f9ab
CrashCounter: 1
Date: Sat Mar 3 00:14:50 2012
ExecutablePath: /usr/share/apport/apport-gtk
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gtk
PythonArgs: ['/usr/share/apport/apport-gtk']
SourcePackage: apport
Title: apport-gtk crashed with UnicodeDecodeError in anonymize(): 'ascii' codec can't decode byte 0xc3 in position 10: ordinal not in range(128)
UpgradeStatus: Upgraded to precise on 2011-12-08 (85 days ago)
UserGroups: adm admin cdrom dialout fuse libvirtd lpadmin plugdev sambashare

David Callé (davidc3) wrote :
tags: removed: need-duplicate-check
Martin Pitt (pitti) on 2012-03-07
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

Fixed in trunk r2221.

Changed in apport (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.94.1-0ubuntu1

---------------
apport (1.94.1-0ubuntu1) precise; urgency=low

  * New upstream bug fix release. Changes since our previous snapshot:
    - apport-cli: Consistently handle unicode vs. byte arrays. (LP: #946207)
    - report.py, anonymize(): Fix crash when the hostname or user name contain
      non-ASCII characters. (LP: #945230)
    - packaging-apt-dpkg.py: Fix UnicodeDecodeError on unexpected md5sum output.
      (LP: #921037)
    - apport-gtk: Fix handling of non-ASCII strings in message dialogs.
      (LP: #620579)
 -- Martin Pitt <email address hidden> Wed, 07 Mar 2012 14:47:31 +0100

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers