apport-cli crashed with UnicodeDecodeError in _check_files_md5(): 'ascii' codec can't decode byte 0xd0 in position 6494: ordinal not in range(128)

Bug #921037 reported by James Brierley on 2012-01-24
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Martin Pitt

Bug Description

TEST CASE:
1. In a terminal run the following command:
$ ubuntu-bug gnome-themes-ubuntu

Apport was collecting information about a bug, then crashed with this error.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: apport 1.91-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-10.17-generic 3.2.1
Uname: Linux 3.2.0-10-generic x86_64
ApportLog:

ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CrashReports:
 640:1000:1000:13636:2012-01-24 16:02:51.607811000 +0000:2012-01-24 16:02:57.103811816 +0000:/var/crash/_usr_bin_apport-cli.1000.crash
 640:1000:1000:1184353:2012-01-20 16:42:14.671801000 +0000:2012-01-20 16:42:17.423801707 +0000:/var/crash/_usr_lib_rhythmbox_rhythmbox-metadata.1000.crash
 640:1000:1000:1149878:2012-01-21 17:12:39.390222000 +0000:2012-01-21 17:12:44.674222158 +0000:/var/crash/_usr_bin_xsane.1000.crash
 600:0:0:719627:2012-01-17 19:23:55.095765000 +0000:2012-01-17 19:23:56.095765000 +0000:/var/crash/_usr_sbin_aptd.4acfa2c0a5d34f2e9f2397f79648a36c.crash
Date: Tue Jan 24 16:02:52 2012
ExecutablePath: /usr/bin/apport-cli
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/apport-cli gnome-themes-ubuntu
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 LANGUAGE=en_GB:en
PythonArgs: ['/usr/bin/apport-cli', 'gnome-themes-ubuntu']
SourcePackage: apport
Title: apport-cli crashed with UnicodeDecodeError in _check_files_md5(): 'ascii' codec can't decode byte 0xd0 in position 6494: ordinal not in range(128)
UpgradeStatus: Upgraded to precise on 2012-01-20 (3 days ago)
UserGroups: adm admin audio dialout floppy fuse lpadmin plugdev sambashare saned src staff video

James Brierley (jmb8710) wrote :
tags: removed: need-duplicate-check
Jean-Baptiste Lallement (jibel) wrote :

Confirmed with ubuntu-bug gnome-themes-ubuntu

visibility: private → public
Changed in apport (Ubuntu):
importance: Undecided → High
status: New → Triaged
description: updated
Christian Lins (cli) wrote :

$ apport-bug boinc-app-seti
Traceback (most recent call last):
  File "/usr/share/apport/apport-gtk", line 494, in <module>
    app.run_argv()
  File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 566, in run_argv
    return self.run_report_bug()
  File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 371, in run_report_bug
    self.collect_info(symptom_script)
  File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 882, in collect_info
    icthread.exc_raise()
  File "/usr/lib/python2.7/dist-packages/apport/REThread.py", line 34, in run
    self._retval = self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 74, in thread_collect_info
    report.add_package_info(package)
  File "/usr/lib/python2.7/dist-packages/apport/report.py", line 238, in add_package_info
    self._pkg_modified_suffix(dep))
  File "/usr/lib/python2.7/dist-packages/apport/report.py", line 180, in _pkg_modified_suffix
    mod = packaging.get_modified_files(package)
  File "/usr/lib/python2.7/dist-packages/apport/packaging_impl.py", line 198, in get_modified_files
    return self._check_files_md5(sums)
  File "/usr/lib/python2.7/dist-packages/apport/packaging_impl.py", line 589, in _check_files_md5
    out = m.communicate(sumfile.encode())[0].decode()
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 479: ordinal not in range(128)

Martin Pitt (pitti) wrote :

Fixed in trunk r2222.

Changed in apport (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.94.1-0ubuntu1

---------------
apport (1.94.1-0ubuntu1) precise; urgency=low

  * New upstream bug fix release. Changes since our previous snapshot:
    - apport-cli: Consistently handle unicode vs. byte arrays. (LP: #946207)
    - report.py, anonymize(): Fix crash when the hostname or user name contain
      non-ASCII characters. (LP: #945230)
    - packaging-apt-dpkg.py: Fix UnicodeDecodeError on unexpected md5sum output.
      (LP: #921037)
    - apport-gtk: Fix handling of non-ASCII strings in message dialogs.
      (LP: #620579)
 -- Martin Pitt <email address hidden> Wed, 07 Mar 2012 14:47:31 +0100

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers